Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Sep 22, 2011
Messages
1,529
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@rafale77, @mamomamo I use the same BCM94360NG in my laptop (running Big Sur) and I don't have any problems. My card is natively recognized by macOS with no kexts and no config.plist customization. I have seen reports that some have seen improvement with the use of AirportBrcmFixup.kext, but I'm not sure what improvements there could be. I have also seen reports that some see reduced 802.11ac performance, but I haven't tested 802.11ac with an 802.11ac capable access point.

If the antenna cables are properly connected and the cables/antennae are good, it should just work. The antenna cables are coaxial, so they cannot have any sharp bends in them and they cannot be crushed anywhere.

EDIT: @mamomamo I think you need to install Windows 10 (or 11) to see if Bluetooth works in Windows. I don't have any other ideas if you think your antennae are installed correctly. See this thread which seems to indicate that some people had issues with bluetooth. If bluetooth doesn't work under Windows, then at least you know its not a macOS configuration issue.
 
Last edited:
Joined
Jan 7, 2016
Messages
216
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
The card being recognized doesn't mean that it won't have any problem... I went through a number of cards and was very OCD about making BT work 100% for everything. In particular I struggled for some time with the watch unlock. There are variations in the BT firmware for various cards and non Apple cards need to have their FW injected using a kext in order for them to fully work with MacOS... maybe. As I said, I gave up and ended up just using the apple card.
 
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
I have fiddled with the "posteriore" (rear) antenna replacement on a couple of units, they are routed under the motherboard with very little room to play with and require taking out the motherboard. It is very fragile is often broken on used units. It is definitely a source of BT issues as I found out with a variety of continuity feature requiring BT. WIFI will also be slower but at least will not stop working if you are missing an antenna.

Also are you injecting the BT firmware (sorry maybe I should look up your EFI). BT implementation is a little complicated on the hacks. If you are not using a native apple wifi/BT card, there is a chance that you will need to inject the BT firmware into the card using a kext. I got tired of noodling with this solution and ended up getting a used apple card and added an adapter and never looked back. It now behaves exactly like a mac.

See my post here: https://www.tonymacx86.com/threads/...ni8-1-hackintosh-opencore.306132/post-2252481
Hello my card is a BCM94360ng ngff which should be "like" native apple (https://www.ebay.it/itm/174224694910) I am sending you the picture of how the pc sees the bluetooth which, among other things, this morning does not it connects to nothing anymore, I also send you my EFI if you want to have a look but, alternatively if I can't get this card to work in bluetooth I would like to test (if it's not too expensive) your system, if you could send me the links of the material to buy I would be grateful.
I'm also looking for a 35cm antenna cable to wire precisely (without crossing the motherboard from below), making the obligatory path that hp has decided for the rear antenna but I can't find it. Thanks for all the help you can give me, have a nice day
 

Attachments

  • EFI.zip
    6.2 MB · Views: 17
  • Schermata 2022-03-02 alle 09.00.59.png
    Schermata 2022-03-02 alle 09.00.59.png
    246.2 KB · Views: 23
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
@rafale77, @mamomamo I use the same BCM94360NG in my laptop (running Big Sur) and I don't have any problems. My card is natively recognized by macOS with no kexts and no config.plist customization. I have seen reports that some have seen improvement with the use of AirportBrcmFixup.kext, but I'm not sure what improvements there could be. I have also seen reports that some see reduced 802.11ac performance, but I haven't tested 802.11ac with an 802.11ac capable access point.

If the antenna cables are properly connected and the cables/antennae are good, it should just work. The antenna cables are coaxial, so they cannot have any sharp bends in them and they cannot be crushed anywhere.

EDIT: @mamomamo I think you need to install Windows 10 (or 11) to see if Bluetooth works in Windows. I don't have any other ideas if you think your antennae are installed correctly. See this thread which seems to indicate that some people had issues with bluetooth. If bluetooth doesn't work under Windows, then at least you know its not a macOS configuration issue.
Hello, if by 802.11ac you mean the 5GHz wifi band, I am satisfied, it goes exactly as the intel goes before the card change, instead I noticed a significant slowdown in the 2.4GHz band which seems much less efficient than the intel card, I send you the screenshots of this morning of the 2 bands, consider that I have a contract of 100mb in download and 20 in upload. Yes, I should install windows to test bluetooth but, I'm not very experienced and I wouldn't want to mess with it, I think I should unmount the nvme disk and try to install it on a normal disk or ssd in order not to ruin the current configuration
 

Attachments

  • Schermata 2022-03-02 alle 09.22.42.png
    Schermata 2022-03-02 alle 09.22.42.png
    114 KB · Views: 17
  • Schermata 2022-03-02 alle 09.25.18.png
    Schermata 2022-03-02 alle 09.25.18.png
    106.7 KB · Views: 17
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
@rafale77, @mamomamo I use the same BCM94360NG in my laptop (running Big Sur) and I don't have any problems. My card is natively recognized by macOS with no kexts and no config.plist customization. I have seen reports that some have seen improvement with the use of AirportBrcmFixup.kext, but I'm not sure what improvements there could be. I have also seen reports that some see reduced 802.11ac performance, but I haven't tested 802.11ac with an 802.11ac capable access point.

If the antenna cables are properly connected and the cables/antennae are good, it should just work. The antenna cables are coaxial, so they cannot have any sharp bends in them and they cannot be crushed anywhere.

EDIT: @mamomamo I think you need to install Windows 10 (or 11) to see if Bluetooth works in Windows. I don't have any other ideas if you think your antennae are installed correctly. See this thread which seems to indicate that some people had issues with bluetooth. If bluetooth doesn't work under Windows, then at least you know its not a macOS configuration issue.
Hi, I have installed Windows 11, during the installation the wifi card is not recognized, inserted LAN and made all the updates and, it is not recognized, then I found the site from where to download the drives and, everything started, both wifi and bluetooth, everything works perfectly, no more "stammering" on audio streaming and, good distance for stable connection so I would say that it is not a hardware problem but a configuration problem with MacOs, I leave the link (if it can be useful) for the draiver of the fenvi cards (https://fenvi.com/drive.html?id=2) and insert photos before and after drive installation.
He also updated the bios to version-02.12.00 which seems to be fine for the little I am trying it, if I notice something abnormal I will report it, have a nice day
 

Attachments

  • photo_2022-03-02_11-53-29.jpg
    photo_2022-03-02_11-53-29.jpg
    204.2 KB · Views: 23
  • photo_2022-03-02_11-53-30 (2).jpg
    photo_2022-03-02_11-53-30 (2).jpg
    107.1 KB · Views: 21
  • photo_2022-03-02_11-53-30 (3).jpg
    photo_2022-03-02_11-53-30 (3).jpg
    205.7 KB · Views: 22
Joined
Sep 22, 2011
Messages
1,529
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@mamomamo By installing Windows, you have confirmed that your BCM94360NG is working properly, so I agree that this is a macOS problem and not an antenna or hardware problem. I don't see anything wrong with your EFI. I would recommend that you re-install Big Sur and test Bluetooth again.
 
Joined
Jan 7, 2016
Messages
216
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Given the high number of people reporting audio issues on various config using the same card, I think @deeveedee is right. I believe your card, the BCM94360NG is not fully supported by MacOS which was also my experience using a very similar Dell version of that card. See below what my info screen shows with Monterey:

Screen Shot 2022-03-02 at 07.48.40.png
 
Last edited:
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
@mamomamo By installing Windows, you have confirmed that your BCM94360NG is working properly, so I agree that this is a macOS problem and not an antenna or hardware problem. I don't see anything wrong with your EFI. I would recommend that you re-install Big Sur and test Bluetooth again.
Yes, I also think that to understand I have to start with a clean installation, perhaps over the months it has brought with it some configuration that conflicts with the new card, I don't think I will do it immediately but, as soon as I decide I will let you know how it went , thanks for all the help and have a nice day
 
Joined
Oct 22, 2020
Messages
42
Motherboard
Lenovo M93P
CPU
Intel Core i5-4590 e i7-4765t
Graphics
Intel HD Graphics 4600 1536 MB
Given the high number of people reporting audio issues on various config using the same card, I think @deeveedee is right. I believe the your card, the BCM94360NG is not fully supported by MacOS which was also my experience using a very similar Dell version of that card. See below what my info screen shows with Monterey:

View attachment 543064
I try to re-install BigSur (I'm terrified to update in Monterey: o)) again to take away any qualms then, I'm open to new possibilities to make it work better, in that regard if you wanted to send me links of what I would need to adopt your solution I would be grateful, thanks for your help have a nice day
 
Joined
Jan 7, 2016
Messages
216
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This adapter is for an SSD NGFF and will occupy an SSD location. I can't seem to find the 180deg adapter I am using which would work on the dedicated WIFI port.
 
Top