Contribute
Register

The Perfect Customac-Pro: X99-A II, i7-6950X, 128GB G.Skill TridentZ, Aorus GTX 1080 TI Xtreme

Status
Not open for further replies.
Joined
Apr 28, 2011
Messages
913
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
RX 6600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Sure Here is mine. It is a Titan X in in slot 16_1 though. I successfully boot with Display port 1, HDMI, and Display port 4. I have not tried to figure out why I can not boot with DVI and Display port 3 in the combination. The only other combination I remember working was DVI and HDMI, but that was before I got a batch of display port to DVI adapters.

Kevin
Thanks, I see some kind of differences (besides the obvious GFX1 and BR3A for the PCIe location). I'd like to give it a try. Do you have audio via HDMI or DP? where did you find the SSDT.aml? Or did you create it on your own?
 
Joined
Apr 29, 2011
Messages
90
Motherboard
Asus PRIME X299-A
CPU
i7-7820X
Graphics
RX 6800 XT
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
delete from the CLOVER\Kexts\10.12, the realtekALC.kext file, plus, from config.plist, delete all the AppleHDA patches and the AppleHDAController one from Kernel and Kext Patches/KextToPatch, then rebuild cache, reboot (no audio, of course) and run toleda's script again. It should work as expected

Thanks man! :clap: I have audio on HDMI now! I still don't have audio on the motherboard lineouts but I have a USB audio dec so I use that one :)

Only one thing left, bios flash. If I do, I will loose guarantee, won't it? I am currently on untouched 1401.
 
Joined
Nov 17, 2010
Messages
168
Motherboard
Asus X-99 A II
CPU
i7-6900K
Graphics
Titan X Maxwell
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks, I see some kind of differences (besides the obvious GFX1 and BR3A for the PCIe location). I'd like to give it a try. Do you have audio via HDMI or DP? where did you find the SSDT.aml? Or did you create it on your own?
This was created using help from Shiloh, which he then used to rewrite parts of the guide. If you read on through that guide you will see us discussing these things, and his solutions. Since my initial help from him I have renamed the slot to make it show up correctly. I do have Audio Via HDMI, but I do not use it, as I also have a blackmagic card installed.

Kevin
 
Joined
Apr 28, 2011
Messages
913
Motherboard
Asus Prime Z690M-Plus D4
CPU
i7-12700KF
Graphics
RX 6600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This was created using help from Shiloh, which he then used to rewrite parts of the guide. If you read on through that guide you will see us discussing these things, and his solutions. Since my initial help from him I have renamed the slot to make it show up correctly. I do have Audio Via HDMI, but I do not use it, as I also have a blackmagic card installed.

Kevin
Very valuable info. Thank you, Kevin
 

kgp

Retired
Joined
May 30, 2014
Messages
6,765
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
:idea: Basic I7-6950X Power Management Guide finished - no sleep/wake yet :idea:


Today, I finished a first basic i7-6950X Power Management Guide that is added towards the end of my originating post. Sleep/wake issues still remain at present (immediate reboot when sent to sleep). I encourage only experienced users to work with this last part of my guide, which yet underlies further development. However, hopefully this basic power management guide is a first attempt in the right direction and I am looking forward to fruitful discussions, extensive feedback and constructive input from experts in the field.
 
Joined
Mar 27, 2016
Messages
57
Motherboard
AsRock X99 Extreme 4
CPU
5820k
Graphics
GTX 980ti
Mac
Classic Mac
Mobile Phone
Did you figure out why you weren't getting vectors loaded? It seems that you've updated your guide to say you're no longer having a problem with them. Btw, what's weird with me is I have the same patches as you in the kerneltopatch section and yeah X86platformplugin is still not loading. I don't know why.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,765
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Did you figure out why you weren't getting vectors loaded? It seems that you've updated your guide to say you're no longer having a problem with them. Btw, what's weird with me is I have the same patches as you in the kerneltopatch section and yeah X86platformplugin is still not loading. I don't know why.

Yes, the freqvectors are loaded now! Solved also many other open issues in the same step. However, further fruitful comments and suggestions concerning optimizations are highly welcome and also needed! E.g., the sleep/wake issue is still without solution (immediate reboot when send to sleep). However, I hope that my first basic guide will also help you to get rid of most of your problems. Don't hesitate to ask in case of open questions.

Cheers
 
Joined
Mar 27, 2016
Messages
57
Motherboard
AsRock X99 Extreme 4
CPU
5820k
Graphics
GTX 980ti
Mac
Classic Mac
Mobile Phone
Yes, the freqvectors are loaded now! Solved also many other open issues in the same step. However, further fruitful comments and suggestions concerning optimizations are highly welcome and also needed! E.g., the sleep/wake issue is still without solution (immediate reboot when send to sleep). However, I hope that my first basic guide will also help you to get rid of most of your problems. Don't hesitate to ask in case of open questions.

Cheers
Well don't keep us waiting, how did you do it!
 

kgp

Retired
Joined
May 30, 2014
Messages
6,765
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Well don't keep us waiting, how did you do it!

:lol: Well just have a look to the current state of my guide :lol: and ask and suggest what ever you want :thumbup:
 

kgp

Retired
Joined
May 30, 2014
Messages
6,765
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Yes your right kgp! I was using your guide but for some point it didn't worked to me and i started to mix with
giacomoleopardo's guide...

I would like to use HDMI audio, so thats why I want to use your script but it just stops here:

Last login: Fri Mar 24 10:19:49 on ttys000

Mac-Pro-di-Attila:~ bagi1992$ /Users/bagi1992/Downloads/audio_cloverALC-120_v1.0f.command ; exit;


Agreement

The audio_cloverALC script is for personal use only. Do not distribute

the patch, any or all of the files or the resulting patched AppleHDA.kext

for any reason without permission. The audio_cloverALC script is

provided as is and without any kind of warranty.


File: audio_cloverALC-120.command_v1.0f

Release Mode

Password:

EFI partition is mounted

System Integrity Protection status: disabled.


OK to patch

Confirm Realtek ALC1150 (y/n): y

Clover Audio ID Injection (y/n): y

Use Audio ID: 1 (y/n): y


Download ALC1150 files ...

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 23555 100 23555 0 0 49727 0 --:--:-- --:--:-- --:--:-- 49694

Edit config.plist/Devices/Audio/Inject/1

Edit config.plist/SystemParameters/InjectKexts/YES

Download kext patches

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 1838 100 1838 0 0 7084 0 --:--:-- --:--:-- --:--:-- 7096


And thats it, doesn't complite. :/ Any idea?


I am happy that giacomoleopardo already solved your problem. :thumbup: In my built I do not need any previous or subsequent fixes to installation. CloverALC and HDMI install and run without further interactions or problems. Sorry for not responding earlier, I was totally busy with the power management today... :crazy:
 
Status
Not open for further replies.
Top