Contribute
Register

i7-4930K - Asus Rampage IV Extreme - 32GB RAM - GTX 770 4GB [Success!!]

Joined
Sep 27, 2017
Messages
20
Motherboard
Asus Rampage IV Extreme
CPU
i7-3930K
Graphics
RX 580
Mac
  1. iMac
Hum... no luck so far. Noob at Catalina and APFS partitions.
From High Sierra I get 2 Catalina drives mounting, Catalina, and Catalina - data.
On which drive/EFI partition do I install Clover and drivers, kexts and all?

View attachment 500321
Hi,
I suggest you go directly to Big Sur and OpenCore. with the EFI of d_prihantoro you should have no problem installing Big Sur.
 
Joined
Jan 7, 2014
Messages
39
Motherboard
Z490-A Prime
CPU
i9-10850k
Graphics
MSI RX 6800 xt Trio
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Thanks for your help! I was able to get the latest Catalina working fine. Except for one thing:
One of my 2 displays stays black after display sleep, never comes back so I have to reboot.
Can't find any solutions for it...
 
Joined
Mar 1, 2014
Messages
131
Motherboard
Rampage IV Extreme X79
CPU
i7-4930K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Hello people,

I recently started learning some python and decided to create something that I would have use for. So I came up with a little script that will gather all the latest files needed for this build. ACPI, kexts and bootloaders. This guide is a little outdated as of now, as support for NVIDIA cards is more or less gone.

Feel free to use the script whenever you need to update or rebuild your system.
However, I still recommend using this guide as reference if you're not really certain where to install all the files.

https://github.com/fbongcam/shilohh_hackintosh

Let me know if you think something is missing!
 
Joined
Mar 13, 2020
Messages
7
Motherboard
Asus Rampage IV Extreme
CPU
Xeon E5-2680v2
Graphics
RX 480
Mac
  1. Mac Pro
hi,
thanks to xerox24 for your help and your efi folder of your system, big sur + oc 0.64 SUCCESS on R4E, I7-3930k, RX580 and all work. For boot the installation of big sur is necessary use the kernel patch ( ACPI section of OC config.plist) that work only on OpenCore 0.6.0+ and NOT on Clover for moment:

Name: UNC0 _HID to XHID
Find: 554E43 30085F48 4944
Replace: 554E43 30085848 4944

My EFI folder with Opencore 0.6.4 - 3 dec 2020 ( the .plist is in verbose mode with ACPI patch for x79 ( thanks to xerox 24 for your efi folder and help ).

I don't know how to thank you, I have got a very similar configuration, but I have GTX 960 instead of your RX, I removed the RX aml and the AMD booster kext both from folders and plist.
The installer boot correctly but after some time on the recovery page (no matter if I choose TimeMachine, Install, Safari or Disk Utility) it freeze and goes with kernel panic.
Could you please help me?
Thank you again,
E
 

Attachments

  • panic-2021-01-30-223857.txt
    7.6 KB · Views: 19
Joined
Mar 13, 2020
Messages
7
Motherboard
Asus Rampage IV Extreme
CPU
Xeon E5-2680v2
Graphics
RX 480
Mac
  1. Mac Pro
I don't know how to thank you, I have got a very similar configuration, but I have GTX 960 instead of your RX, I removed the RX aml and the AMD booster kext both from folders and plist.
The installer boot correctly but after some time on the recovery page (no matter if I choose TimeMachine, Install, Safari or Disk Utility) it freeze and goes with kernel panic.
Could you please help me?
Thank you again,
E
Hi, I just wanted to say I solved the problem, for everyone dealing with that problem it is common on OpenCore troubleshooting.
All I needed was just to enable DummyPowerManagement under Kernel/Emulate in config.plist.
 
Joined
Feb 5, 2021
Messages
20
Motherboard
ASUS Rampage IV Extreme X79
CPU
i7-4930K
Graphics
GTX 770
Hey guys

I am coming back to update my build (copy of Shilohh's here with R4E, 4930k and GTX 770)
I'm pretty rusty as it was long ago and i just followed Shilohh's Clover guide.

I was going to do OpenCore and Big Sur. But, reading the guide, it seems a bit out of my depth. Can you share any tips for doing that with this build? If I just copy d_prihantoro's EFI, will it work?

I’m making my USB Installer on my Macintosh. So it will take out internal SSD and install new one for the install. So I want to make sure I have approached the USB installer properly before swapping the SSDs!

Thank you for any help, and apologies for nooby question.
 
Joined
Jan 10, 2012
Messages
9
Motherboard
Asus Rampage IV Black Edition
CPU
Xeon E5-2640 v2
Graphics
Titan Black
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Hey guys

I am coming back to update my build (copy of Shilohh's here with R4E, 4930k and GTX 770)
I'm pretty rusty as it was long ago and i just followed Shilohh's Clover guide.

I was going to do OpenCore and Big Sur. But, reading the guide, it seems a bit out of my depth. Can you share any tips for doing that with this build? If I just copy d_prihantoro's EFI, will it work?

I’m making my USB Installer on my Macintosh. So it will take out internal SSD and install new one for the install. So I want to make sure I have approached the USB installer properly before swapping the SSDs!

Thank you for any help, and apologies for nooby question.
Hi,
Actually, I no longer use OpenCore.
I found that Clover is able to to boot and install Big Sur as well or even better (in my opinion) than OpenCore.
I am now using Clover Release v5.1 r5129.
Works like a charm.
 
Joined
Feb 5, 2021
Messages
20
Motherboard
ASUS Rampage IV Extreme X79
CPU
i7-4930K
Graphics
GTX 770
Thankyou! Will give it a shot!
 
Joined
Mar 13, 2020
Messages
7
Motherboard
Asus Rampage IV Extreme
CPU
Xeon E5-2680v2
Graphics
RX 480
Mac
  1. Mac Pro
Hi,
Actually, I no longer use OpenCore.
I found that Clover is able to to boot and install Big Sur as well or even better (in my opinion) than OpenCore.
I am now using Clover Release v5.1 r5129.
Works like a charm.
Hi,
Did you make a clean install or did you switch from OC to Clover?
Could you please explain the steps?
Did you manage to let USB 3 work?
And last but not least: with OC I've been able to update to 11.2.1 without problems, does Clover support the last update?
Sorry for so many questions :D
Thank you in advance
RN
 
Joined
Jan 10, 2012
Messages
9
Motherboard
Asus Rampage IV Black Edition
CPU
Xeon E5-2640 v2
Graphics
Titan Black
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
Hi,
Did you make a clean install or did you switch from OC to Clover?
Could you please explain the steps?
Did you manage to let USB 3 work?
And last but not least: with OC I've been able to update to 11.2.1 without problems, does Clover support the last update?
Sorry for so many questions :D
Thank you in advance
RN
Hi,
I installed 11.2 using OC, then I switched to Clover.
Few days later, when 11.2.1 was released, I updated to 11.2.1 with Clover bootloader successfully.
Unfortunately, I have never been able to make USB 3 to work for a while.
Fortunately, I managed to get my WiFi to work.

Edit: One thing I should point out though, on Clover Boot Screen, always select 'Preboot' partition to boot.
 
Last edited:
Top