Contribute
Register

i7-4930K - Asus Rampage IV Extreme - 32GB RAM - GTX 770 4GB [Success!!]

Joined
Jan 24, 2013
Messages
10
Motherboard
MSI Z77A-G45 Thunderbolt
CPU
i5-3570K @ 4.2 Ghz
Graphics
GTX 1070 Ti
Hello all! First off, let me say this is a wonderful guide and I appreciate all the work that went into this!

I would love some help with troubleshooting. I have a friend who has the Rampage IV Extreme Motherboard on the newest BIOS. We followed this guide to the "T" when upgrading him to Seirra (10.12.6). Everything is working quite well except for his graphics card. He has an Nvidia EVGA GTX 1080 Ti. The computer has no trouble with Multi Monitor DVI resolution at 1080. However, he owns two SW27i BenQ monitors. The max resolution on both those monitors are 4K. The computer will boot great with one in the display port, and the other unplugged. Then once he is past the login screen, he can connect the other one into another display port. If he doesn't follow this technique, the monitors are not recognized and his computer falls into the "black screen" issue discussed in this thread. The only way to get it working again is to reset the NVRAM in single user mode. We've tried installing the NVDIA fix app included in the post files. Unfortunately, this has had no effect.

Is this an issue with NVRAM not working properly? Has anyone else had this issue?

Any help is extremely appreciated. :)
 
Joined
Mar 28, 2012
Messages
2
Motherboard
Rampage IV Extreme 4901
CPU
i7 3930k
Graphics
GTX 980
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
Hi, @shilohh!
Long time lurker´s first post...
So, I've been following this guide and successfully installed Sierra 10.12.6 on my system(yey!! Thank you:headbang:), but couldn't make SpeedStep work.
I've tried everything, every guide, I've extracted my own SSDT. Followed the guide to the T.
My CPU stays idle @1.2MHz and I'm starting to feel desperate. There is no way this thing is working.
Geekbench gives me 1293-6668
Can someone help me please? I can provide any info and files required.
Thank you in advance.
Cheers
 

Attachments

Last edited:
Joined
Sep 27, 2017
Messages
6
Bumb

Mojave anyone?

If anyone has done the upgrade, have you stumbled on to any problems?
Found any solutions if so?
I have update to Mojave without problem with my build ( R4E +i7-4930+ ASUS RX 580 + 16GB corsair). I use the X79 liked in this good guide. I was looking for an optimization of the conf.plist for patch 10.12 of conf.plist present on this guide

PS. toleda script for audio not work with Mojave for this i use the guide present on Mojave desktop support for ability audio on Mojave.
 
Joined
Feb 4, 2017
Messages
4
Motherboard
Asus Rampage IV Extreme
CPU
I7-3960X
Graphics
GTX 770
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
HELP!
Code:
Anonymous UUID:       487034BD-0104-3CD6-AB56-897D98B96F09

Mon Oct  8 09:03:28 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff8003e272f2): "USB3.0 Hub[0x10000046e]::terminate(kIOServiceSynchronous) timeout\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4903.201.2/iokit/Kernel/IOService.cpp:2333
Backtrace (CPU 0), Frame : Return Address
0xffffff81f2b93950 : 0xffffff80037aca1d
0xffffff81f2b939a0 : 0xffffff80038e6b13
0xffffff81f2b939e0 : 0xffffff80038d859a
0xffffff81f2b93a50 : 0xffffff8003759ca0
0xffffff81f2b93a70 : 0xffffff80037ac437
0xffffff81f2b93b90 : 0xffffff80037ac283
0xffffff81f2b93c00 : 0xffffff8003e272f2
0xffffff81f2b93c60 : 0xffffff8003e2adfd
0xffffff81f2b93ce0 : 0xffffff7f843af776
0xffffff81f2b93d00 : 0xffffff7f863a5ee3
0xffffff81f2b93d40 : 0xffffff7f863a58bf
0xffffff81f2b93da0 : 0xffffff7f8639adbb
0xffffff81f2b93de0 : 0xffffff7f8639db81
0xffffff81f2b93e30 : 0xffffff8003e39918
0xffffff81f2b93ea0 : 0xffffff8003e396ca
0xffffff81f2b93ec0 : 0xffffff80037e8865
0xffffff81f2b93f40 : 0xffffff80037e8415
0xffffff81f2b93fa0 : 0xffffff80037590ce
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBFamily(900.4.2)[B3A7BE9C-2002-3891-B7D1-A84CEA0AC9E0]@0xffffff7f84372000->0xffffff7f8440cfff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[2CE7BCB3-0766-3A94-A8D4-29BF3EBAEFBC]@0xffffff7f84095000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[ED37A531-57CD-313C-B164-BC0F33B09D35]@0xffffff7f842f0000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[7F32C612-AC3B-333C-9067-5EAB39CF6EC3]@0xffffff7f842e8000
         com.apple.driver.AppleUSBLegacyHub(900.4.2)[E3885C3A-7A62-3AF4-A1C5-93424708182F]@0xffffff7f86398000->0xffffff7f863b0fff
            dependency: com.apple.iokit.IOUSBFamily(900.4.2)[B3A7BE9C-2002-3891-B7D1-A84CEA0AC9E0]@0xffffff7f84372000

BSD process name corresponding to current thread: kernel_task
Boot args: npci=0x2000 darkwake=00

Mac OS version:
18A391

Kernel version:
Darwin Kernel Version 18.0.0: Wed Aug 22 20:13:40 PDT 2018; root:xnu-4903.201.2~1/RELEASE_X86_64
Kernel UUID: DF83AD37-501E-3B4F-B1F0-04F3AC90FE35
Kernel slide:     0x0000000003400000
Kernel text base: 0xffffff8003600000
__HIB  text base: 0xffffff8003500000
System model name: iMac14,2 (Mac-27ADBB7B4CEE8E61)

System uptime in nanoseconds: 1102312142580
last loaded kext at 196853771533: com.apple.filesystems.msdosfs    1.10 (addr 0xffffff7f84ec2000, size 69632)
last unloaded kext at 701576634120: com.insanelymac.driver.AppleIntelE1000e    2.4.14 (addr 0xffffff7f87183000, size 102400)
loaded kexts:
org.hwsensors.driver.GPUSensors    1787
org.hwsensors.driver.LPCSensors    1787
org.hwsensors.driver.CPUSensors    1787
net.osx86.kexts.GenericUSBXHCI    1.2.11
com.insanelymac.IntelMausiEthernet    2.4.0
org.emlydinesh.driver.EAPDFix    2.3
as.vit9696.AppleALC    1.3.0
as.vit9696.Lilu    1.2.5
com.rehabman.driver.USBInjectAll    0.6.5
org.netkas.driver.FakeSMC    1787
org.tgwbd.driver.NullCPUPowerManagement    1.0.0d2
com.apple.filesystems.msdosfs    1.10
com.apple.filesystems.smbfs    3.3
com.apple.fileutil    1
com.apple.driver.AudioAUUC    1.70
com.apple.filesystems.autofs    3.0
com.apple.driver.ApplePlatformEnabler    2.7.0d0
com.apple.driver.AGPM    110.23.41
com.apple.driver.X86PlatformShim    1.0.0
com.apple.filesystems.ntfs    3.13
com.apple.AGDCPluginDisplayMetrics    3.22.9
com.apple.driver.AppleUpstreamUserClient    3.6.5
com.apple.driver.AppleHDA    282.10
com.apple.driver.AppleMCCSControl    1.5.7
com.apple.driver.AppleHV    1
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.GeForce    12.0.0
com.apple.iokit.IOBluetoothSerialManager    6.0.8f6
com.apple.driver.pmtelemetry    1
com.apple.driver.eficheck    1
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleLPC    3.1
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.driver.AppleOSXWatchdog    1
com.apple.filesystems.hfs.kext    407.200.4
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.BootCache    40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.AppleSystemPolicy    1.0
com.apple.driver.AppleUSBLegacyHub    900.4.2
com.apple.filesystems.apfs    945.200.129
com.apple.driver.AirPort.BrcmNIC    1400.1.1
com.apple.driver.AppleAHCIPort    329.200.2
com.apple.driver.AppleHPET    1.8
com.apple.driver.AppleACPIButtons    6.1
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    190
com.apple.security.TMSafetyNet    8
com.apple.driver.AppleIntelCPUPowerManagement    220.0.0
com.apple.kext.triggers    1.0
com.apple.driver.DspFuncLib    282.10
com.apple.kext.OSvKernDSPLib    527
com.apple.iokit.IOAVBFamily    700.6
com.apple.plugin.IOgPTPPlugin    700.7
com.apple.iokit.IOEthernetAVBController    1.1.0
com.apple.driver.AppleSMBusController    1.0.18d1
com.apple.nvidia.driver.NVDAGK100Hal    12.0.0
com.apple.iokit.IOAcceleratorFamily2    400.24
com.apple.nvidia.driver.NVDAResman    12.0.0
com.apple.driver.AppleSSE    1.0
com.apple.iokit.IOSurface    255.1
com.apple.iokit.IOSerialFamily    11
com.apple.iokit.IONDRVSupport    530
com.apple.driver.AppleHDAController    282.10
com.apple.iokit.IOHDAFamily    282.10
com.apple.AppleGPUWrangler    3.22.9
com.apple.AppleGraphicsDeviceControl    3.22.18
com.apple.iokit.IOGraphicsFamily    530.9
com.apple.driver.X86PlatformPlugin    1.0.0
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport    6.0.8f6
com.apple.iokit.IOBluetoothHostControllerUSBTransport    6.0.8f6
com.apple.iokit.IOBluetoothHostControllerTransport    6.0.8f6
com.apple.iokit.IOBluetoothFamily    6.0.8f6
com.apple.driver.usb.IOUSBHostHIDDevice    1.2
com.apple.iokit.IOAudioFamily    206.5
com.apple.vecLib.kext    1.2.0
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.usb.AppleUSBHub    1.2
com.apple.filesystems.hfs.encodings.kext    1
com.apple.iokit.IOAHCIBlockStorage    301.200.2
com.apple.iokit.IO80211Family    1200.12.2
com.apple.driver.mDNSOffloadUserClient    1.0.1b8
com.apple.driver.corecapture    1.0.4
com.apple.iokit.IOAHCIFamily    288
com.apple.driver.usb.AppleUSBEHCIPCI    1.2
com.apple.driver.usb.AppleUSBEHCI    1.2
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IOUSBFamily    900.4.2
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.driver.AppleUSBHostMergeProperties    1.2
com.apple.iokit.IOSMBusFamily    1.1
com.apple.security.quarantine    3
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.driver.DiskImages    493.0.0
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleEffaceableStorage    1.0
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleUSBTDM    456.200.8
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.kext.CoreTrust    1
com.apple.iokit.IOUSBMassStorageDriver    145.200.2
com.apple.iokit.IOSCSIBlockCommandsDevice    408.200.1
com.apple.iokit.IOSCSIArchitectureModelFamily    408.200.1
com.apple.iokit.IOStorageFamily    2.1
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.2
com.apple.driver.usb.AppleUSBCommon    1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor    1
com.apple.iokit.IOTimeSyncFamily    700.7
com.apple.iokit.IONetworkingFamily    3.4
com.apple.iokit.IOReportFamily    47
com.apple.driver.AppleACPIPlatform    6.1
com.apple.driver.AppleSMC    3.1.9
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread    1
com.apple.kec.Libm    1
com.apple.kec.corecrypto    1.0

EOF
Model: iMac14,2, BootROM IM142.0130.B00, 6 processors, 6-Core Intel Xeon E5, 3.3 GHz, 16 GB, SMC 2.15f7
Graphics: NVIDIA GeForce GTX 770, NVIDIA GeForce GTX 770, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 2400 MHz, Kingston, KHX2400C11D3/8GX
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 2400 MHz, Kingston, KHX2400C11D3/8GX
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x111), Broadcom BCM43xx 1.0 (7.77.61.1 AirPortDriverBrcmNIC-1305.2)
Bluetooth: Version 6.0.8f6, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Wi-Fi, AirPort, en1
PCI Card: NVIDIA GeForce GTX 770, Display Controller, PCI Slot 1
Serial ATA Device: SanDisk SD6SN1M-256G-1006, 256.06 GB
Serial ATA Device: TOSHIBA Q300., 240.06 GB
Serial ATA Device: KINGSTON SUV400S37120G, 120.03 GB
Serial ATA Device: WDC WD10EZEX-00WN4A0, 1 TB
Serial ATA Device: ST1000LM024 HN-M101MBB, 1 TB
Serial ATA Device: WDC WD30EZRZ-00Z5HB0, 3 TB
Serial ATA Device: WDC WD30EZRZ-00Z5HB0, 3 TB
Serial ATA Device: WDC WD5000AACS-00ZUB0, 500.11 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Composite Device
USB Device: G700s Rechargeable Gaming Mouse
Thunderbolt Bus:
 
Joined
Jul 26, 2011
Messages
64
Motherboard
unBranded X79 - Clover
CPU
i7-3960X
Graphics
R9 280x/1920x1200
Mac
Mac Pro
Mobile Phone
Other
@shilohh
my Rampage IVE board fizzled out decided not to boot anymore not sure why, was perfect under your guide, now I have a Chines unbranded X79 board seems to be close to it at fraction of price ,runs Yosemite out of box like R4E.Had issue with boot up with HighSierra had to edit I deleted Device(SCK0) to Device(SCK3)
Finally after modifying, all Processor locate directly inside _SB instead of _SB.SCKN.
Hope you guys with X79 motherboard can solve this problem .Now I cannot shutdown it only reboots.Not sure where it is the point to cause this ,maybe my usb edits I used clover to change EHC1 to ENC01 45484331 in clover there is drop down with total of 4 edits I selected all, 4th was USBE to EH02 in list of patches. along with injectALL kext solved my usb problems.
everything seems ok have not tried Sleep but no biggie Just would like it to shut down. I wanted to try SSDT edits but not sure
where to edit.I played with ticking SSDT settlings in clover at no avail.
best,
Drone4zone
 
Joined
Feb 4, 2017
Messages
4
Motherboard
Asus Rampage IV Extreme
CPU
I7-3960X
Graphics
GTX 770
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Hello! I use i7-3960x +R4E! According to your tutorial Settings, the machine works fine! But there is a legacy issue Cannot overpass frequency, can only switch back and forth between 1200M-3300M! Is there any way to correct it?
I've tried regenerating the SSDT from your tutorial, but the effect is the same: you can't overdrive or multiscale.
Now I upload my efi file, please check it for me!
Here is my boot.log file!

OK!I solved!

sudo perl -pi -e 's|\xFF\x0F\x84\x2D|\xFF\x0F\x85\x2D|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\x01\x00\x01\x0F\x84|\x01\x00\x01\x0F\x85|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\xC9\x74\x15\x0F\x32\x25\xFF\x0F\x00\x00\x48|\xC9\xEB\x15\x0F\x32\x25\xFF\x0F\x00\x00\x48|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\xC9\x74\x0C\x0F\x32\x83\xE0\x1F\x42\x89\x44\x3B|\xC9\xEB\x0C\x0F\x32\x83\xE0\x1F\x42\x89\x44\x3B|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\x01\x74\x61|\x01\xEB\x61|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\x3E\x75\x38|\x3E\x90\x90|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement;
sudo perl -pi -e 's|\x75\x11\xB9|\xEB\x11\xB9|g' /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement
echo "Patching AppleIntelCPUPowerManagement.kext"
sudo chown -R root:wheel /System/Library/Extensions/AppleIntelCPUPowerManagement.kext
sudo chmod -R 755 /System/Library/Extensions/AppleIntelCPUPowerManagement.kext
sudo touch /System/Library/Extensions
 

Attachments

Last edited:
Joined
Feb 5, 2011
Messages
226
Motherboard
Asus X79 Rampage IV Extreme
CPU
Core i7-3930k
Graphics
GTX 680 2GB
Mac
MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Centris, iBook, iMac, LC, Performa, Portable, Power Mac, PowerBook, Quadra, Workgroup Server
Mobile Phone
iOS
Hi again everyone!

After playing with "Dark Mode" on my MacBook, I became addicted. So I am testing 10.14 Mojave using a separate SSD drive on my trusty old 3930k Hackintosh.

It went pretty well so far. What I did:
-----------------
INITIAL INSTALLATION
-----------------
1) Since I have been on 10.12, and there is no way to get APFS support, I decided to install from my MacBook. I booted the MacBook up in recovery mode and connected the new SSD externally in a USB-3 enclosure. I formatted the disk using GUID and APFS. Then I installed 10.14. I went ahead and set up a user on first boot (still running on the MacBook).
2) I downloaded the newest Clover and installed on the external USB drive.
NOTE: Above steps could be done the usual way with a USB stick that has the apfs.efi installed; but I was lazy and had the MacBook handy.
-----------------
FIX UP CLOVER - copying files from my old working 10.12 clover EFI
-----------------
3) I mounted the EFI partition using "EFI Mounter V3" app and copied all the kexts from /EFI/Clover/kexts/10.12 to /EFI/Clover/kexts/10.14 (AppleIntelE1000e.kext, FakeSMC.kext, and realtekALC.kext).
4) I copied missing drivers:
/CLOVER/drivers64UEFI
OsxAptioFix2Drv-64.efi
OsxFatBinaryDrv-64.efi
apfs.efi <- downloaded the appropriate 10.14 version of this
5) I copied missing config files:
/CLOVER/
config.plist
/CLOVER/OEM/SystemProductName/
config.plist
/CLOVER/OEM/SystemProductName/UEFI/
config.plist
-----------------
FIRST BOOT ON HACKINTOSH
-----------------
6) At the Clover screen I booted with nv_disable=1 and also -v
7) Once booted up in low resolution, I ran shilohh's trusty AGDPfix and rebooted.

Now I am running my dual displays at full resolution with Metal support in Mojave! It has actually been very stable! Next I need to fix my audio and SpeedStep.

I didn't have any luck using the newest version of the audio script from shilohh's guide. It runs but I have no audio.

Now I have to figure out how to get the very basic SpeedStep I use running (I'm basically running 4.2Ghz without much stepping). At the moment I seem to be locked at 3.2Ghz on all cores. Unfortunately I cannot use the full power management setup shiloh uses because my particular 3930k CPU causes crashes when the speed/voltage drops too far...but is 100% stable as long as that never happens. Oh well, at least I can switch back to full speed 10.12 at any time by just swapping SSD drives.

I have been messing around with creating SSDT files; but am pretty rusty. I included my EFI partition (EFI.zip) in case anyone wants to look it over.

This won't be my main system until I can figure out these issues; but it's cool to try!


Screen Shot 2018-10-17 at 9.10.47 AM.png
NVIDIA GeForce GTX 680:



Chipset Model: NVIDIA GeForce GTX 680

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

VRAM (Dynamic, Max): 2047 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x1180

Revision ID: 0x00a2

ROM Revision: VBIOS 80.04.47.00.2e

Metal: Supported, feature set macOS GPUFamily1 v4

EDIT: Hah! Just noticed my <key>SerialNumber</key> is set to the default. I wonder how long I've been running 10.12 like that? Probably since I updated years ago :-/
 

Attachments

Last edited:
Joined
Aug 3, 2018
Messages
2
Graphics
NVIDIA 1080 FE
Hello guys
I have one question to you: I have the configuration (R4E + i7 4930 + GTX1080) that upgraded to HS recently - and sleep stopped to work (or works partially: screen goes black but motherboard/fans are still power on). Does anyone with sleep working could share config or pointing me where to debug this problem?

Regards and TIA
Pawel
 
Top