Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Mar 16, 2015
Messages
229
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
It seems so far I'm hitting blanks. I had to remove the RX580 to get BIOS / Clover video again. Can't help but think there must at least be a Clover option for this kind of situation. I've heard they're working on this for OpenCore for even *real* Macs that have the video boot problem. Hmmm...
Since it is unclear what model, what CPU, what you want to do, please explain.
RX580 should work properly from 10.14.5.
 
Joined
Feb 27, 2014
Messages
185
Motherboard
Dell Inspiron 530
CPU
Q9650
Graphics
GTX 750 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
@Asural 8300 Elite CMT, Core i7-3770, Sapphire RX580 8GB. BIOS version: 2.99
 
Joined
Mar 16, 2015
Messages
229
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
@Asural 8300 Elite CMT, Core i7-3770, Sapphire RX580 8GB. BIOS version: 2.99
I use have HP8300CMT core i-5 3470 RX570.
The RX580 requires a power capacity of 450W or more. How is it provided?
 
Joined
Feb 27, 2014
Messages
185
Motherboard
Dell Inspiron 530
CPU
Q9650
Graphics
GTX 750 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
I use have HP8300CMT core i-5 3470 RX570.
The RX580 requires a power capacity of 450W or more. How is it provided?
The 8pin BQ(-B) VGA cable from a 600 Watt EVGA 600BQ with the modified adapter cable that has fan control wire attached to case CPU fan so that there's no BIOS fan control error.
 
Joined
Mar 16, 2015
Messages
229
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
The 8pin BQ(-B) VGA cable from a 600 Watt EVGA 600BQ with the modified adapter cable that has fan control wire attached to case CPU fan so that there's no BIOS fan control error.
If + 5VSB is 15W or more, there should be no problem.

Check the connection method with the monitor in the manual of RX580 used.
(My RX570 only tests DVI, HDMI, DP 1)
Probably, it will be three kinds of output of MDMI, DP, DPx2.
 
Joined
Feb 27, 2014
Messages
185
Motherboard
Dell Inspiron 530
CPU
Q9650
Graphics
GTX 750 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
I have 2xDP, 2xHDMI 1xDVI outs.
 
Joined
Mar 16, 2015
Messages
229
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
I have 2xDP, 2xHDMI 1xDVI outs.
Is the connection method with the monitor described?
DVI cannot be used unless it is corrected in RX570.

 
Joined
Feb 27, 2014
Messages
185
Motherboard
Dell Inspiron 530
CPU
Q9650
Graphics
GTX 750 Ti
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
iMac, Power Mac
Mobile Phone
Android, iOS
Well I just had an odd development: I'm getting video @ BIOS, Clove, Boot and in macOS with all 3 monitors.

I'll come back to this and put in my BIOS settings once I have some time (today is a hectic day).

I ended up using 1x DVI, 1x HDMI, 1x DP to 3 monitors. Will take a photo of the config as well and add later as well.

This is a somewhat baffling situation even still.
 
Joined
Mar 16, 2015
Messages
229
Motherboard
HP 6300 SFF-V3.08
CPU
i5-3570
Graphics
GT 640
Mac
Mac mini, Mac Pro
Classic Mac
Power Mac, Quadra, SE/30
Well I just had an odd development: I'm getting video @ BIOS, Clove, Boot and in macOS with all 3 monitors.

I'll come back to this and put in my BIOS settings once I have some time (today is a hectic day).

I ended up using 1x DVI, 1x HDMI, 1x DP to 3 monitors. Will take a photo of the config as well and add later as well.

This is a somewhat baffling situation even still.
Perhaps it is a specification that guarantees three types of output: DVI, HDMI, and DP.

read the specification of the power supply, but when + 5VSB was 12.5W, in my case, I could not boot up unless I set the BIOS setting to "Consumption".
Even if you buy a new one. It seems that it will not be able to start in 1 to 3 years.

I'm going to sleep, you can enjoy the power test.
 
Joined
Aug 10, 2017
Messages
8
Motherboard
HP 6300 Pro MT
CPU
I5-3470
Graphics
RX 560
Mac
iMac
Mobile Phone
iOS
Hi All. I'm trying to update to Sniki's Mojave by doing a clean install. In the Pre Installation and after the boot loader installation is complete, I opened the EFI partition of the USB drive and deleted the config.plist file in EFI/Clover. Do I replace it with both files in Sniki's Repo (namely the HP2500.plist AND the HP4000.plist files), or just the single file appropriate for my machine? I'm running on a HP 6300 Microtower, so I believe if I use a single file replacement, I would only replace with the HP2500.plist file. Thanks
 
Top