Contribute
Register

Solved > Catalina work only with 0x12345678 platform id

Joined
Feb 16, 2017
Messages
89
Motherboard
Gigabyte Z170XP-SLI
CPU
i5-6600K
Graphics
GTX 1050 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Hi i just installed catalina on my hackintosh and i have a problem with video drivers.

MOBO: Z170XP-SLI
CPU: Intel 6600K
GPU: Intel HD 530
SSD: Samsung 97 Evo plus

The video card integrated in the processor is an Intel HD 530

When I boot it gives me the error in the photo.
The only way to access the system is by going to the bootloader on Options> Graphic Inject and setting id platform on 0x12345678
however, as you can see in the photo, the dedicated memory is 7MB

I tried to set the 0x19120000 via clover configurator but nothing changes

I attach my EFI folder below
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,975
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi i just installed catalina on my hackintosh and i have a problem with video drivers.

MOBO: Z170XP-SLI
CPU: Intel 6600K
GPU: Intel HD 530
SSD: Samsung 97 Evo plus

The video card integrated in the processor is an Intel HD 530

When I boot it gives me the error in the photo.
The only way to access the system is by going to the bootloader on Options> Graphic Inject and setting id platform on 0x12345678
however, as you can see in the photo, the dedicated memory is 7MB

I tried to set the 0x19120000 via clover configurator but nothing changes

I attach my EFI folder below
try adding -disablegfxfirmware boot argument

don't inject intel in config.plist
 
Joined
Feb 16, 2017
Messages
89
Motherboard
Gigabyte Z170XP-SLI
CPU
i5-6600K
Graphics
GTX 1050 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Resolved
Thank you very much you saved my day :headbang::wave:
 
Top