Contribute
Register

[Success!] Snbd889's Video Editing Build: Core i7-4790k - GA-Z97X-UD5H - 16GB CORSAIR VENGENANCE RAM

Joined
Dec 26, 2014
Messages
51
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 760
i'm brand new at hacks and have just put this one together with yosemite:

Gigabyte GA-Z97X-UD5H LGA 1150 Z97
Intel Core i7-4790K
EVGA GeForce GTX760
Crucial Ballistix Tactical Low Profile 32GB
Samsung 840 EVO 250GB (boot)
Corsair Carbide Series Black 500R Mid Tower
Corsair RM Series 650 Watt ATX/EPS 80PLUS

i started trying the UB/MB install method. i couldn't get that to boot properly. i tried baja-king' clover method for his Z77x-ud5h listed here:

http://www.tonymacx86.com/yosemite-desktop-guides/150852-success-guide-yosemite-10-10-1-clover-uefi-guide-gigabyte-ga-z77x-ud5h.html.

the clovenator part didn't make sense to me and didn't seem to do anything. but, after i tweaked the bios as follows:

Load optimized defaults.
Advanced memory settings > XMP Profile 1.
Set VT-d to Disabled.
Set XHCI mode to Auto.
Set XHCI Hand-off to Enabled.
Set EHCI Hand-off to Enabled.
Disable onboard video.
Set SATA configuration to AHCI.
Save and reset, quite obviously.

all of a sudden, i was booting up and running. i've migrated data and am doing pretty well. i don't have sound, but i've given up and ordered a usb solution. i've had a kernel panic issue i can't isolate. it happened once yesterday when i was trying to move the cursor in an word 2011 document. it happened this morning after i woke the computer up from overnight sleep.

any thoughts on trying to figure out the cause?

i'm considering ordering a bluetooth/wifi card (http://www.osxwifi.com/apple-broadco...-pc-hackintosh) so i can use the bt keyboard and trackpad i love. any experience with this?

my about this mac shows me as a mac mini server (late 2012). and it doesn't seem that updates are working very well. the office suite wanted to put an update on. i ran the program 3 times. every time, it came back saying that the same update was ready to install. the same with a thunderbolt firmware update 1.2. i've run it 3 times and, every time, i'm told that it's still available. same thing with my office 2011 software and my scansnap software trying to update. i get a message that it failed to update.

i know i don't have thunderbolt. i'll stop trying to update with that. i don't know how to change the system profile, either. is that important?

and, aside from the update question, should i do anything else? what should i look for? i'm pretty happy so far. i'm driving three monitors, a 30" apple cinema display and two viewsonic 23.5 inchers. everything seems fast and doing what i need it to do. i'm wondering what else i should know. thank you in advance,
 
Joined
Dec 2, 2014
Messages
95
Motherboard
GA-Z97X-UD5H
CPU
i5-4690k
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
I was able to finally install Yosemite through Clover using your guide (not without headaches!). This may be common sense, but if you're going to use one of Snbd889's config.plist's, make sure to edit the file name to "config.plist", otherwise you wont get passed a circle with a strike at the install.

I have an Nvidia GTX 970 installed, before installing Yosemite I went into BIOS and disabled PCIE under graphics, and enabled IGFX instead. I had to type in "npci=0x2000, nv_disable=1" into the boot args in order to get the install running (this probably wouldn't have been necessary if I removed my graphics card). The install went fine, it said "about a second remaining" for about 15 - 20 minutes before finally restarting. After the second restart (again I'm typing in "npci=0x2000, nv_disable=1" every time) I booted from the SSD, and followed the "post-installation" instructions, except I added a step (I'm not even sure what it does) from tonymac's official guide, this one...

1. Open /Applications/Utilities/Terminal
2. Type: diskutil list and locate your system drive's EFI partition. It will be under IDENTIFIER. Be sure to use the correct one. (For this example: disk0s1)
3. Type the following, enter password and hit enter:

Code:
sudo newfs_msdos -v EFI -F 32 /dev/rdisk0s1


I believe that changes the EFI from HFS to FAT32...I'm not sure if this is necessary, or even recommended by the Clover community, but I trust tonymac. After following Snbd889's post-install method, I installed the CUDA and NVIDIA drivers for my graphics card. I restart the computer, go into BIOS, and change back my graphics to PCIE and disable IGFX. When Clover starts up, it immediately recognizes the graphics card and has "nvda_drv=1" already listed in it's boot args. I've only briefly played around in Yosemite after the install, but sleep seems to be working fine, even though "Energy Saver" preferences look different from my Chimera build (there's no "computer sleep" option under "Energy Saver" in the Clover build, but it definitely works after a minute of the display sleeping). Audio is working fine even without running multibeast or downloading any kexts (outside of the ones provided by Snbd889), and it plays back after sleep.

Now I just need to figure out how to get the Clover boot screen to automatically boot into the Yosemite SSD after a set amount of time, without having to manually select it, and fix the boot screen to fit a 2560x1440 resolution. I'm assuming this is all done by importing the config.plist and editing it in Clover Configurator.

Motherboard: Gigabyte Z97X-UD5H
CPU: i5-4690K
GPU: Gigabyte Geforce GTX 970
Power: Corsair RM650
RAM: 16GB Crucial Ballistix
SSD: 120GB Samsung 840 EVO
Cooling: Cooler Master Seidon 240M
Optical: LG WH14NS40
Case: Corsair Carbide 500R
Monitor: Apple Cinema Display 27"
 
Joined
Dec 26, 2014
Messages
51
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 760
you guys that are getting this working, what is your system definition? i'm stuck on mac mini server late 2012. is that going to hurt me? i ran multibeast for mac pro 3,1, but nothing happened.

i'm also seeing some instability. i get one kernel panic in the mornings after the system has been on, but asleep, all night. after reboot, i've been able to go all day without much problem. firefox has completely shut down on me once. and chrome extensions (like hangouts and workflowy) will sometimes crash. anyone else seeing this? any ideas? also, my dropbox seems affected by the kernel panics. on reboot, it looks like dropbox is trying to sync every file in the box.

thanks for the ideas,
 
Joined
Dec 2, 2014
Messages
95
Motherboard
GA-Z97X-UD5H
CPU
i5-4690k
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
Have you fixed your sound yet? I used your guide, almost everything worked but I didn't have sound.

I followed this gude...
I started by adding "kext-dev-mode=1" to the config.plist. I needed to grab the ALC kext (I think it's the RealtekALC.kext.zip found here, I'll edit this post when I get home to confirm) and move it to my 10.10 kext folder. I then ran the shell, which I believe is the audio_cloverALC-100.command.zip file (I really need to start writing these processes down!), the message I got back was different than allgreyarea's guide, and I didn't do step two either. Since I'm using the display port on my Nvidia card, I also moved this kext to my 10.10 folder. When I rebooted I was able to get sound through my monitor, headphone port, and my home theater receiver.
 
Joined
Oct 27, 2014
Messages
29
Motherboard
GA-Z97X-UD5H
CPU
intel i7-4790k
Graphics
EVGA GTX 980
Mac
Classic Mac
Mobile Phone
Have you fixed your sound yet? I used your guide, almost everything worked but I didn't have sound.

I followed this gude...
I started by adding "kext-dev-mode=1" to the config.plist. I needed to grab the ALC kext (I think it's the RealtekALC.kext.zip found here, I'll edit this post when I get home to confirm) and move it to my 10.10 kext folder. I then ran the shell, which I believe is the audio_cloverALC-100.command.zip file (I really need to start writing these processes down!), the message I got back was different than allgreyarea's guide, and I didn't do step two either. Since I'm using the display port on my Nvidia card, I also moved this kext to my 10.10 folder. When I rebooted I was able to get sound through my monitor, headphone port, and my home theater receiver.
Thank you!!
Sound works perfect!!
 
Joined
Dec 26, 2014
Messages
51
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 760
i'm getting pretty frequent kernel panics—at least one a day. i'm not sure what to do to diagnose it. how important is system definition? mine's still listed as a macmini server. i haven't figured out clovenator yet to change it. i copied the problem report but i'm not sure what to do with it. any ideas? thanks.

is this telling me it's possibly a ram problem? i'm running Crucial Ballistix Tactical Low Profile 32GB.

thanks,


Mon Jan 12 07:50:23 2015


*** Panic Report ***
panic(cpu 4 caller 0xffffff8000405d82): "Possible memory corruption: pmap_pv_remove(0xffffff8000adfd48,0xffffff83ac5ec000,0x7603d5, 0x80000007603d5202, 0xfffffeb10180ef60): empty hash"@/SourceCache/xnu/xnu-2782.1.97/osfmk/i386/pmap_internal.h:822
Backtrace (CPU 4), Frame : Return Address
0xffffff83ad1b3860 : 0xffffff800033a811
0xffffff83ad1b38e0 : 0xffffff8000405d82
0xffffff83ad1b39d0 : 0xffffff80004065e5
0xffffff83ad1b3a30 : 0xffffff80003b6bb1
0xffffff83ad1b3b40 : 0xffffff80003acd2c
0xffffff83ad1b3b70 : 0xffffff80003a9013
0xffffff83ad1b3ba0 : 0xffffff800057d978
0xffffff83ad1b3bd0 : 0xffffff800057a3f6
0xffffff83ad1b3bf0 : 0xffffff800075fdb3
0xffffff83ad1b3c20 : 0xffffff8000742cc0
0xffffff83ad1b3d40 : 0xffffff8000573700
0xffffff83ad1b3dc0 : 0xffffff8000568c5f
0xffffff83ad1b3e30 : 0xffffff80007ef305
0xffffff83ad1b3ee0 : 0xffffff80007b5c80
0xffffff83ad1b3f50 : 0xffffff800084dcb2
0xffffff83ad1b3fb0 : 0xffffff800043ac46


BSD process name corresponding to current thread: coreduetd
Boot args: dart=0 kext-dev-mode=1 slide=0


Mac OS version:
14B25


Kernel version:
Darwin Kernel Version 14.0.0: Fri Sep 19 00:26:44 PDT 2014; root:xnu-2782.1.97~2/RELEASE_X86_64
Kernel UUID: 89E10306-BC78-3A3B-955C-7C4922577E61
__HIB text base: 0xffffff8000100000
System model name: Macmini6,2 (Mac-F65AE981FFA204ED)


System uptime in nanoseconds: 2518026828227
last loaded kext at 8084035147: com.apple.driver.AppleGraphicsDevicePolicy 3.7.7 (addr 0xffffff7f8224a000, size 45056)
last unloaded kext at 77810846235: com.apple.driver.AppleFileSystemDriver 3.0.1 (addr 0xffffff7f82260000, size 8192)
loaded kexts:
com.Creative.driver.TruStudioPCUSBAudioPlugin 2.3.20
com.displaylink.driver.DisplayLinkDriver 2.1
com.Cycling74.driver.Soundflower 1.5.2
org.virtualbox.kext.VBoxUSB 4.1.22
org.virtualbox.kext.VBoxDrv 4.1.22
com.insanelymac.driver.AppleIntelE1000e 3.0.4
net.osrom.kext.Disabler 1.0.1
org.netkas.driver.FakeSMC 1328
com.apple.driver.AppleGraphicsDevicePolicy 3.7.7
com.apple.driver.AppleUSBDisplays 372.1
com.apple.filesystems.autofs 3.0
com.apple.iokit.IOBluetoothSerialManager 4.3.1f2
com.apple.driver.AppleUpstreamUserClient 3.6.1
com.apple.driver.AppleMCCSControl 1.2.10
com.apple.GeForce 10.0.0
com.apple.driver.AppleOSXWatchdog 1
com.apple.iokit.IOUserEthernet 1.0.1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.AppleHWAccess 1
com.apple.driver.AppleHV 1
com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
com.apple.driver.Apple16X50ACPI 3.2
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 35
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage 2.6.5
com.apple.driver.AppleUSBHub 705.4.1
com.apple.driver.AppleAHCIPort 3.0.7
com.apple.driver.AppleUSBEHCI 705.4.14
com.apple.driver.AppleUSBXHCI 705.4.14
com.apple.driver.AppleRTC 2.0
com.apple.driver.AppleACPIButtons 3.1
com.apple.driver.AppleHPET 1.8
com.apple.driver.AppleSMBIOS 2.1
com.apple.driver.AppleAPIC 1.7
com.apple.nke.applicationfirewall 161
com.apple.security.quarantine 3
com.apple.security.TMSafetyNet 8
com.apple.driver.AppleGraphicsControl 3.7.21
com.apple.iokit.IOUSBHIDDriverPM 705.4.5
com.apple.kext.triggers 1.0
com.apple.driver.AppleUSBMergeNub 705.4.0
com.apple.driver.AppleSMBusController 1.0.13d1
com.apple.iokit.IOSMBusFamily 1.1
com.apple.iokit.IOAcceleratorFamily2 156.4
com.apple.nvidia.driver.NVDAGK100Hal 10.0.0
com.apple.nvidia.driver.NVDAResman 10.0.0
com.apple.AppleGraphicsDeviceControl 3.7.21
com.apple.iokit.IOSurface 97
com.apple.iokit.IOBluetoothFamily 4.3.1f2
com.apple.iokit.IONDRVSupport 2.4.1
com.apple.iokit.IOGraphicsFamily 2.4.1
com.apple.driver.AppleSMC 3.1.9
com.apple.driver.IOPlatformPluginLegacy 1.0.0
com.apple.driver.IOPlatformPluginFamily 5.8.0d49
com.apple.driver.Apple16X50Serial 3.2
com.apple.iokit.IOSerialFamily 11
com.apple.iokit.IOUSBUserClient 705.4.0
com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.0
com.apple.driver.AppleUSBAudio 295.22
com.apple.iokit.IOAudioFamily 200.6
com.apple.vecLib.kext 1.2.0
com.apple.iokit.IOUSBHIDDriver 705.4.0
com.apple.driver.AppleUSBComposite 705.4.9
com.apple.iokit.IOAHCIFamily 2.7.0
com.apple.iokit.IONetworkingFamily 3.2
com.apple.iokit.IOUSBFamily 705.4.14
com.apple.driver.AppleEFINVRAM 2.0
com.apple.driver.AppleEFIRuntime 2.0
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.security.sandbox 300.0
com.apple.kext.AppleMatch 1.0.0d1
com.apple.driver.AppleKeyStore 2
com.apple.driver.AppleMobileFileIntegrity 1.0.5
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.DiskImages 389.1
com.apple.iokit.IOStorageFamily 2.0
com.apple.iokit.IOReportFamily 31
com.apple.driver.AppleFDEKeyStore 28.30
com.apple.driver.AppleACPIPlatform 3.1
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.corecrypto 1.0
com.apple.kec.pthread 1
com.apple.kec.Libm 1
Model: Macmini6,2, BootROM MM61.0106.B00, 4 processors, Intel Core i7, 4.00 GHz, 32 GB, SMC 2.8f0
Graphics: NVIDIA GeForce GTX 760, NVIDIA GeForce GTX 760, PCIe, 2048 MB
Memory Module: BANK0/DIMM0, 8 GB, DDR3, 1333 MHz, Crucial Technology, BLT8G3D1608ET3LX0.
Memory Module: BANK1/DIMM0, 8 GB, DDR3, 1333 MHz, Crucial Technology, BLT8G3D1608ET3LX0.
Memory Module: BANK0/DIMM1, 8 GB, DDR3, 1333 MHz, Crucial Technology, BLT8G3D1608ET3LX0.
Memory Module: BANK1/DIMM1, 8 GB, DDR3, 1333 MHz, Crucial Technology, BLT8G3D1608ET3LX0.
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Samsung SSD 850 EVO 250GB, 250.06 GB
Serial ATA Device: ST3000DM001-1ER166, 3 TB
Serial ATA Device: ST3000DM001-1ER166, 3 TB
Serial ATA Device: ST2000DM001-1E6164, 2 TB
USB Device: Hub
USB Device: Hub
USB Device: VF0690 Live! Cam Socialize HD AF
USB Device: Sound Blaster Play! 2
USB Device: USB Receiver
USB Device: Hub
USB Device: Hub
USB Device: Hub
USB Device: Apple Cinema HD Display
USB Device: Hub
Thunderbolt Bus:
 
Joined
Oct 27, 2014
Messages
29
Motherboard
GA-Z97X-UD5H
CPU
intel i7-4790k
Graphics
EVGA GTX 980
Mac
Classic Mac
Mobile Phone
i'm getting pretty frequent kernel panics—at least one a day. i'm not sure what to do to diagnose it. how important is system definition? mine's still listed as a macmini server. i haven't figured out clovenator yet to change it. i copied the problem report but i'm not sure what to do with it. any ideas? thanks.

is this telling me it's possibly a ram problem? i'm running Crucial Ballistix Tactical Low Profile 32GB.

thanks,
I have the same ram and have not had a problem. Do you have a video card? Also what OS are you running? You should update your profile to include your hardware.
 
Last edited:
Joined
Mar 7, 2011
Messages
12
Motherboard
osx
CPU
2600k
Graphics
nvidia
Mac
Classic Mac
Mobile Phone
You should test your Ram with Memstest86 and try to Install Yosemite with Multibeast. I have almost the same parts as you and I've installed Yosemite with Multibeast without any problem. At least you can check that way if it is a clover or a hardware problem.
 
Joined
Dec 26, 2014
Messages
51
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 760
thank you for the replies. I've updated my profile to show hardware. I'm running 10.10.1.

yesterday's kernel panic showed chrome as the problem, not my ram. so yesterday i migrated everything over to Firefox. and this morning, after sleeping all night, the machine didn't panic on wakeup.

I'm hoping that's a new trend. I'm hesitant to try a fresh install using MultiBeast just because this is my daily work computer and i don't want the downtime. but that's a good idea. if i keep having problems, i'll have to try it.

one advantage using only firefFirefoxox seems to have is lower memory usage. i don't know if anyone has tracked this, but when i ran chrome, my ram usage was crazy. but right now I've got 4 windows open with 22 tabs in all, not all of them have loaded since the last start, but I'm at less than 25% in total ram usage. makes me wonder if i could have skipped the hackintosh and just used Firefox on my Mac Mini. oh well.
 
Top