Contribute
Register

macOS Mojave kextd stall AppleACPICPU and Unsupported PCH

Joined
Jul 17, 2015
Messages
131
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
I have followed RehabMan's guide to prepare the bootable macOS Mojave USB. However I'm stuck with the said error. I tried recreating the bootable medium twice to no avail. Problem Reporting files have been attached.
 

Attachments

Joined
Apr 21, 2016
Messages
1,364
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
Remove GenericUSBXHCI.kext, not for your hardware.
Use the non-spoof config.plist. Spoofing Kaby Lake as Skylake is not necessary in 10.12.6+.
Make sure you're using the latest Clover release from SourceForge.
 
Joined
Jul 17, 2015
Messages
131
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Remove GenericUSBXHCI.kext, not for your hardware.
Use the non-spoof config.plist. Spoofing Kaby Lake as Skylake is not necessary in 10.12.6+.
Make sure you're using the latest Clover release from SourceForge.
Okay. Thank You
So I did follow the guideline by using the non-spoof config.plist and removed GenericUSBXHCI.kext. Now I am able to reach the installer but during installation it says 2 minutes remaining and suddenly shutdown call gets initiated and the system reboots.

I have tried capturing the output. It misses some lines at the end that were there for a fraction of second only.
 

Attachments

Last edited:
Joined
Apr 21, 2016
Messages
1,364
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
Okay. Thank You
So I did follow the guideline by using the non-spoof config.plist and removed GenericUSBXHCI.kext. Now I am able to reach the installer but during installation it says 2 minutes remaining and suddenly shutdown call gets initiated and the system reboots.

I have tried capturing the output. It misses some lines at the end that were there for a fraction of second only.
Are you using the latest Clover release?
As it shuts down, I'm not sure it's actually an error (I could be wrong). Isn't there any other boot option besides the USB installer after it happens?
 
Joined
Jul 4, 2012
Messages
342
Motherboard
Gigabyte Aorus Z390 Ultra
CPU
i5-9600K
Graphics
Vega 56
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Are you using the latest Clover release?
As it shuts down, I'm not sure it's actually an error (I could be wrong). Isn't there any other boot option besides the USB installer after it happens?
There are multiple progress bars as part of the installation process, The first progress bar you see after you select the drive to install to is where contents is copied from USB to the internal hard drive. It then reboots and you select the 'installer on Macintosh HD' and then there is another progress bar. If that is the progress bar you are having a problem and is stuck as 2 minutes then the USB drive is not your problem. The only reason you need the USB key for the reboot is because you need clover because you don't have a real Mac and is simply there to start the installer files that were copied to the hard drive during the first progress bar.
 
Joined
Jul 17, 2015
Messages
131
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Yes there is an option to boot from the drive. But a new error pops up there. Kindly have a look.
 

Attachments

Joined
Aug 5, 2018
Messages
524
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Disable smcbatterymanager.kext from start up. Replace with acpibatterymanager.kext
 
Joined
Jul 17, 2015
Messages
131
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Disable smcbatterymanager.kext from start up. Replace with acpibatterymanager.kext
I'm sorry but I can't find the stated kext. Can you please point me to the location? I have attached the EFI partition below.
 

Attachments

Joined
Aug 5, 2018
Messages
524
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Nevermind. As far as I can see from your clover folder you haven't any of these kexts , so the problem must be other.
 
Top