Contribute
Register

[Guide] Razer Blade 15 (2018) Detailed Install Guide High Sierra 10.13.6 (17G2208-17G5019)

Joined
Jan 19, 2019
Messages
5
Motherboard
Razer Blade 15 Base
CPU
i7-8750H
Graphics
GTX 1060, 1920x1080
If you patched your DSDT correctly and are using all of the provided kexts, you should have working battery status. There is no issue with battery status and the base model blade.

As far as the trackpad goes, there's nothing you really can do. What it boils down to is the hardware just isn't supported by the kexts that are used to make the trackpad work.
The only thing you can do is post in the VoodooI2C support thread as others have done, the demand for that trackpad to work might cause the developers to look into it more. The support thread is here: https://www.tonymacx86.com/threads/voodooi2c-help-and-support.243378/page-88

Gah. Well thanks for the info (and the guide).
I kept getting an error when I tried to patch the DSDT with the battery patch, was likely user error on my part.

Time to nag away at the devs! Its a real bummer man, I got my blade all ready to go and just want to avoid using an external mouse.:mrgreen:
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Gah. Well thanks for the info (and the guide).
I kept getting an error when I tried to patch the DSDT with the battery patch, was likely user error on my part.

Time to nag away at the devs! Its a real bummer man, I got my blade all ready to go and just want to avoid using an external mouse.:mrgreen:

We've been steering people away from the base model for this very reason.

What error are you getting when you try and patch your DSDT?
 
Joined
May 15, 2018
Messages
26
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 4K Display
I am running on Mojave perfectly fine. I had a similar issue after installing the updated KEXT were the permissions on my Library/Extensions folder broke. Booting using my USB recovery drive and running the following terminal commands fixed my boot problem.

sudo chown -R 0:0 /Library/Extensions/*
sudo chmod -R 755 /Library/Extensions/*

The only issue I am seeing now is my imessages and facetime doesn't seem to want to authenticate with the invalid serial numbers.


Ok so we have some progress. I changed the permissions and I got further in the boot but still nothing no Kp just the attached error. Here is the kicker if I connect my thunderbolt 3 monitor I can get it to boot!!! However it’s stable for about 20 seconds and the whole system locks up.

IMG_20190123_214621.jpeg
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Ok so we have some progress. I changed the permissions and I got further in the boot but still nothing no Kp just the attached error. Here is the kicker if I connect my thunderbolt 3 monitor I can get it to boot!!! However it’s stable for about 20 seconds and the whole system locks up.

View attachment 381682
Upload your EFI folder
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@kilabyte
Why do you have screen resolution set under the GUI in clover? Leave that blank, changing the resolution there can cause boot issues.

Your information says you have the 4K display. I don't think we've had anyone with the 4K display yet. There could be some discrepancies with this.
For now, for testing, remove SSDT-PNLF and SSDT-XOSI. Get rid of the screen resolution in the GUI settings of the config.plist and try to boot verbose and see what happens.
 
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@kilabyte
Please try the attached config.plist. Before you reboot after adding the new config.plist, rebuild kextcache. Let me know what you come up with.

I added a patch to kexts to patch that is specifically for the 4K displays, I also removed the screen resolution you set.
 

Attachments

  • config.plist
    11.3 KB · Views: 96
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Decided to install Mojave for fun and test out the guide myself. All went smoothly, even had a little fun with the About This Mac section :)

Screen Shot 2019-01-24 at 10.52.09 PM.png
 
Joined
May 15, 2018
Messages
26
Motherboard
Razer Blade 15
CPU
i7 8750H
Graphics
UHD 630, 1070 GTX, 4K Display
So started from scratch used the new config and this is what I got. I'm gonna try something else this weekend. Also love your about Mac lol
 

Attachments

  • IMG_20190124_211614.jpg
    IMG_20190124_211614.jpg
    5.1 MB · Views: 25
Joined
Dec 7, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
So started from scratch used the new config and this is what I got. I'm gonna try something else this weekend. Also love your about Mac lol

@RehabMan can you shed some light on this issue by any chance?
 
Top