Contribute
Register

Black screen on DisplayPort in 1/2 boot (Apple logo screen), HD 630, Asus ROG Strix Z370-G, HDMI ok

Joined
Oct 16, 2018
Messages
7
Motherboard
ASUS ROG STRIX Z370-G GAMING
CPU
i7-8700K
Graphics
UHD-630
Hello,
it is my 1. Hackintosh build and followed: https://www.tonymacx86.com/threads/pastrychefs-asus-rog-strix-z370-g-gaming-wi-fi-ac-build-w-i7-8700k-amd-vega-56.239969/
- Differences are MB is without Wifi AC, use of 2 x 16 Hyper X Fury 3466Mhz, Samsung 970evo 500gb
- Intel HD 630 only
- No additional cards or adapters
- Display BL2711U
- DP cable packed with the display
- macOS Mojave
- used Unibeast, Clover Configurator (to load iMac 18.1 profile), Multibeast

When I plug HDMI everything works fine except I did not get HiDPI resulutions but it is not a problem now.

I would like to use Displayport to get a HiDPI resolution on 60Hz but I can not because getting black screen during boot:
- When Power Off I plug DP cable in DP port on MB on boot
- Bios screen present
- Clover screen present
- Select boot to Mojave and Apple logo present
- When the boot gauge gets into 1/2 display switch to Black screen and shows "No signal" label.

- After I plug HDMI and switch from DP to HDMI I will see macOS Logon screen and I can log in.
- When I unplug or plug DP cable it causes Computer reset when maOS is booted.
- When I switch between DP 1.1 & 1.2 in display settings in causes Computer reset when maOS is booted.

I tested many setting variants in BIOS and Clover/config.plist but nothing helped. I followed every solution I found on web. No success yet.
Please help & feel free to ask for any additional info.
Thanks!
 
Joined
Oct 16, 2018
Messages
7
Motherboard
ASUS ROG STRIX Z370-G GAMING
CPU
i7-8700K
Graphics
UHD-630
I have the same problem. Have you figured it out yet?
Yes, I made new clean install of Mojave & Clover.
In Multibeast I checked Whatevergreen + Lilu, 18.1 Mac profile and voila DP is working in 4K@60HZ.
I did all the install with only DP plugged into iGPU port.
 
Joined
Oct 16, 2018
Messages
7
Motherboard
ASUS ROG STRIX Z370-G GAMING
CPU
i7-8700K
Graphics
UHD-630
Where in multibeast is lilu? Having the same issue here.
Depends on Multiberast version it is in:

"Multibeast / Customize / Graphics Configuration / Core Graphics Fixup AKA Whatevergreen"
or
"Multibeast / Drivers / Misc / Core Graphics Fixup AKA Whatevergreen"

- Provides patches necessary for Intel GPUs by vit9696.
- Installs Lilu.kext and WhateverGreen.kext to /Library/Extensions.


Also
"Multibeast / Drivers / Audion / AppleALC"

- Enables native macOS HD audio for without any filesystem modifications by vit9696.
- Installs Lilu.kext and AppleALC.kext to /Library/Extensions.

Do not forget to have your display plugged into DP only during macOS installation.
 
Last edited:
Top