Contribute
Register

X299 - Open Core support

Joined
Feb 5, 2013
Messages
929
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
Radeon VII
Mac
iMac, Mac Pro
Catalina requires EC. That’s probably why you guys can’t get BT working.
Well, I knew about EC (I thought that was only needed in beta 5 of Catalina), but in my case, BT doesn't work in Mojave, either, and Mojave does not require EC.....and Lorengrin also reported that BT didn't work in Mojave or Catalina, with symptoms very close to mine.
 
Joined
Feb 5, 2013
Messages
929
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
Radeon VII
Mac
iMac, Mac Pro
I have to go out and do some errands before I hit the bed, but I'll try it tonight if I can....thanks!
 
Joined
Feb 24, 2013
Messages
2,162
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Well, I knew about EC (I thought that was only needed in beta 5 of Catalina), but in my case, BT doesn't work in Mojave, either and Mojave does not require EC.....and Lorengrin also reported that BT didn't work in Mojave or Catalina, with symptoms very close to mine.
Yeah, I've seen others report similar issues on other forum regarding the BrcmPatchRAM2 stuff in Catalina...but if @Ellybz has a workaround use that for now until this is figured out.

Unfortunately I don't have any other PCIe cards to test with or I would chime in about BT issues.

I think the issue is BrcmBluetoothInjector is not being injected properly in Catalina, but it is in Mojave.
 

shael

Suspended
Joined
Mar 9, 2011
Messages
359
Motherboard
ASUS PRIME X299-Deluxe
CPU
i9-7980XE
Graphics
Vega Frontier
Maybe @shael can post his EFI?
I really would rather not post my EFI... I thought about it as Ii have finally finished conforming to OC docs. However, with the treatment this forum hands out. I'd rather not open myself up to all the questions. It is really not difficult to read the docs, and I have yet to see anyone in this thread aside from @izo1 read them. Especially since a lot of the stuff KGP has in his guide is irrelevant to OC, outdated, or incorrect. which will lead to a lot of confusion among the users in this thread.

This thread should really be about clarification on the docs and help with assistance on creating a flawless OC config. Just my 2 cents.

@mm2margaret id is pci14e4,43a0 card is Bcm94360cd...why are you using injector kexts? :banghead:
 
Joined
Feb 5, 2013
Messages
929
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
Radeon VII
Mac
iMac, Mac Pro
I really would rather not post my EFI... I thought about it as Ii have finally finished conforming to OC docs. However, with the treatment this forum hands out. I'd rather not open myself up to all the questions. It is really not difficult to read the docs, and I have yet to see anyone in this thread aside from @izo1 read them. Especially since a lot of the stuff KGP has in his guide is irrelevant to OC, outdated, or incorrect. which will lead to a lot of confusion among the users in this thread.

This thread should really be about clarification on the docs and help with assistance on creating a flawless OC config. Just my 2 cents.

@mm2margaret id is pci14e4,43a0 card is Bcm94360cd...why are you using injector kexts? :banghead:
Because it works. And it has worked in Sierra, High Sierra and Mojave. That's why.....now I'm sorry I posted my EFI.
Again, with the reading of the docs. I've read them. And I suspect Ellybz has read them as well.
 
Joined
Feb 5, 2013
Messages
929
Motherboard
Asus X299 Prime Deluxe
CPU
i9 7940X
Graphics
Radeon VII
Mac
iMac, Mac Pro
@Ellybz So, if your change was AirportBrcmfixup, it didn't work for me. Sorry to report that. I do appreciate the effort....

I suspect that will be the last time I post my EFI on this thread.

I have a Broadcom CS card in my other hack. I may switch it out and see what I get then....thanks again.
 
Last edited:

shael

Suspended
Joined
Mar 9, 2011
Messages
359
Motherboard
ASUS PRIME X299-Deluxe
CPU
i9-7980XE
Graphics
Vega Frontier
@Ellybz So, if your change was AirportBrcmfixup, it didn't work for me. Sorry to report that. I do appreciate the effort....

I suspect that will be the last time I post my EFI on this thread.
Give this a look over... (it belongs in the deviceproperties section of the config.plist)

**keep in mind this is for the card being in slot slot-3**

1565840265506.png


Code:
           <key>PciRoot(0x0)/Pci(0x1b,0x2)/Pci(0x0,0x0)</key>
            <dict>
                <key>device-id</key>
                <data>oEMAAA==</data>
                <key>AAPL,slot-name</key>
                <string>Slot-3</string>
                <key>device_type</key>
                <string>AirPort Controller</string>
                <key>model</key>
                <string>OSX WIFI Broadcom BCM94360CD 802.11 a/b/g/n/ac + Bluetooth 4.0 Controller</string>
                <key>compatible</key>
                <string>pci14e4,43a0</string>
                <key>name</key>
                <string>AirPort Extreme</string>
            </dict>
**EDIT**
As well please confirm that your USB 2.0 header on the board is enabled using IOReg.

Please don't tell me you have read the docs as your EFI clearly does not reflect such. If you still cant figure it out... post an IOReg dump, and I will work with you on correcting the issue. That is if you want the help this time.

Thanks to @apfelnico for the SSDT that I then further modified.
 

Attachments

Last edited:
Top