Contribute
Register

Use iGPU instead of Nvidia GPU

Status
Not open for further replies.
Joined
Oct 9, 2018
Messages
9
Motherboard
Intel Dh77eb
CPU
i7-3770
Graphics
AMD RX 480 8GB
Mobile Phone
  1. Android
I'm currently running Mojave with an i7-3770 with intel HD4000 on an intel DH77EB mobo, along with GTX 1050ti OC as GPU. My question is can I use the Intel hd 4000 instead of the 1050ti when the cable is connected to the DGPU? The IGPU has native support in Mojave. Mojave fails to boot when I set the IGPU to always enabled. Any help is greatly appreciated!
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,996
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I'm currently running Mojave with an i7-3770 with intel HD4000 on an intel DH77EB mobo, along with GTX 1050ti OC as GPU. My question is can I use the Intel hd 4000 instead of the 1050ti when the cable is connected to the DGPU? The IGPU has native support in Mojave. Mojave fails to boot when I set the IGPU to always enabled.


@mhys33,

Should be no reason why you cant use the HD4000 and leave the GTX 1050 Ti in-place and connected for use in Windows.
Just be sure to use Lilu + WhatEverGreen to correctly configure the IGPU :-



I suspect that MacOS is still picking up your GTX 1050 Ti and binding the VESA drivers to it.
You can disable the GTX 1050 Ti via ACPI code .. see the linked guide in this post for more info.



Cheers
Jay
 
Joined
Oct 9, 2018
Messages
9
Motherboard
Intel Dh77eb
CPU
i7-3770
Graphics
AMD RX 480 8GB
Mobile Phone
  1. Android
Hey,

I tried using both the guides you gave me, but nothing seemed to work. I tried to disable my 1050ti with the code, but it is still detected. I'm attaching my config plist and the spoof-ssdt file I created with the values. The last thing left to try was to remove the 1050ti and connect the HDMI cable to the mobo and it worked like a charm with everything working. My only problem is why isn't my iGPU detected when I connect the cable to the 1050ti? I would like to use the system connected to the DGPU for windows, but it simply doesn't work both ways.
 

Attachments

  • config.plist
    24.9 KB · Views: 40
  • Kexts.zip
    5.6 MB · Views: 48
  • SSDT-DiscreteSpoof.aml
    128 bytes · Views: 60
Status
Not open for further replies.
Top