Contribute
Register

The 4K Dell OptiMac - 9020 MT - Core i7-4790 - Radeon RX 570 - LG 4K IPS Monitor

Joined
Jan 21, 2012
Messages
997
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
  1. Android
@bulbmkr Without the 570 - a few, not sure how many, differences - see post 3 here for a list of differences between this and a slightly altered build, tested without an external GPU.

Yes - 'Allow Legacy ROMS' allows sleep with Integrated GPU.
 
Last edited:
Joined
May 22, 2019
Messages
57
Motherboard
Dell 9020 SFF
CPU
i7 4770
Graphics
HD 4600
Hi
Been using this guide for a month or 2 on a couple of my 9020 SFF Hackintoshes, one home theater and one Audio workstation.
All good... apart from a couple of random restarts, and I've had a few issues with USB not being 100%.

I have 4-5 USB devices plugged in. The main problem behavior is, when I insert another USB device, it can cause another USB device to disconnect or act strangely. For example, when using my USB BT dongle (which I use for Keyboard and mouse), if I plug in a USB thumb drive, it can cause the Bluetooth to get jittery and will start to disconnecting and reconnecting, etc. It does seem to be related to which ports I use, as in a certain combination it seems to work together OK.
I've seen similar things on my audio workstation with midi interfaces, etc., disconnecting.

It's not major, but I'd try and work out why.
Where should I start with the troubleshooting on this?

Thanks
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,858
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
For example, when using my USB BT dongle (which I use for Keyboard and mouse), if I plug in a USB thumb drive, it can cause the Bluetooth to get jittery and will start to disconnecting and reconnecting, etc. It does seem to be related to which ports I use, as in a certain combination it seems to work together OK.
If the BT dongle is in a front USB port try it in one of the rear panel USB 2.0 ports. May make things more stable. We generally don't recommend BT dongles because they often have poor range and stability. Best results are with a native Broadcom Wifi/BT card installed in a PCIe adapter.
 
Joined
May 22, 2019
Messages
57
Motherboard
Dell 9020 SFF
CPU
i7 4770
Graphics
HD 4600
If the BT dongle is in a front USB port try it in one of the rear panel USB 2.0 ports. May make things more stable. We generally don't recommend BT dongles because they often have poor range and stability. Best results are with a native Broadcom Wifi/BT card installed in a PCIe adapter.
Thanks, will try that first.
 
Joined
Jan 21, 2012
Messages
997
Motherboard
HP 8300 Elite
CPU
i5-3570
Graphics
GT 710
Mobile Phone
  1. Android
@Iofidub - the 7020 did have a BIOS update that was said to fix USB connections dropping out (BIOS A9(?)) - you should be on a later version than that but if not - update BIOS. Otherwise, if the USB ports only fail when there is a lot going on then it is more likely to be a power issue but it might just be one of the devices taking all the bandwidth or having a fault. You can unplug one device at a time or better use a separately powered USB hub to help you troubleshoot.
 
Joined
Nov 13, 2018
Messages
20
Motherboard
Dell Optiplex 9020 SFF
CPU
I7 4790K
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
@trs96, thank you for the great guide.
I have followed it to install Mojave on my Dell 9020 SFF successfully and everything works fine.

I have a 4K monitor with DP port and I have the internal HD4600 GPU only,
is it possible to enable 4K resolution on my MAC with the DP port?
I've tried some methods but I still cannot get the resolution more than 2K.
for example, I tried to change the DVMT-prealloc with UEFI shell; I changed it to 64M, 128M,...512M, 4K is not shown in display settings.

If it's possible, could you please give me some hint? thank you in advance.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,858
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
If it's possible, could you please give me some hint? thank you in advance.
I have not done this myself as I use the RX 570 with igpu in headless mode. You should probably post in the new thread started by @nicksoph in Graphics.

 
Joined
Nov 13, 2018
Messages
20
Motherboard
Dell Optiplex 9020 SFF
CPU
I7 4790K
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. Android
@trs96 Thank you for your quick response. It's exactly what I am looking for. I will follow that post. Thank you very much.
 
Joined
May 22, 2019
Messages
57
Motherboard
Dell 9020 SFF
CPU
i7 4770
Graphics
HD 4600
If the BT dongle is in a front USB port try it in one of the rear panel USB 2.0 ports. May make things more stable. We generally don't recommend BT dongles because they often have poor range and stability. Best results are with a native Broadcom Wifi/BT card installed in a PCIe adapter.

I do have one of those on order.
It looks like moving it to the rear USB is a pretty good workaround, I can use USB on the front ports now without it affecting the BT. Thanks
@Iofidub - the 7020 did have a BIOS update that was said to fix USB connections dropping out (BIOS A9(?)) - you should be on a later version than that but if not - update BIOS. Otherwise, if the USB ports only fail when there is a lot going on then it is more likely to be a power issue but it might just be one of the devices taking all the bandwidth or having a fault. You can unplug one device at a time or better use a separately powered USB hub to help you troubleshoot.

Oh, yeah, I'm on the latest BIOS. Good idea on the powered USB hub, tho.
 
Joined
May 22, 2019
Messages
57
Motherboard
Dell 9020 SFF
CPU
i7 4770
Graphics
HD 4600
Wifi and Bluetooth

BCM94360CS2 Wifi/BT PCIe Adapter Card
Ebay.com (Win10 driver attached below)

Was there any tricks/kexts required to get this card working?
I've got WiFi working well but BT isn't detected. I have the BT header on the card plugged in to a external USB port via an adapter, but it isnt detected. Nothing shows in the USB tab in the hackintool app. Also, when I plug the USB in to a windows machine, I just see something about a descriptor error..blah, blah...and it cant read the device ID or anything. (Sorry, not infront of the computer at the moment.)

I'm thinking I may have a defective card, but wanted to check first.
 
Top