Contribute
Register

[SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

Joined
May 28, 2020
Messages
10
Motherboard
Aorus Z390 Pro WiFi
CPU
Intel i9-9900K
Graphics
Asus Radeon RX 580 8GB
Mac
  1. iMac
Hello @qadri,

We have intentionally disabled USB 2 protocol on all of the USB-C/TB3 ports in order to maintain a limit of 15 USB ports. Only USB 3 and Thunderbolt devices will work.

The USB-C cable that comes in the iPad Pro box does not support USB 3. You have 3 options:
  • Use any Thunderbolt 3 cable
  • Purchase a USB-C to USB-C cable that supports USB 3.x (see bottom of Note 5 below)
  • Use a USB-C to USB Type A cable that supports USB 3.x
This is explained in the Catalina build guides as follows:

View attachment 473598
Thank you very much MR CaseySJ for helping me. You are a great man
 
Joined
Feb 7, 2014
Messages
33
Motherboard
Gigabyte Designare Z390
CPU
i5 9600K
Graphics
2x RX580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
OK, so I have followed the guides, and I borrowed a Raspberry Pi and bought the clips and cables. ( I also have a degree in computer engineering and have written many linux kernel modules so I'm not a newbie ). I am following updated supplemental Procedure. I have tried the following command:

sudo flashrom -p linux_spi:dev=dev/spidev0.0,spispeed=1024 -r Designare.bin

1591238681741.png


So I think I followed the directions wiring the system up...
1591239783751.png

1591239809153.png


But I can't seem to get the chip to reply... Any tips?

@jb007 - can you comment on this post? - I've triple checked my connections and tried reducing the speed value on the spi bus to no avail. Please and thank you :)
 
Last edited:
Joined
May 31, 2016
Messages
998
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Just installed the opencore bootloader on an USB thumb drive for some testing. Worked the first time, thanks to the very clear mini guide in this thread. Well done!

Now, can someone remind me of the improvements compared to Clover?

According to them, these:

 
Joined
May 31, 2020
Messages
19
Motherboard
ASUS ProArt Z490
CPU
i9-10900K
Graphics
RX 5700 XT
@CaseySJ and @NorthAmTransAm

@tonymacx86 is getting this motherboard and will put together a Build Description.

I, too, am sorely tempted to get this motherboard.

Hi Stork, when do you expect to have a build description for the ProArt Z490? I am a beginner in Hackintosh, and I tried to install mac on my i9-10900K + ProArt Z490 + RX 5700XT build, but I am always stuck at the boot. I attached the OpenCore log below. I tried all the options I could think of, but no luck. I am really hoping you guys could help me out and get the build description soon. Thank you in advance!
 

Attachments

  • opencore-2020-06-03-191816.txt
    256 KB · Views: 52
Joined
May 31, 2016
Messages
998
Motherboard
Gigabyte Z490 Vision G
CPU
i9-10900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. PowerBook
  2. Quadra
Mobile Phone
  1. iOS
Hi Stork, when do you expect to have a build description for the ProArt Z490? I am a beginner in Hackintosh, and I tried to install mac on my i9-10900K + ProArt Z490 + RX 5700XT build, but I am always stuck at the boot. I attached the OpenCore log below. I tried all the options I could think of, but no luck. I am really hoping you guys could help me out and get the build description soon. Thank you in advance!

Not to jump in, but have you worked through this?

 
Joined
May 31, 2020
Messages
19
Motherboard
ASUS ProArt Z490
CPU
i9-10900K
Graphics
RX 5700 XT
not to jump in, but have you worked through this?


Hi canyondust,

Yes, I have followed the instructions to make my plist. I also copied the plist file from a success ASUS Z490 build (yilmazca - Asus-prime-Z490A-hackintosh), but no luck at all. I attached my EFI zip file below, I would really appreciate if you could take a look for me. Thanks!

(**UPDATE) I found an interesting error that the error message says it couldn't find "\_SB.PCI0.XHC.RHUB", however in my DSDT, I can only find "\_SB_.PCI0.XHC_.RHUB. *" ('*' could be INIR, PS0X, PS2X, PS3X). But I don't know how can I correct the naming to match what I have on my motherboard.

IMG_1401.jpg
 

Attachments

  • EFI.zip
    1.9 MB · Views: 43
Last edited:
Joined
Jan 25, 2020
Messages
51
Motherboard
Gigabyte X99 Designare-EX
CPU
E5 1660 V3
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Hello @Elias64Fr,

Just got a chance to examine your modified NVM 50. Regarding SubsystemID, are you referring to these three bytes? If so, does this make a functional difference or a cosmetic difference on the Designare Z390? In other words, if these 3 bytes are not changed, what effect do you observe?
View attachment 473393
Hi, @CaseySJ
What app is this, can you tell me? I want to research my own firmware.
Thanks!
 
Joined
May 15, 2020
Messages
1,300
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KF
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Hi guys,
I'm using AdGuard (paid licence) to block ads (tonymacx is on my whitelist), it works really good on my MacBook Pro and an old iMac. But it doesn't on my hackinotsh. I contacted AdGuard support service I sent them debug logs of the app and they told me this:
Screenshot 2020-06-04 at 09.38.15.png

Do you have any idea why this not working on the hackinotsh? I installed using the May Update 2020 with 10.15.4 fresh install guide.
Iv not installed any antivirus or network monitoring app.
 
Last edited:

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,198
*** OpenCore 0.5.7 / 0.5.8 / 0.5.9 Mini-Guide for Designare Z390 ***

can i use this ^^^ guide also to build my first dualboot hackintosh but with Mojave and not Catalina:
Z390 Designare
i9 9900k
vega 56 (or rx590 it depends what I can get due to the out of stocks of radeon cards here)
G.Skill Aegis DIMM Kit 32GB, DDR4-3200
Crucial P1 SSD 1TB, M.2
Samsung evo850 1tb (for win10)
Corsair TX-M Series Modular TX750M

I want to go open core bc all say its the future, its harder to setup but i would go over it.
 
Joined
Jun 1, 2019
Messages
13
Motherboard
Designare Z390
CPU
9900
Graphics
Radeon VII
Sure, it's a good idea to see if the bootable backup disk still works.

Also try CMOS Reset and configure BIOS parameters once again. This will also require unlocking MSR 0xE2 if it was previously unlocked.
Last night, the system failed to start after I cleared CMOS. I then started the system with a backup and replaced it with OsxAptioFix2Drv-free2000.efi, and the system started normally. I'll unlock CFG your way right away. Replace it again with the OcQuirks.efi three-piece set. OK, my Mojave's back. However, the usb drive still can't start as my upgrade, the same display kernel crashes
 

Attachments

  • IMG_7313.JPG
    IMG_7313.JPG
    201.9 KB · Views: 23
  • IMG_7315.JPG
    IMG_7315.JPG
    187.2 KB · Views: 25
Top