Contribute
Register

Stuck at Missing Bluetooth Controller Transport!

Joined
Oct 6, 2013
Messages
9
Motherboard
MSI Z87 G45
CPU
i5-4670K
Graphics
Intel HD 4600
Mac
Mac Pro
Classic Mac
Mobile Phone
Android, iOS
Can someone help me? I installed OS X on my hard drive after I patched my BIOS using pmpatch but when I tried to boot from it, it stuck at Missing Bluetooth Controller Transport.

I've tried to boot with;
-v
-f
GraphicsEnabler=No

but still failed.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,146
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
Can someone help me? I installed OS X on my hard drive after I patched my BIOS using pmpatch but when I tried to boot from it, it stuck at Missing Bluetooth Controller Transport.

I've tried to boot with;
-v
-f
GraphicsEnabler=No

but still failed.
Your gfx is probably not initializing. Try boot with -v -x
 
Joined
Aug 28, 2012
Messages
21
Motherboard
Gigabyte GA-B75M-D3P
CPU
Core i3-3225 Ivy Bridge 3.3GHz
Graphics
Intel HD Graphics 4000
Mac
Classic Mac
Mobile Phone
Your gfx is probably not initializing. Try boot with -v -x
Thanks!

I was having the same issue (Stuck at Missing Bluetooth Controller Transport) but I am able to boot successfully using -v -x

What do I have to change to prevent me from having to enter this command at each boot? Thanks!

10.8.5
 
Joined
Jul 16, 2012
Messages
47
Motherboard
Gigabyte Z77-DS3H
CPU
I7-3770
Graphics
GTX 1050 Ti
Mac
iMac, Mac mini
Classic Mac
iBook, iMac, Plus, PowerBook
Mobile Phone
iOS
Stuck at Missing Bluetooth Controller Transport! SOLVED!

I solved the problem with the missing bluetooth controller transport with the following from InsanelyMac Legend rlf:

Boot -s. When you see the prompt "root:", then:


Type: mount -uw /
Type: cd /System/Library/Extensions
Type: mkdir intel_back
Type: mv AppleIntelHD* AppleIntelF* intel_back/
Type: touch ../Extensions


Reboot -v
 
Joined
Sep 4, 2013
Messages
35
Motherboard
ASUS Sabertooth x79
CPU
i7-3930K
Graphics
GTX 980ti
Mac
Mac Pro
Can someone help me? I installed OS X on my hard drive after I patched my BIOS using pmpatch but when I tried to boot from it, it stuck at Missing Bluetooth Controller Transport.

I've tried to boot with;
-v
-f
GraphicsEnabler=No

but still failed.
[SUCCESS]

[TROUBLESHOOTING 10.8.5]

Hi there...I just updated to 10.8.5 from 10.7.4 and had similar issue where it would say Missing Bluetooth Controller Transport but after waiting for about a minute the loading would continue.
However, I would get to home screen and the system would freeze. After some research I found out that in 10.8.5 if you are using npci= key you must set it to npci=0x2000 instead of npci=0x3000. Again this is 10.8.5 version of Mountain Lion we are talking about. In your case it might be different.

npci=0x2000 could solve the Still waiting for Root Device issue

I use the following boot flags in order to successfully boot on 10.5.8
darkwake=0 npci=0x2000 PCIRootUID=1 GraphicsEnabler=No -v



org.chameleon.Boot.plist
<key>GraphicsEnabler</key>
<string>No</string>
<key>Kernel Flags</key>
<string>darkwake=0 npci=0x2000 PCIRootUID=1 GraphicsEnabler=No -v</string>

*note I have two GraphicsEnabler=No. One as a separate key. This helped prevent issues were GraphicsEnabler=No would not register using <key>Kernel Flags</key> parameter.


If you can't get pass the boot try using -x (Safe Mode) and see if you can at least get to the home screen and navigate.

[MORE ADVICE FOR THOSE OF YOU TRYING TO SUCCESSFULLY BOOT]

Here are some additional steps that will help improve performance and stability of your system


VoodooTSCSync.kext fixes cpus=1 (enables all cores)
EvOverboot.kext fixes the issues were attempting restart would cause the system to hang on startup.
 
Joined
Sep 23, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
GA-H61N-USB motherboard
I3-3245 HD 4000 cpu
through DVI connection

After you install the 1st half of mavericks it will restart, if you boot -v it will show bluetooth missing transport or so. restart computer and boot -v

Be patient, the 2nd half of Mavericks installation should resume now, after that you can go ahead and install your drivers(Kexts).

I launched Miltibeast and loaded my kexts, I was still getting a hang at bluetooth missing transport.

I went into System/Library/Extentions, I got rid of anything with the word bluetooth in it, didn't work.
I then deleted anything with the word ATI, INTELHDXXXX, AMD, NVIDIA, things listed as graphics...
EXCLUDING for the ones my system was going to be using which were the INTEL HD4000.

That solved my problem and was able to boot in Mavericks without an issue.

*under safe mode it should list your gfx that were picked up like it showed me, that's how I knew what to eliminate aside from knowing I had the HD4000 in specs.*...APPLE LOGO>ABOUT THIS MAC>MORE INFO... and look for GRAPHICS.
 
Joined
Jul 4, 2013
Messages
1
Motherboard
GA-Z77-DS3H Rev. 1.1
CPU
Intel i5 3570K 3.40 Ghz
Graphics
GeForce GTX 650
Mac
iMac
Classic Mac
Mobile Phone
**SOLVED - I was able to restore from a Time Machine Backup within the Installer and was able to boot then***

I am running into the same issue. I have tried everything mentioned but the problem persists (including removing the graphics kexts). I verbose boot (-v) and get to the "Missing Bluetooth Controller Transport!" message.

After a short time the following appears:
flow_divert_kctl_disconnect (0): disconnecting group 1

And eventually:
Resetting IOCatalogue.
considerRebuildOfPrelinkedKernel prebuild rebuild has expired

I have tried countless flags (-v, -x, -f, GraphicsEnabler=Yes/No, PCIRootUID=Yes/No, dart=0), but I am still not able to boot at all. I have even tried removing my graphics card and booting off the Intel HD4000 integrated graphics, but still no boot.

The installation went by flawless and I have installed Mac OSX on my previous two hard drives, but needed an upgrade.

Are there any more flags I should try to boot with? Or, is there another process I should follow? Any ideas?

Thanks in advance!
 
Joined
Jul 24, 2011
Messages
2
Motherboard
GA-Z87X-UDH3
CPU
I7-4790K
Graphics
HD 4600
Mac
iMac, Mac Pro
Worked for me as well... Thanks
 
Joined
Jul 18, 2011
Messages
66
Motherboard
Gigabyte x99 gaming 5
CPU
i7-5620K
Graphics
1080-Ti
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I solved the problem with the missing bluetooth controller transport with the following from InsanelyMac Legend rlf:

Boot -s. When you see the prompt "root:", then:


Type: mount -uw /
Type: cd /System/Library/Extensions
Type: mkdir intel_back
Type: mv AppleIntelHD* AppleIntelF* intel_back/
Type: touch ../Extensions


Reboot -v
After doing this my hard drive will not show up at startup just the installer.
 
Top