Contribute
Register

OpenCore FAKE ID/GPU SPOOF R9-290 FAILED

Status
Not open for further replies.
Joined
Feb 12, 2018
Messages
6
Motherboard
ASUS Z97-WS
CPU
i7-4770
Graphics
R9-290
Tried so many inject ways from clover to open core.
I don't think I can make any further investment anymore.

Long story short:
I'm using OpenCore, followed This Guide to install Mojave 10.14.6.
Trying to FakeID R9 290 with SSDT GPU SPOOF guide. FAILED.
My final goal is getting iGPU headless acceleration and dGPU for primary display.
My motherboard has PLX PCI-Bridge on it which using a standard SSDT GPU SPOOF will fake the PEGP(PCI-Bridge) device-id not GPU.
I can get my GFX0 to IGPU rename and IGPU headless acceleration working.
Currently stuck on finding ways to specify my real GPU path to inject FakeID using SSDT patch.
About My Mac says Display 5MB no Framebuffer nor X4000 kexts loaded.
Any method are welcome!
See the attachment for IOReg, config.plist, screenshots, SSDT, etc.

Very long story of me trying different kind of methods:
My Specs:
CPU - Intel i7-4770
MOBO - ASUS Z97-WS
RAM - Kingston 1600 8Gx2
GPU - Gigabyte R9-290 4GB Windforce

Using Clover at first, tried InjectATI, modify Kexts, FakeID 67b1/67b0,FB Name(Hawaii, Radeon, Baladi), Lilu/WhateverGreen, patch Framebuffer(in 8000 Controller and from clover's ATI connector patch), switch between BIOS PEG/PCIE and CPU Multimonitor On/Off.
Got my card detected as AMD Radeon R9 390/290 5 MB.

Decided to try OpenCore.
I followed this guide for installing.
I only used IGPU for installing, almost every steps are followed from the guide.

A screenshot of my IOREG (Full IOReg attach below).
Screen Shot 2020-05-03 at 5.55.08 AM.png


1.I don't need HDMI audio for now so some files I attached, the hda settings may missing.
2.AMD8000Controller.kext, AMDRadeonX4000.kext, AMDRadeonX4000HWServices.kext's IOPCIMatch are added 0x67B11002.


Method 1.
OpenCore SSDT GPU spoof with WhateverGreen, it inject ID to PEGP but my real graphics card is inside the pci-bridge.
My motherboard have a PLX PCI Bridge for the PCI slots.
So in the IOReg my GPU path are: PCI0>PEG0>PEGP>PCI-Bridge>display(or GFX0 if enable Whatevergreen)@0
From hacktool I saw my PCI-Bridge(PEGP) fakeid to 67B0.
Screen Shot 2020-05-04 at 10.11.26 PM.png

Before Injection

Screen Shot 2020-05-04 at 10.08.20 PM.png

After Injection

Attachment for this method is SSDT-GPU-SPOOF.aml.

Method 1a.
Basically is my GPU-SPOOF mixed with IGPU headless acceleration settings.

I found the Sample.dsl from WhateverGreen's Github.
I modify it to keep the IGPU section and adapt my settings from my SSDT-GPU-SPOOF and put the If (_OSI ("Darwin")) in it because I'm dual boot Windows.
Attachment for this method is SSDT-GPU-IGPU-290.aml.

Method 2.
I'm using hacktool to get my device path which is:
Mine: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)/Pci(0x10,0x0)/Pci(0x0,0x0)
I have tried the path from the article but still can't get it inject.
Attachment for this method is in config.plist.

Method 3.
SSDT GPU (Graphics Card) Injection
I thought I found some clues for my problem.
Because I'm just testing so I disable my IGPU and also exclude those iGPU Patching from it.
Turns out it just rename my PEGP@0 to GFX1@0 and the PCI-Bridge@10 are still there.
I knew this is more a Nvidia tutorial but I thought I can modify it to fits my 290.
Attachment for this method is SSDT-REPLACEPEGP.aml.

That pretty much is all my research for these days.
Really looking for someone can solve my problems, also English is not my native language, I'm very sorry if you feel pain reading this.

Thanks Everyone!:lol:

Note: EFI.zip is my current EFI partition.
 

Attachments

  • SSDT-GPU-IGPU-290.aml
    501 bytes · Views: 273
  • SSDT-GPU-SPOOF.aml
    263 bytes · Views: 330
  • SSDT-REPLACEPEGP.aml
    373 bytes · Views: 231
  • EFI.zip
    986.8 KB · Views: 234
  • config.plist
    18.5 KB · Views: 267
  • katropod’s iMac.ioreg
    47.7 MB · Views: 198
  • Screen Shot 2020-05-04 at 10.08.20 PM.png
    Screen Shot 2020-05-04 at 10.08.20 PM.png
    295.3 KB · Views: 209
Last edited:
Joined
Dec 18, 2020
Messages
7
Motherboard
hp z240sff
CPU
e3-1280v6
Graphics
amd r7
I'm use R5 430/R7 240 dGPU only with intel E3 CPU , also looking for the GPU FakeID or SSDT-GPU-SPOOF way to enable it.
 
Joined
May 11, 2011
Messages
2,374
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Have you added the address path say of your PCI Bridge host controller to your config.plist? Some of the other parts of the system devices may be necessary for your GPU to be recognised in system.
 
Joined
Feb 12, 2018
Messages
6
Motherboard
ASUS Z97-WS
CPU
i7-4770
Graphics
R9-290
Have you added the address path say of your PCI Bridge host controller to your config.plist? Some of the other parts of the system devices may be necessary for your GPU to be recognised in system.
Thanks for the advice! Unfortunately I can't do further research since my 290 has stopped working a while ago. (Random Freeze):crazy:
So I bought an RX580 for my Hackintosh system and it's running OOB.
I guess my problem is going to be a mystery forever.:lol:
But I can confirm my card was functional at that time tho!
 
Joined
Feb 12, 2018
Messages
6
Motherboard
ASUS Z97-WS
CPU
i7-4770
Graphics
R9-290
I'm use R5 430/R7 240 dGPU only with intel E3 CPU , also looking for the GPU FakeID or SSDT-GPU-SPOOF way to enable it.
I have an E3-1230V2 machine, but with RX460.
As I remembered, I used to install Hackintosh on it with RX460, Clover, macOS HighSierra. Because of the native support for RX460, it's working OOB even in the macOS installer.
So, unfortunately I can't give you any advice.

Please let me know if you get to working!
 
Status
Not open for further replies.
Top