Contribute
Register

Opencore Catalina, stuck at BuildActDeviceEntry exit

Status
Not open for further replies.
Joined
Nov 11, 2019
Messages
7
Motherboard
haswell
CPU
intel i5
Graphics
intel hd4600 with Nvidia geforce 820m
Look
Got the same problem, on an HP ZBook. If I find any solutions, I'll let you guys know.

// Edit:

I tried removing the PS2 and I2C kexts, because I thought that an actuator might have something to do with it, now this was only my gut feeling. Then, the error has shifted to apple_apfs driver related stuff. So, whatever you change in your kext configuration, the error is just going to change it's face.

What I think is the issue here:
* EC not set up properly
* _OSI may need the XOSI reroute (_OSI to XOSI rename, then load SSDT-XOSI)

My EC seems to be usable as it is - but please check the dortania guide on how to patch EC. I just renamed EC0 to EC, since I think it'll do as it is and I don't need a fake one. After that, I did the whole _OSI business, and I can boot now, nice!

I hope this may help...
Look i am installing catalina in hp laptop. so as per dortania guide for you don't need to create a new EC rather patch it. So tell me, am i correct or not? And do i actually need the osi patch to xosi because i keyboard and trackpad are works on ps2.
 
Joined
Nov 11, 2019
Messages
7
Motherboard
haswell
CPU
intel i5
Graphics
intel hd4600 with Nvidia geforce 820m
Got the same problem, on an HP ZBook. If I find any solutions, I'll let you guys know.

// Edit:

I tried removing the PS2 and I2C kexts, because I thought that an actuator might have something to do with it, now this was only my gut feeling. Then, the error has shifted to apple_apfs driver related stuff. So, whatever you change in your kext configuration, the error is just going to change it's face.

What I think is the issue here:
* EC not set up properly
* _OSI may need the XOSI reroute (_OSI to XOSI rename, then load SSDT-XOSI)

My EC seems to be usable as it is - but please check the dortania guide on how to patch EC. I just renamed EC0 to EC, since I think it'll do as it is and I don't need a fake one. After that, I did the whole _OSI business, and I can boot now, nice!

I hope this may help...
What do you mean _OSI business
 
Joined
Mar 8, 2017
Messages
749
Motherboard
Lenovo ThinkPad T480s (OpenCore)
CPU
i7-8550U
Graphics
UHD 620, 2560x1440
Mobile Phone
  1. Android
@Summit

Whether or not you can keep your original EC device depends on it's properties. Dortania states what you need to look for. Easiest route is to just create a fake EC.

_OSI to XOSI with SSDT-XOSI can't harm you, from my experience. But if everything works, why bother?
 
Joined
Nov 11, 2019
Messages
7
Motherboard
haswell
CPU
intel i5
Graphics
intel hd4600 with Nvidia geforce 820m
@Summit

Whether or not you can keep your original EC device depends on it's properties. Dortania states what you need to look for. Easiest route is to just create a fake EC.

_OSI to XOSI with SSDT-XOSI can't harm you, from my experience. But if everything works, why bother?
Ok Thanks, And can you tell me, how to rename my EC, my EC device is H_EC. and Please can you share your EFI folder?.
 
Joined
Nov 11, 2019
Messages
7
Motherboard
haswell
CPU
intel i5
Graphics
intel hd4600 with Nvidia geforce 820m
I am able to boot just by adding UsbinjectAll.kext. Now its working fine.
 
Status
Not open for further replies.
Top