Contribute
Register

No Audio Devices - AppleHDA Realtek Audio

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS

Attachments

  • config.plist
    7.2 KB · Views: 81

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
May 11, 2017
Messages
158
Motherboard
MSI X299 SLI Plus
CPU
i7-7800X
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
AppleALC Kaby Lake audio controller patch is not working
Install attached config.plist
Restart, reply with new files
Thanks Toleda,

herewith the new files. Noticed changes on DPCI screenshot.
 

Attachments

  • 190130b.zip
    3 MB · Views: 19
Joined
May 11, 2017
Messages
158
Motherboard
MSI X299 SLI Plus
CPU
i7-7800X
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
AppleALC disabled controller patch
Install attached config.plist
Restart, reply with new files
Installed, here are new files
 

Attachments

  • 190131.zip
    3 MB · Views: 20
Joined
May 20, 2014
Messages
13
Motherboard
Gigabyte GA-Z87X-UD7 TH
CPU
i7-4771
Graphics
RX 590
Mac
  1. MacBook
Mobile Phone
  1. iOS
I do not see what is causing the problem
Suggest moving to AppleALC.kext,
See AppleHDA Realtek Audio/Post #1/
X. Uninstall AppleHDA Realtek Audio/2. MultiBeast ...
II. AppleHDA Realtek Audio Methods

Thanks so much Toleda. I now have working audio. I trashed my RealtekALC.kext file - I used multibeast to install AppleALC (which also installed Lilu.kext, which we had removed earlier) - I went into Clover Configurator and selected FixHDA (which I believe patches HDAS to HDEF? I don't really understand a lot of this in depth.) Clover was already set to inject Audio ID to 1. I rebooted and now I have my audio devices again.

All of your trouble shooting seemed to help me remove the junk and then get to a place where it works. Thanks for your time!
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
new files
Separate controller patch did not work
Replace existing kexts with attached
Replace existing config.plist with attached
Install FakePCIID.kext and FakePCIID-Intel-HDMI-Audio.kext
Install all kexts to /L/E with KextBeast
Restart
Terminal:
Code:
log show --predicate 'process == "kernel" AND (eventMessage CONTAINS "AppleALC" OR eventMessage CONTAINS "Lilu")' --style syslog --source --info --debug --last 1h
Reply with new files and Terminal output from log command
 

Attachments

  • config.plist
    7 KB · Views: 77
  • 1.3.5 (DEBUG).zip
    821.6 KB · Views: 28
  • Lilu.kext.zip
    312.9 KB · Views: 24

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
May 11, 2017
Messages
158
Motherboard
MSI X299 SLI Plus
CPU
i7-7800X
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Separate controller patch did not work
Replace existing kexts with attached
Replace existing config.plist with attached
Install FakePCIID.kext and FakePCIID-Intel-HDMI-Audio.kext
Install all kexts to /L/E with KextBeast
Restart
Terminal:
Code:
log show --predicate 'process == "kernel" AND (eventMessage CONTAINS "AppleALC" OR eventMessage CONTAINS "Lilu")' --style syslog --source --info --debug --last 1h
Reply with new files and Terminal output from log command

Thanks dude for all your help, really appreciate it.

Here are the new files.
 

Attachments

  • 190201.zip
    1.8 MB · Views: 23

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
new files
Debug log shows Lilu started but did not run and AppleALC is mia. Where were the kexts installed?
IOReg missing
Remove and reinstall Lilu and AppleALC
Restart, reply with new files
 
Last edited:
Top