Contribute
Register

No Audio Devices - AppleHDA Realtek Audio

Joined
Feb 13, 2013
Messages
18
Motherboard
Z370XP SLI
CPU
i7-8700K
Graphics
Radeon 7
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
1. No Output devices listed under Sound Preferences

2. macOS 10.14.3 / Gigabyte Z370XP SLI / F11 / i7 8700k / Vega 64 LC

3. Multibeast Procedure (AppleALC & 100 / 200 / 300 Series Audio Support)

4. Attached

5. Attached

6. Attached

7. Attached

8. Attached

9. DONE

Thanks in advance!
 

Attachments

  • No Sound.zip
    2.7 MB · Views: 36

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Feb 13, 2013
Messages
18
Motherboard
Z370XP SLI
CPU
i7-8700K
Graphics
Radeon 7
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Fix your profile
Did not remove High Sierra audio, see AppleHDA Realtek Audio/Post #1/X. Uninstall AppleHDA Realtek Audio/2. MultiBeast ...
Audio is now working properly. I had an issue, after Uninstalling AppleHDA Realtek Audio, updating Clover that required me to pull the boot drive and use MultiBeast again from my Mac laptop to reinstall everything to the boot drive, but it seems to have worked. With absolute respect and appreciation for your help to the community, I feel the Uninstall instructions are a bit difficult to understand, I'm still not sure I did it correctly, despite everything working current. Thanks for the help!

Dan
 
Joined
May 11, 2017
Messages
158
Motherboard
MSI X299 SLI Plus
CPU
i7-7800X
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
AppleALC: alc @ failed to obtain device info for analog controller (1)
Restore native AppleHDA:
a. run installer over existing install
b. extract AppleHDA.kext from installer with Pacifist
Install, restart, reply with new files

Extracted Vanilla AppleHDA from update 10.14.3
Installed AppleHDA into S/L/E using KextBeast.

Here are the new files.
 

Attachments

  • 190205.zip
    2.6 MB · Views: 59

toleda

Moderator
Joined
May 20, 2010
Messages
24,235
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Extracted Vanilla AppleHDA from update 10.14.3
Not vanilla, 500 KB missing/Resources should have 91 files, 1 file in the attached
Update only contains the files changed. Mojave installer is the only way to get native AppleHDA.kext
See Post #1701
 
Last edited:
Joined
May 16, 2018
Messages
68
Motherboard
ASRock Extreme 4
CPU
i7-8700k
Graphics
RX 560
Hi,
I'm having issues regarding to using microphone on build in inputs. I want to use apple earphone mic as input in logic pro and I have set both in mac and logic pro to use built in inputs and outputs.

I connect microphone and headphone input from the motherboard using audio splitter (so basically i want to use apple earphone as both input and output to record and listen) but that seem to not work. What am i doing wrong. The apple earphone definitely has no problem because i tried to record with it using my iphone voice memo. It works fine.

I have attached the splitter that i use to connect headphone and mic below.
385305
 
Joined
May 11, 2017
Messages
158
Motherboard
MSI X299 SLI Plus
CPU
i7-7800X
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Not vanilla, 500 KB missing/Resources should have 91 files, 1 file in the attached
Update only contains the files changed. Mojave installer is the only way to get native AppleHDA.kext
See Post #1701
Hey Toleda,

Pulled correct one from Mojave installer. Still no luck. Please find attached new files.
 

Attachments

  • 190206.zip
    3.1 MB · Views: 20
Top