Mouse + Keyboard not working during installation

Discussion in 'Mavericks Desktop Support' started by yonyz, Oct 23, 2013.

  1. yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Oct 23, 2013 at 10:14 PM #1
    yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Hi,

    I made a Unibeast USB for 10.9 and I am able to boot the installer using no DSDT and by typing npci=0x3000. Once I get to the installer, the mouse and keyboard (both are USB connected) do not work. I have a 1156 chipset motherboard and I tried using Legacy USB and it didn't help.

    If I copy my DSDT file to the Extra folder in the UniBeast USB, it gets stuck at PCI Configuration Begin, despite my use of the npci=0x3000 flag (I tried 0x2000 as well).

    Strangely, this appears to also be the case with my 10.8 USB. I don't know what changed that made the mouse and keyboard not work on that one. Could be that I was using some flags I forgot, though I did put them all in the Chameleon plist file.

    I also tried GraphicsEnabler=No, which didn't help.

    My PC:

    Intel i5 661
    Geforce GT 520 1GB
    lots of RAM
    GA-H55M-D2H (BIOS F4, which is the latest)
     
  2. neoolaf

    neoolaf

    Joined:
    Oct 22, 2013
    Messages:
    1
    Oct 23, 2013 at 10:25 PM #2
    neoolaf

    neoolaf

    Joined:
    Oct 22, 2013
    Messages:
    1
    mouse and keyboard to USB 3.0
     
  3. yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Oct 23, 2013 at 10:36 PM #3
    yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    My motherboard has no USB 3 ports, so USB 3 is not the problem.
     
  4. Acidfever

    Acidfever

    Joined:
    Nov 10, 2010
    Messages:
    2
    Motherboard:
    Gigabyte P55a UD4
    CPU:
    Core i7 960
    Graphics:
    Nvidia 8600GT passive
    Oct 23, 2013 at 11:03 PM #4
    Acidfever

    Acidfever

    Joined:
    Nov 10, 2010
    Messages:
    2
    Motherboard:
    Gigabyte P55a UD4
    CPU:
    Core i7 960
    Graphics:
    Nvidia 8600GT passive
    Copy your DSDT.aml in the hidden "Extra" folder on your unibeast usb drive.
     
  5. yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Oct 23, 2013 at 11:11 PM #5
    yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    You haven't fully read my original post. I said that I did try using my DSDT file in the Extra folder, but that makes the boot hang at "PCI configuration begins".

    I did make a bit of progress, though:
    I downloaded IOUSBFAMILY ROLLBACK for 10.8 and replaced it (deleted the original one of 10.9) and now, booting with DSDT=null (meaning the DSDT file is not being used), the keyboard works fine but the mouse still doesn't function, and I need both for the installation.
     
  6. Luke_BMM

    Luke_BMM

    Joined:
    Dec 1, 2010
    Messages:
    2
    Oct 24, 2013 at 2:56 PM #6
    Luke_BMM

    Luke_BMM

    Joined:
    Dec 1, 2010
    Messages:
    2
    Just in case anyone else stumbles across this thread, this was the cure for my particular frustration. I could get to the installation process, but just couldn't click the button. Infuriating.

    Older build with a GA-P55A-UD3 motherboard.
     
  7. dithy

    dithy

    Joined:
    May 16, 2011
    Messages:
    27
    Motherboard:
    Dell Inspiron 14 3442
    CPU:
    4th Generation Intel(R) Core(T M) i3-4005U
    Graphics:
    Intel® HD graphics 4400
    Oct 24, 2013 at 3:01 PM #7
    dithy

    dithy

    Joined:
    May 16, 2011
    Messages:
    27
    Motherboard:
    Dell Inspiron 14 3442
    CPU:
    4th Generation Intel(R) Core(T M) i3-4005U
    Graphics:
    Intel® HD graphics 4400
    try to add laptop support & legacy support in unibeast installation option.
     
  8. yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Oct 24, 2013 at 3:06 PM #8
    yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    I don't understand this "fix" - what exactly did you do?
     
  9. yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    Oct 24, 2013 at 3:07 PM #9
    yonyz

    yonyz

    Joined:
    Mar 10, 2012
    Messages:
    92
    CPU:
    i5-661
    Graphics:
    GT 520
    Mobile Phone:
    iOS
    I enabled legacy support (which installs the IOUSBFAMILY rollback kexts), and it didn't work. I also tried different versions of the IOUSBFAMILY kexts, to no avail. Time to try Laptop Support, though I believe it only has to do with PS2 keyboard, which I don't use.
     
  10. alcanfane

    alcanfane

    Joined:
    Jul 13, 2012
    Messages:
    141
    Motherboard:
    GA-Z370 HD3
    CPU:
    i5-8600
    Graphics:
    GTX 1050
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Oct 24, 2013 at 3:40 PM #10
    alcanfane

    alcanfane

    Joined:
    Jul 13, 2012
    Messages:
    141
    Motherboard:
    GA-Z370 HD3
    CPU:
    i5-8600
    Graphics:
    GTX 1050
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    I had this problem before with Mountain Lion. I solved it by delete ati6000 kext on the bootable drive, this helped in my case.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice