Contribute
Register

Mouse + Keyboard not working during installation

Joined
Oct 6, 2013
Messages
14
Motherboard
Gigabyte GA-P41T-D3
CPU
Intel Core 2 Quad
Graphics
NVIDIA GTX 560
Mac
Classic Mac
Mobile Phone
iOS
I too have this problem although it's the other way around.. My mouse works fine but the keyboard does not! Not even ps2 keyboard. Anyone help?
 
Joined
Jul 26, 2012
Messages
7
Motherboard
MacPro 3,1
CPU
i7 920
Graphics
Gigabyte GTX 460 OC
Mac
Classic Mac
Mobile Phone
I found a solution to it. just replace USB kext from ML. :thumbup:
edit: I mean I replaced both IOUSBFamily and IOUSBMassStorage
 
Joined
Mar 10, 2012
Messages
91
CPU
i5-661
Graphics
GT 520
Mobile Phone
iOS
phuong12 and alcanfane, could you please share your boot flags? I tried fixing permissions and all that with Kext Wizard but I still didn't get the mouse and keyboard to work when I booted with "-v". What other flags do I need?

And if you could share your graphics cards, that would help as well.
 
Joined
Jul 26, 2012
Messages
7
Motherboard
MacPro 3,1
CPU
i7 920
Graphics
Gigabyte GTX 460 OC
Mac
Classic Mac
Mobile Phone
phuong12 and alcanfane, could you please share your boot flags? I tried fixing permissions and all that with Kext Wizard but I still didn't get the mouse and keyboard to work when I booted with "-v". What other flags do I need?

And if you could share your graphics cards, that would help as well.
I booted in safe mode (-x). My graphics card is good old GTX 460 so I need GraphicsEnabler=YES and PCIRootUID=1
 
Joined
Mar 10, 2012
Messages
91
CPU
i5-661
Graphics
GT 520
Mobile Phone
iOS
OK. Can you please upload your aforementioned kext files that you got from ML?
 
Joined
Jul 26, 2012
Messages
7
Motherboard
MacPro 3,1
CPU
i7 920
Graphics
Gigabyte GTX 460 OC
Mac
Classic Mac
Mobile Phone
I'm not on mac os right now and having some works to do. You can try extracting those kexts from System\Library\Extensions of yr ML.
 
Joined
Mar 10, 2012
Messages
91
CPU
i5-661
Graphics
GT 520
Mobile Phone
iOS
I'm not on mac os right now and having some works to do. You can try extracting those kexts from System\Library\Extensions of yr ML.
I tried that before, that's why I wanted your files, in case I ever changed mine on ML.
Oh well, maybe the "-x" will make the difference.

Edit: No joy. I tried "-x GraphicsEnabler=Yes PCIRootUID=1" and then "-x GraphicsEnabler=No PCIRootUID=0" and in both cases I got the same problem, despite my replacement of the USB files with those of ML. Maybe I should remove the AMD6000 kext once again.
 

Joe

Joined
May 7, 2010
Messages
42
Motherboard
Mac OS X Lion
CPU
Core i3 Clarkdale
Graphics
Nvidia 8600GT
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I've got a similar motherboard, the S2H, and the same problem as well. I've also moved the ML kexts over with no success either.

Edit: Tried the "Copy your DSDT.aml in the hidden "Extra" folder on your unibeast usb drive." tip above and it seemed to work.
 
Joined
May 12, 2011
Messages
50
Motherboard
Gigabyte GA-Z270X-Ultra Gaming
CPU
i7-7700K
Graphics
RX 580
Mac
MacBook Air, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I have a GA-H55M-UD2H mobo and I was also having problems with the Mavericks install screen and my mouse and keyboard not working. I used the DSDT method and took a copy of my DSDT file from my ML Extra's folder and placed it in the USB Maverick's installation Extra's folder and it worked! Both keyboard and mouse were working and installation went without a hitch. Currently working in Mavericks.
 
Top