Contribute
Register

[Guide] Razer Blade 15 (2018) Detailed Install Guide High Sierra 10.13.6 (17G2208-17G5019)

Joined
Dec 8, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Here is the most recent information on the trackpad for base model.
Im not sure if this would work or even how to implement this, maybe you have more info on this.



Code:
Return (ConcatenateResTemplate (I2CM (I2CX, BADR, SPED), SBFI))
I'm not 100% on this, but using @Razeriste DSDT from his PR files, I believe the first attached screenshot is what your current DSDT looks like.
The second attached screenshot is what it should look like given the instructions from ben9923 on the VoodooI2C thread.

Again I'm not 100% that this is what he means, but test it and see what happens.
 

Attachments

  • Screen Shot 2019-01-04 at 10.20.05 AM.png
    Screen Shot 2019-01-04 at 10.20.05 AM.png
    177.8 KB · Views: 65
  • Screen Shot 2019-01-04 at 10.18.52 AM.png
    Screen Shot 2019-01-04 at 10.18.52 AM.png
    160.8 KB · Views: 61
Joined
Dec 2, 2018
Messages
23
Motherboard
Razer Blade 15 - 2018 - Base
CPU
i7-8750H
Graphics
UHD 630/GTX 1060
I'm not 100% on this, but using @Razeriste DSDT from his PR files, I believe the first attached screenshot is what your current DSDT looks like.
The second attached screenshot is what it should look like given the instructions from ben9923 on the VoodooI2C thread.

Again I'm not 100% that this is what he means, but test it and see what happens.
Is this while still using the original patch from this guide?
 
Joined
Oct 27, 2015
Messages
94
Motherboard
EliteBook 850 G2
CPU
i7-5500U
Graphics
HD5500
If there is something going on with your patched DSDT all you would have to do is reboot and when you get to Clover hit F2 and F4 so it dumps fresh DSDT and SSDT files and then boot back into OSX and disassemble the new files and then repatch your fresh DSDT and add it back into your ACPI Patched folder.

That would take care of any of your DSDT issues that might be causing your sleep issue.

Yeah, I've done that a few times. Maybe I'm just misunderstanding the current status. You said in one of your previous posts that 95% of your boots were good after your BIOS update to 1.06. So you're saying, at this point, I shouldn't expect backlight to work on every boot? And that there will be random hangs on boot every now and then? If that's the case, then yeah dumping and re patching has helped things.
 
Last edited:
Joined
Dec 8, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Is this while still using the original patch from this guide?
As far as I'm aware, yes. Just take your already patched DSDT and just edit that one section that's show in the screenshots and test. If it doesn't work, generate PR files and post it back to the VoodooI2C thread and see what Ben says.
 
Joined
Dec 8, 2011
Messages
545
Motherboard
Razer Blade 15 - Clover
CPU
i7-8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Yeah, I've done that a few times. Maybe I'm just misunderstanding the current status. You said in one of your previous posts that 95% of your boots were good after your BIOS update to 1.06. So you're saying, at this point, I shouldn't expect backlight to work on every boot? And that there will be random hangs on boot every now and then? If that's the case, then yeah dumping and re patching has helped things.
Even with the 1.05 BIOS backlight at boot wasn't 100%, that is why I have yet to update the guide for it. I'm still waiting for the issue to be 100% fixed. But it's pretty much there.
But to answer your question overall, yes. Don't expect backlight to work at every boot for the time being. And yes, sometimes you will get random hangs upon boot, it's a WhateverGreen bug with the Framebuffer Patching. But it should only happen once in a while.

But you should have working sleep with and without Nvidia disabled, working trackpad, battery status and brightness. All of the basics should work as intended.

The last few issues are pretty much related to WhateverGreen and waiting for it to be updated once it's figured out why the black screen bug is so hit or miss.

There is another bug that I'm trying to sort myself. I don't know if maybe the 1.06 BIOS has taken care of it or not, or if a couple of other things I have tried has. Today will be the big test. The bug is, after 4.5-5.5 hours of constant use, the laptop will randomly start to shut itself down, but before it finishes the shutdown sequence it will freeze. Nobody else has reported this, it seems that I was the only one that has had it thus far. If you want to do some more test, use the laptop for a long period of time, don't put it to sleep or shut it down. If you're not going to use it, leave the lid open and the screen on, it can go to screensaver, but just make sure it's set to never go to sleep. See if you have the same bug.
 
Joined
Dec 20, 2018
Messages
23
Motherboard
Razer Blade 15 2018
CPU
I7 8750H
Graphics
UHD 630/GTX 1060 - 1920x1080
I'm not 100% on this, but using @Razeriste DSDT from his PR files, I believe the first attached screenshot is what your current DSDT looks like.
The second attached screenshot is what it should look like given the instructions from ben9923 on the VoodooI2C thread.

Again I'm not 100% that this is what he means, but test it and see what happens.

Good to see you again. ;)
 
Joined
Oct 7, 2017
Messages
11
Motherboard
MSI P65 Laptop-Clover
CPU
i7-8750H
Graphics
GTX 1070
Good catches. Updated to reflect.
I did this all by memory, I'm surprised that's all I forgot to add and the one thing I messed up lol.

Thanks for the writeup @vettz500

Couple of things:

-remove "[/LIST][/INDENT]" from the touchpad patch
-should mention that fast boot and secure boot both need to be disabled

Where do I edit this??
 
Joined
Oct 7, 2017
Messages
11
Motherboard
MSI P65 Laptop-Clover
CPU
i7-8750H
Graphics
GTX 1070
  1. Once you are in Clover tap on the F2 key and then tap the F4 key.
    • 1.1.Do so again with the F2 and F4 keys, this time holding down the fn key on the keyboard.
  2. Now select your OSX Installation and let it boot. Your screen will go black as soon as it starts to boot. This normal and is okay.
    This is the ONE AND ONLY MAJOR BUG with this laptop and is currently being worked on.
    Shine a flash right on the screen to see what it's doing, you should be able to see the Apple Logo go to the login screen. Once it gets to the login screen, shut the lid/screen of the laptop and wait for the logo light to shut off and then open the lid, the backlight should be working now.

When I did this, I just get a black screen and it just stays black. It did not go into apple logo or load anything. Do I tap f2 and f4 separately and then hold fn and select osx installation from the usb? Very confused about this. What does this do and what I'm doing wrong here?
 
Joined
Oct 27, 2015
Messages
94
Motherboard
EliteBook 850 G2
CPU
i7-5500U
Graphics
HD5500
When I did this, I just get a black screen and it just stays black. It did not go into apple logo or load anything. Do I tap f2 and f4 separately and then hold fn and select osx installation from the usb? Very confused about this. What does this do and what I'm doing wrong here?

Did you install clover to the drive you installed MacOS on? When you start your computer you should be booting into clover automatically, without your USB installer. You'll have two options, booting MacOS or Recovery. At that screen you press F2 once. Then press F4 once. Afterwards Hold FN then press F2 once. Keep holding FN then Press F4 once.
 
Top