Contribute
Register

[Guide] HP Elite 8300 & 6300 Pro (all form factors) using Clover UEFI hotpatch

Joined
Oct 23, 2020
Messages
45
Motherboard
HP Elite 6300 Pro SFF
CPU
i5-3470S
Graphics
GT 710
That's what comes up on samsung 'Upday' News Thingy (Damn Samsung)
 
Joined
Jan 5, 2015
Messages
5
Motherboard
HP Elite 6300 Pro SFF
CPU
i7-3770
Graphics
Intel HD Graphics 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I succesfully upgraded my HP 6300 SFF, i7-3770, HD 4000 from Catalina to Big Sur (no clean installation, I need my files, so formatting is not a valid option).

Preparations for Big Sur:

1) Replaced my old Clover EFI folder with the OC folder provided by Sniki.
2) OC boots OK on Catalina, bye WIN10 boot option from old Clover (I can boot WIN10 OK pressing F9 and selecting the proper disk after OC shows up).
3) Changed the SMBIOS in config.plist to MacPro6,1 with GenSMBIOS, then rebooted.
4) booted OK with new SMBIOS, then Big Sur is downloaded from App Store.

Installation:

5) Ran the installation app, failed at min 22 -> black screen with Apple logo, then jumped to log-in window.
6) Ran the installation app again, the progress bar reached 100% and failed to restart -> black screen with Apple logo, then jumped to log-in window.
7) I did a manual restart to see if the Boot macOS Install option showed up in the OC boot screen but it didn't.
8) The same step 6 situation is repeated in the next 5 tries.

Solution:

9) Downloaded these kexts (Lilu, VirtualSMC, WhateverGreen, IntelMausi and AppleALC) and replaced the ones provided by Sniki, then rebooted.
10) The Boot macOS Install appeared now in OC boot options, this is the first time that it showed up after multiple reboots in the process. Chose this option, the installation continues. SUCCESS!

Screenshot 2020-12-27 at 14.43.41.png
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
19,915
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
5) Ran the installation app, failed at min 22 -> black screen with Apple logo, then jumped to log-in window.
6) Ran the installation app again, the progress bar reached 100% and failed to restart -> black screen with Apple logo, then jumped to log-in window.
7) I did a manual restart to see if the Boot macOS Install option showed up in the OC boot screen but it didn't.
8) The same step 6 situation is repeated in the next 5 tries.
Did you clear/clean the NVRAM before installing Big Sur ?
 
Joined
Jan 5, 2015
Messages
5
Motherboard
HP Elite 6300 Pro SFF
CPU
i7-3770
Graphics
Intel HD Graphics 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Did you clear/clean the NVRAM before installing Big Sur ?
Yes, in every reboot. No effect before replacing kexts.
 
Joined
Nov 23, 2020
Messages
4
Motherboard
HP 6300 SFF
CPU
i7-3770
Graphics
ZOTAC GeForce GT 710
Can someone tell me if my system is Big Sur compatible? Is there a tutorial like there was for Mojave?

I'm currently running Catalina 10.15.7 on a 6300 SFF, i7-3770, 24GB RAM, with a ZOTAC GeForce GT 710 graphics card.
 
Joined
Oct 7, 2015
Messages
42
Motherboard
Intel Q77
CPU
I7-3770
Graphics
HD4000
Mobile Phone
  1. iOS
  2. Other
Can someone tell me if my system is Big Sur compatible? Is there a tutorial like there was for Mojave?

I'm currently running Catalina 10.15.7 on a 6300 SFF, i7-3770, 24GB RAM, with a ZOTAC GeForce GT 710 graphics card.
If you are newbie try this

 
Joined
Feb 1, 2011
Messages
99
Motherboard
8300 SFF iMac15,1
CPU
3.4 GHz Quad-Core Intel Core i7
Graphics
Radeon RX 560 4 GB
Mobile Phone
  1. iOS
Joined
Nov 23, 2020
Messages
4
Motherboard
HP 6300 SFF
CPU
i7-3770
Graphics
ZOTAC GeForce GT 710
Thanks guys. Yeah, I am a newbie, however, I have successfully upgraded 3 times (going from Mojave to Catalina) since I first built mac system. nguyendj is that tutorial the same as this YouTube video?

Also, can I follow this tutorial to upgrade to OpenCore before attempting to upgrade to Big Sur? I think I am supposed to use this this EFI folder instead, correct?
 
Last edited:
Top