Contribute
Register

CustoMacMini 2014 - Intel NUC Haswell i5-4250U - Sierra

Joined
Mar 17, 2019
Messages
2
Motherboard
Intel NUC 54250WYK
CPU
i5-4250
Graphics
HD 5000
This is a great forum and people are supportive.

I built my first first Hackintosh (Mojave) successfully with peppe1945's Clover.zip on a NUC 54250WYK.

My problem is, Chrome and Firefox do not render properly and show blank screens for all websites. I searched a while and the posts I found were all related to font smoothing, antialiasing, which seems to be different from my issue.

Any idea?
Thanks.
 

Attachments

Joined
Oct 23, 2010
Messages
301
Motherboard
z68a-d3-b3
CPU
i7-3770k
Graphics
GTX 650
This is a great forum and people are supportive.

I built my first first Hackintosh (Mojave) successfully with peppe1945's Clover.zip on a NUC 54250WYK.

My problem is, Chrome and Firefox do not render properly and show blank screens for all websites. I searched a while and the posts I found were all related to font smoothing, antialiasing, which seems to be different from my issue.

Any idea?
Thanks.

Hi, change your integrated graphics memory to 128mb in the bios.. I had mine set to 64mb and that fixed this issue for
me. :)
 
Last edited:
Joined
Mar 17, 2019
Messages
2
Motherboard
Intel NUC 54250WYK
CPU
i5-4250
Graphics
HD 5000
Hi, change your integrated graphics memory to 128mb in the bios.. I had mine set to 64mb and that fixed this issue for
me. :)
Thank you very much Elite2k. It worked! I must have overlooked this requirement documented somewhere. You are awesome and I am very glad people in this forum are very helpful and supportive!
 
Joined
Sep 13, 2012
Messages
35
Motherboard
INTEL D54250WYKH2
CPU
i5-4250U
Graphics
HD 5000
Mobile Phone
Android
Here we go, again.
10.15 Beta (19A536g) works flawlessly. Settings are provided below the screenshot.
Screenshot 2019-08-29 at 14.21.07.png


Prerequisites
Bootloader
Clover_v2.5k_r5058/pkg

-Clover for UEFI booting only
-Install Clover in the ESP
-UEFI Drivers

ApfsDriverLoader.efi
OsxAptioFix3Drv.efi
VBoxHfs.efi

ACPI/Patched:
SSDT-HACK.aml
SSDT-IGPU.aml
SSDT-USB.aml
SSDT.aml

Kexts/Other:
AppleALC.kext
FakeSMC.kext
IntelMausiEthernet.kext
Lilu.kext
WhateverGreen.kext

Clover:
-Acpi:
HDAS-HDEF
SAT0-SATA
MEI-IMEI
HECI-IMEI
EHC1 to EH01
H_EC to EC

FixShutdown
addMCHC
fixHPET
fixIPIC
fixSBUS
fixAirport

-Boot:
dart=0
kext-dev-mode=1
-lilubetaall
-alcbeta
-lilubeta

-Devices
Audio
Inject 1
 
Joined
Sep 6, 2013
Messages
2
Motherboard
win7
CPU
T6670
Graphics
G105m
Mac
Mac mini
Classic Mac
Mobile Phone
Here we go, again.
10.15 Beta (19A536g) works flawlessly. Settings are provided below the screenshot.
View attachment 423617

Prerequisites
Bootloader
Clover_v2.5k_r5058/pkg

-Clover for UEFI booting only
-Install Clover in the ESP
-UEFI Drivers

ApfsDriverLoader.efi
OsxAptioFix3Drv.efi
VBoxHfs.efi

ACPI/Patched:
SSDT-HACK.aml
SSDT-IGPU.aml
SSDT-USB.aml
SSDT.aml

Kexts/Other:
AppleALC.kext
FakeSMC.kext
IntelMausiEthernet.kext
Lilu.kext
WhateverGreen.kext

Clover:
-Acpi:
HDAS-HDEF
SAT0-SATA
MEI-IMEI
HECI-IMEI
EHC1 to EH01
H_EC to EC

FixShutdown
addMCHC
fixHPET
fixIPIC
fixSBUS
fixAirport

-Boot:
dart=0
kext-dev-mode=1
-lilubetaall
-alcbeta
-lilubeta

-Devices
Audio
Inject 1
Here we go, again.
10.15 Beta (19A536g) works flawlessly. Settings are provided below the screenshot.
View attachment 423617

Prerequisites
Bootloader
Clover_v2.5k_r5058/pkg

-Clover for UEFI booting only
-Install Clover in the ESP
-UEFI Drivers

ApfsDriverLoader.efi
OsxAptioFix3Drv.efi
VBoxHfs.efi

ACPI/Patched:
SSDT-HACK.aml
SSDT-IGPU.aml
SSDT-USB.aml
SSDT.aml

Kexts/Other:
AppleALC.kext
FakeSMC.kext
IntelMausiEthernet.kext
Lilu.kext
WhateverGreen.kext

Clover:
-Acpi:
HDAS-HDEF
SAT0-SATA
MEI-IMEI
HECI-IMEI
EHC1 to EH01
H_EC to EC

FixShutdown
addMCHC
fixHPET
fixIPIC
fixSBUS
fixAirport

-Boot:
dart=0
kext-dev-mode=1
-lilubetaall
-alcbeta
-lilubeta

-Devices
Audio
Inject 1
would u please upload your EFI?
 
Joined
Oct 11, 2019
Messages
8
Motherboard
mac mini
CPU
i5
Graphics
intel
I've just update my nuc machine to osx mojave.
Audio, QE/CI, LAN, USB, sleep/wakeup: all appear good.
Here my clover folder.
I just updated update Mojave directly from Sierra. I don't have Audio after the update, I have the message "Could not load Sound preference pane".
I checked what peppe1945 did in his config file.
I have the following:
- clover 5070
- I have used SMCHelper, ApfsDriverLoader, OsxAPTIOFix3Drv
- AppleALC.kext ver 1.4.2
- Lilu.kext ver 1.3.8
- WhateverGreen.kext ver 1.3.3

I am open to your suggestions.

Thanks in advance!
 
Joined
Apr 25, 2011
Messages
21
Motherboard
Intel NUC8i5beb
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
Mac mini
I just updated update Mojave directly from Sierra. I don't have Audio after the update, I have the message "Could not load Sound preference pane".
I checked what peppe1945 did in his config file.
I have the following:
- clover 5070
- I have used SMCHelper, ApfsDriverLoader, OsxAPTIOFix3Drv
- AppleALC.kext ver 1.4.2
- Lilu.kext ver 1.3.8
- WhateverGreen.kext ver 1.3.3

I am open to your suggestions.

Thanks in advance!
Please,
try one of the two:
1. put "Yes" the "InjectKexts" parameter in config.plist file
2. copy all kext (updated version should be OK) from Clover/kext/other to /Library/Extensions and rebuild kernel cache.

I prefer second method and I use the first one as parachute.

I hope this solve your problem.
 
Joined
Oct 11, 2019
Messages
8
Motherboard
mac mini
CPU
i5
Graphics
intel
Please,
try one of the two:
1. put "Yes" the "InjectKexts" parameter in config.plist file
2. copy all kext (updated version should be OK) from Clover/kext/other to /Library/Extensions and rebuild kernel cache.

I prefer second method and I use the first one as parachute.

I hope this solve your problem.
Thanks for looking into this!

I did the 2nd method, I played also with the 1st one, it didn't help.
I wonder if there are some other kexts in /L/E that matters. Thoughts?


One more observation after the update, the safari became sluggish, like sites like apple.com and even worse, the reuters.com, takes for ever ...
Do you have a similar observation on your machine?

Thank you!
 
Joined
Oct 11, 2019
Messages
8
Motherboard
mac mini
CPU
i5
Graphics
intel
Hi,

I collected the added kexts and I was checking looking into the System Report -> Software -> Extensions:
AirportBrcmFixup.kext - ver 2.0.3​
AppleALC.kext - ver 1.4.2​
BrcmFirmwareRepo.kext - ver 2.2.10​
BrcmPatchRAM2.kext - ver 2.2.10​
FakeSMC_ACPISensors.kext - ver 626-357-gceb835ea.100​
FakeSMC_CPUSensors.kext - ver 626-357-gceb835ea.100​
FakeSMC_GPUSensors.kext - ver 626-357-gceb835ea.100​
FakeSMC_LPCSensors.kext - ver 626-357-gceb835ea.100​
FakeSMC_SMMSensors.kext - ver 626-357-gceb835ea.100​
GenericUSBXHCI.kext - ver 1.2.11​
IntelMausEthernet.kext - ver 2.4.0​
Lilu.kext - ver 1.3.8​
NightAhiftUnlocker.kext - ver 2.2.1​
USBInjectAll.kext - ver 0.7.1​
WhateverGreen.kext - ver 1.3.3​

Is something that might cause audio problem?

I tried also the clover files supplied by you (peppe1945), trying to follow as close your config (different serial and uuid) ...

Please advise.

Thanks in advance!
 
Joined
Oct 11, 2019
Messages
8
Motherboard
mac mini
CPU
i5
Graphics
intel
One more info, not long time ago I updated the Bios and I got the WY0054.bio update.
What you have?

Thanks!
 
Top