Contribute
Register

CustoMacMini 2014 - Intel NUC Haswell i5-4250U - Sierra

Joined
Sep 17, 2010
Messages
18
Motherboard
NUC D54250WYKH
CPU
i5
Graphics
Intel IGP
@ethermcman & @Serg716
Hi guys, I am on short vacations at the Adriatic coast and I will reply to you ASAP.:)

EDIT: my EFI is now in the attached zip file. I hope that helps. Note that you don't need IntelGraphicsFixup.kext anymore because WhateverGreen does its task. Also update your Clover to the most recent version and don't forget to rebuild your caches:

sudo touch /System/Library/Extensions && sudo kextcache -u /

the above is taken from here: Rebuilding kernel cache
The Adriatic, such a nice place!!!
Whatever, thanks for posting you're conf. I'll take a look and report here.
 
Joined
Sep 17, 2010
Messages
18
Motherboard
NUC D54250WYKH
CPU
i5
Graphics
Intel IGP
@gorila
Hide your SN in your config.plist ;)
Use only one OsxAptio*drv.efi
And you can bypass apfs.efi by using ApfsDriverLoader-64.efi and PartitionDxe-64.efi
With the latest version of Clover, you can avoid the use of the folder drivers64.
 
Last edited:
Joined
Sep 13, 2012
Messages
35
Motherboard
INTEL D54250WYKH2
CPU
i5-4250U
Graphics
HD 5000
Mobile Phone
Android
Thanks for your advices mate. I will follow your advices to make my little giant feels closer to the real mac. I also have forgotten to do what you did: now, I have enabled trim just like you did, literally, to the letter as you did. Now my both drives perform much better. This is exactly why I love this "Hack" community: in contrast to the global divisive trend, people here tend to collaborate and help each other. It seems that Hackintoshers are a very special kind. We shall survive. :)
Regarding your EFI from the previous page, I would like to offer my humble advice: get rid of woodoo audio. Uninstall it entirely and remove Shiki. Perhaps everything related to audio and start from the stratch, including these boot args : -lilubetaall -igfxbeta. Dump them alltogether. They arent needed anymore. AppleHDA, Lilu and WhateverGreen have matured enough to use them directly, at least on our "thiny giants".
Have a pleasant week end.
 
Joined
May 1, 2010
Messages
387
Motherboard
motherboard or system make & model # > See Rules!
CPU
Intel> Need model # > See Rules!
Graphics
Graphics > model # > See Rules!
Mac
Mac mini
Mobile Phone
iOS
I've just update my nuc machine to osx mojave.
Audio, QE/CI, LAN, USB, sleep/wakeup: all appear good.
Here my clover folder.
Thanks for sharing !
(for information the audio codec previously used in no longer supported in Mojave ... just install AppleALC + Lilu to get audio)
 
Joined
Mar 30, 2011
Messages
27
Motherboard
GA-Z97MX GAMING 5
CPU
i5 4440
Graphics
GT 610
Mac
MacBook, MacBook Air, Mac mini
Mobile Phone
Android, iOS
I am using Haswell Nuc D34010WYKH with latest 042 bios. So far, I have not even been able to boot a USB install disk.

Can anyone share their EFI folder?

I have installed mojave with peppe1945's EFI folder. However, the display has problem which no display driver detected.
Any idea? Machine model: (D34010WYKH)
 
Joined
Apr 25, 2011
Messages
21
Motherboard
Intel NUC8i5beb
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
Mac mini
I have installed mojave with peppe1945's EFI folder. However, the display has problem which no display driver detected.
Any idea? Machine model: (D34010WYKH)
Hi,
my machine is little different (D54520WYK) I think you should make changes in config.plist and add some kexts.
Please try to follow Rehabman guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
and in particular:
https://www.tonymacx86.com/threads/fix-hd4200-hd4400-hd4600-hd5600-on-10-11.175797/
I hope these are useful...
 
Joined
Nov 15, 2018
Messages
1
Does anybody else have any issues with their bluetooth audio being choppy/laggy? I used a BCM943225hmb card and have both wifi and bluetooth working(Just laggy) While looking through the forms I noticed it may be related to Rehabman's guide for creating a SSDT for usbinjextall.kext. But I haven't had much success making the correct SSDT for the problem I suppose. If anybody has any tips on this issue please let me know.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,528
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@TylerDavis3292, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Mar 17, 2019
Messages
3
Motherboard
NUC8i5BEH
CPU
i3-8259u
Graphics
Iris Plus Graphics 655
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
This is a great forum and people are supportive.

I built my first first Hackintosh (Mojave) successfully with peppe1945's Clover.zip on a NUC 54250WYK.

My problem is, Chrome and Firefox do not render properly and show blank screens for all websites. I searched a while and the posts I found were all related to font smoothing, antialiasing, which seems to be different from my issue.

Any idea?
Thanks.
 

Attachments

Top