Contribute
Register

Try to install Lilu for Audio - High Sierra not booting if Lilu.kext installed

Status
Not open for further replies.
Joined
Nov 9, 2018
Messages
7
Motherboard
Lenovo T440S
CPU
i5-4300U
Graphics
HD 4400
Mobile Phone
  1. Android
Hi,

my first ever Hackintosh with High Sierra (followed the guides) is working very well except the sound isn't.
To fix it I've read I should use Lilu + AppleALC.
I've followed this guide from the forum and also some others threads like the iDiot for Lilu guide.

If I install Lilu.kext (it's regardless if it's on Library/Extensions or EFI/CLOVER/kexts/Other) my computer does not boot anymore. After a long time it shows the prohibited sign.
I need to go in Recovery -> Terminal and manually delete Lilu, then it boots again.

I think I messed up a lot in my configuration with Clover Configurator and Multibeast.
I own a MSI Z270 Gaming Pro Carbon which uses the Realtek A1220 Codec for Audio.
Also an Intel i7700k and a Nvidia 1060 6GB.

I'm wondering, that it not crashed before, because in the guide the person uses VirtualSMC which needs Lilu I thought. I've installed it too and temporarily uninstalled FakeSMC and it worked. Now FakeSMC is installed again in Library/Extensions because of Multibeast.

Maybe someone can help me with the config? I've uploaded my zipped CLOVER folder, zipped Library/Extensions Folder and a photo from the verbose boot with Lilu.

Thanks in advance. If you need any further information please ask and I try to get & post them.

PS: Maybe after that someone can tell me how I can configure Clover not to scan user entries etc. So it only has, say Windows and macOS + Recovery. I saw the settings in Clover Configurator but I'm a noob and can't get it.
 

Attachments

  • IMG_20190217_214553.jpg
    IMG_20190217_214553.jpg
    933.3 KB · Views: 104
  • CLOVER.zip
    1.6 MB · Views: 142
  • Extensions.zip
    12.8 MB · Views: 107

toleda

Moderator
Joined
May 19, 2010
Messages
22,928
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I'm wondering, that it not crashed before, because in the guide the person uses VirtualSMC which needs Lilu I thought. I've installed it too and temporarily uninstalled FakeSMC and it worked. Now FakeSMC is installed again in Library/Extensions because of Multibeast.
No an audio problem, off topic.
Maybe after that someone can tell me how I can configure Clover not to scan user entries etc. So it only has, say Windows and macOS + Recovery. I saw the settings in Clover Configurator but I'm a noob and can't get it.
No an audio problem, off topic.
Fix the boot issue, post new files with the audio problem only.
 
Status
Not open for further replies.
Top