Contribute
Register

The Dell OptiMac Big Sur/OpenCore Thread - For 7020/9020 Optiplex Desktops

Joined
Feb 8, 2012
Messages
26
Motherboard
Dell Optiplex 9020
CPU
i7 4790
Graphics
HD 4600
Mac
  1. iMac
Mobile Phone
  1. iOS
Great! Thank you all.
 
Joined
Dec 1, 2019
Messages
8
Motherboard
Dell Optiplex 9020
CPU
i7 4770
Graphics
RX 580
Mobile Phone
  1. iOS
I have managed to transition over to OC and install/boot Big Sur using a combo of this guide and Zearp's GitHub thread, However i am unable to get the i7 4770's iGPU to run in headless, being a novice to OC i'm unsure were i have gone wrong. or if it is at all possible to get headless to work with pre refresh processors on SMBIOS 15.1, I have set bios DVMT to 64MB and tried deleting the whole PciRoot...0x2... child hoping WhateverGreen automatically configures this to no avail.

I also have very little experience with Hackintool so i'm unsure if their is a work around using this tool to patch it?

Screenshot 2020-09-10 at 2.03.09 pm.png
 
Joined
Dec 1, 2019
Messages
8
Motherboard
Dell Optiplex 9020
CPU
i7 4770
Graphics
RX 580
Mobile Phone
  1. iOS
Thanks for the prompt response, I will try that config now. I concluded headless is inoperable from the VDA Decoder state in Hackintool and no iGPU data displayed in Intel Power Gadget.
Screenshot 2020-09-10 at 2.45.30 pm.png
 
Joined
Dec 1, 2019
Messages
8
Motherboard
Dell Optiplex 9020
CPU
i7 4770
Graphics
RX 580
Mobile Phone
  1. iOS
AAPL,ig-platform-id set to 04001204 should be all that it takes.
How are you determining whether iGPU is running headless or not ?

This has still given me VDA Decoder Failed
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,446
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
This has still given me VDA Decoder Failed
Did you create your own config.plist via the Dortania guide or just use the one from Zearp ? If you followed Zearp's GitHub thread there may be some things tailored to using HD4600 exclusively instead of a dedicated gfx card with iGPU running headless. I haven't looked at that in great detail yet. Will take some going over your config.plist to see what is keeping it from working. I'm off to work now, so won't be able to assist till later this evening or tomorrow.
 
Joined
Dec 1, 2019
Messages
8
Motherboard
Dell Optiplex 9020
CPU
i7 4770
Graphics
RX 580
Mobile Phone
  1. iOS
Did you create your own config.plist via the Dortania guide or just use the one from Zearp ? If you followed Zearp's GitHub thread there may be some things tailored to using HD4600 exclusively instead of a dedicated gfx card with iGPU running headless. I haven't looked at that in great detail yet. Will take some going over your config.plist to see what is keeping it from working. I'm off to work now, so won't be able to assist till later this evening or tomorrow.

Take care!

I have resolved the issue by double checking my BIOS settings and finding;
  • Primary Display Adapter -> AUTO
  • Multi-Monitor Mode -> Disabled
After changing these to;
  • Primary Display Adapter -> dGPU
  • Multi-Monitor Mode -> Enabled
with AAPL,ig-platform-id set to 04001204 VDA Decoder is now Fully Supported.

Screenshot 2020-09-10 at 3.37.30 pm.png


I used jaymonkey's Lilu guide you previous linked on the Golden Build to find this was the cause of my problems.
https://www.tonymacx86.com/threads/an-idiots-guide-to-lilu-and-its-plug-ins.260063/


Thanks trs for your help!

I tried following the Dortania guide but it would hang up on boot with "PCI configuration end.... \n Couldn't alloc class" or "ifnet_attach: all kernal threads created for interface lo0... proceeding". I have no idea what any of this means?

So i followed Zearp's thread starting with a naked 9020MT using his complete EFI, This thread for bios mods, Installed Catalina, Following Zearp's USB portmap to remap the 9020MT so i can use the internal USB header, I then proceeded to build upon his config.plist to suite my needs whilst installing my hardware (dGPU, NVMe...) updating to the latest release of opencore. along with updating to the newest kexts. Then finally upgrading OSX to the Big Sur beta

I have attached my current EFI that seems to have everything working (i've not tested integrated audio as i have a USB DAC), Though the USB mapping (USBPorts.kext) is still quirky as i've only mapped one of the front USB 3 headers as in my set up i have converted the 2 Dell USB3's into USB2's and only utilise 1 USB3 port because i have a funky 5.25" SD card reader that has a usb3 port, In hindsight I should have used the USB3 to USB2 adaptor on this port maintaining 2 front USB3 ports, enabling me to map these properly.

IMG_0497.jpg


This is a screenshot of my USB mapping, HS11 and SSP1 is the missing front USB3 port.
Screenshot 2020-09-10 at 4.49.53 pm.png
 

Attachments

  • Bibo's Dell 9020 OC EFI.zip
    6.7 MB · Views: 227
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,446
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
This is a screenshot of my USB mapping, HS11 and SSP1 is the missing front USB3 port.
You are still at 14 USB ports so I would try to add that front USB 3 port to your USBports kext. The HS11 is not that important. I would want to have both front USB 3 ports functional. If you don't really need it, that's fine too. Otherwise your EFI looks good if you're not using the internal Realtek audio for anything.
 
Joined
Dec 1, 2019
Messages
8
Motherboard
Dell Optiplex 9020
CPU
i7 4770
Graphics
RX 580
Mobile Phone
  1. iOS
You are still at 14 USB ports so I would try to add that front USB 3 port to your USBports kext. The HS11 is not that important. I would want to have both front USB 3 ports functional. If you don't really need it, that's fine too. Otherwise your EFI looks good if you're not using the internal Realtek audio for anything.

Thanks for taking a look, All physical usb ports are functional in my set up because of the way i have laid them out, Though was more of a warning to others, I have drew a block diagram because it's not the easiest thing to explain.
Screenshot 2020-09-11 at 9.38.13 am.png

I used another PC case front I/O for mapping the internal USB2 header, So didn't map using the hub as i'd read this can cause all sorts of issues.

Thanks for the heads up on the Audio, I've changed this to layout 13 and deleted the boot-args override.

I really appreciate your time Trs, Again thank you so much!
 
Last edited:

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,446
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
All physical usb ports are functional in my set up because of the way i have laid them out, Though was more of a warning to others.
Thanks, this helps make a point about the uniqueness of each person's OptiMac. Even with the exact same machine, the Optiplex 7020/9020, there will be many variations to take into account. Whether integrated graphics or a dedicated GPU is used and whether it's an SFF or MT model will call for some important differences in BIOS setup, USB configuration and the config.plist. The latter, especially when using OpenCore. This is why it's really important to not simply copy/paste an EFI folder found online. OptiMac owners need to understand how this all works to have an Optimally configured system. Pun intended. So again, great job on the case modding and doing the work to figure out what works for your unique system.
 
Top