Contribute
Register

(Success) (NO PATCHES) Yosemite ASRock Fatal1ty H87 Performance + Xeon E3 1231 V3 + R9 280

Joined
Dec 18, 2013
Messages
11
Mac
Classic Mac
Mobile Phone
My specs:

ASRock Fatal1ty H87 Performance
Xeon E3 1231 V3
Asus AMD R9 280
2x4GB Kingston HyperX RAM
500GB PNY SSD

Hello! I installed Yosemite yesterday with UniBeast and everything is working now, sleep too!

I'M NOT INSTALLED PMPATCH OR KERNEL PATCHES. I DIDN'T NEED TO EDIT MY DSDT!

I used flags "GraphicsEnabler=No -v" on install. Then I formatted my Mavericks partition and installed yosemite. :beachball:

When it booted to OS X, I installed Chimera and I needed to use "Basic boot options" on MultiBeast to get org.chameleon.boot.plist.

ADD "kext-dev-mode=1" flag to kernel flags in org.chameleon.Boot.plist! Because before I used this, my Network wasn't working when I installed FakeSMC to boot system. And when I installed network kexts, computer didn't boot. So i needed to reinstall Yosemite and I added flag kext-dev-mode=1 and then everything worked.

After that, if your sound is not working, install ALC1150 from MultiBeast and if network is not working then install AppleIntelE1000e v3.1.0 kext. If your network isn't working after that, go to Settings > Network > and press Use button on bottom right corner of window.

Now everything is working, sleep too! It takes ~30 seconds to fully shut power off on reboot too. It's only "problem" but it does not bother me. :mrgreen:

Graphics card is not fully supported so it gives low FPS on some games and sometimes when I turn PC on it shows static noise/snow on screen. But that happens only on sometimes. So I don't suggest you to buy this graphics card if you want to play games on Mac OS X side.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,632
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Before using another audio driver from an earlier MultiBeast, see this post as Yosemite has changed it's audio output settings.
 
Joined
Dec 18, 2013
Messages
11
Mac
Classic Mac
Mobile Phone
I'm not sure how internal ALC1150 is working with Yosemite, because I got external USB sound card. The sound crackled little bit with ALC1150 on Mavericks....
 
Joined
Aug 19, 2014
Messages
5
Motherboard
i5
CPU
4670k
Graphics
gtx770
Mac
Classic Mac
Mobile Phone
Congrats to your success! I have the same motherboard, but with haswell cpu, even the installer freezes..
Tried changing some bios settings (secure mode disable, c states, etc), no luck so far.
 
Joined
Jun 4, 2013
Messages
4
Motherboard
AsRock Fatal1ty H87 Performance
CPU
i7-4770
Graphics
GTX 750 Ti
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Got it working.

ASRock Fatal1ty H87 Performance
Haswell i7 4770 (not K)
4gb x 2 Corsair RAM
SSD Samsung EVO 840
Integrated Graphics HD 4600 (my old Radeon 6870 exploded :problem:)
Ps: Dual Display

Installed using UniBeast, no flags needed, Then MultiBeast. the only thing that wasn't working was the Ethernet, then I used AppleIntelE1000e v3.1.0. Win.

Attached is my MultiBeast config
 

Attachments

  • MultiBeast Config.mb
    5 KB · Views: 261
Top