Contribute
Register

[READ ME FIRST!] Graphics Setup & Troubleshooting

Joined
Aug 18, 2011
Messages
409
Motherboard
ASUS Z390-I Gaming
CPU
i5-9600K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
2. AMD Radeon Graphics Cards

Basic Setup
AMD Radeon drivers are always included in OS X. You'll always find the most recent drivers in the latest OS X release, there's no other official place to download them. You might come across some patched or backported Kexts, but we'd advice against using them for stability reasons.
If you've ever installed on of those kexts, restore the original OS X drivers by reinstalling the latest Combo Update.

To get started, boot up without any graphics related settings in your config file:
Clover: InjectAti=False (FBName/VideoPorts unnecessary)
Chimera/Chameleon: GraphicsEnabler=No (AtiConfig/AtiPorts unnecessary)

If you have a OOB supported graphics card, OS X will boot with full acceleration. Done!
This 'straightforward' approach doesn't work for me.:banghead:


I recently purchased the Sapphire Pulse RX580, hoping to be able to change my NVidia GFX 950 and get a boot to Mojave from the High Sierra 10.13.6 OS I have running now. It's been a nightmare. I can't boot anything, USB Installer, the working OS SSD, nothing. It just freezes.

I have posted here, post 2588,
Radeon Compatibility Guide - ATI/AMD Graphics Cards

discussing the problem I'm seeing. No advice yet helps. It must be some simple Clover setting as this freeze occurs as kexts are being loaded.

Any help here?
 
Joined
Jul 13, 2014
Messages
33
Motherboard
Z87X-OC
CPU
i5-4690K OC 4.4 Ghz
Graphics
GTX 1060
Mac
MacBook Pro
Dear hackintosh experts,
I am unsure when this occured, but I am pretty sure it was after the latest high sierra update.
Prior to that, my GTX 1060 was working smoothly with nvidia web drivers and acceleration enabled.
But now, it's not. I can still access my mac through screen sharing, and I discover that my screen is recognized as "built-in display" but obviously, my screen stays black.
Via screen sharing I can see that the GPU is correctly recognized, the Nvidia web drivers are enabled, and that acceleration is clearly functional (Chrome is not blinking).
Could you help me find a way to fix this? I have tried reverting to a clone of my hdd when it was working, but I still have the issue. I reverted to numerous backup version of config.plist as well as clover EFI and kexts with no luck. Tried to install lulu and whatevergreen but didn't make any improvement.
Kinda desperate here... hence my post. What would you need from me to help me out?
Best
 
Joined
Oct 28, 2010
Messages
131
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX570
This 'straightforward' approach doesn't work for me.:banghead:


I recently purchased the Sapphire Pulse RX580, hoping to be able to change my NVidia GFX 950 and get a boot to Mojave from the High Sierra 10.13.6 OS I have running now. It's been a nightmare. I can't boot anything, USB Installer, the working OS SSD, nothing. It just freezes.

I have posted here, post 2588,
Radeon Compatibility Guide - ATI/AMD Graphics Cards

discussing the problem I'm seeing. No advice yet helps. It must be some simple Clover setting as this freeze occurs as kexts are being loaded.

Any help here?
Yea, this never worked for me either. My issue is wake after sleep. All the usual fixes don’t really work. For "OOB" my RX570 has been nothing but a hassle.

You might want to try RadeonDeinit=YES and use darkwake=2 or 10. I'm not entirely sure which one will work or why (despite having read the explanation here https://www.tonymacx86.com/threads/...-break-auto-sleep-in-10-8-1.69714/post-447117)

EDIT 02-22-19
I think I have finally figured it out. darkwake=8 works for my set-up. Have been able to wake from sleep several times. Screen comes on almost immediately after a single key press.
 
Last edited:
Joined
Jun 4, 2017
Messages
13
Motherboard
ASUS H81M-CS
CPU
i3-4130
Graphics
HD 4400
Mac
iMac
Mobile Phone
Android, iOS
I'm using a Monitor with only one VGA port and my motherboard has also one VGA port for the Display but I am using onboard integrated Haswell Intel HD 4400 graphics . I was unable to enable graphics acceleration on my Hackintosh Mojave at all .Please help me and show me a way to enable graphics.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,387
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I'm using a Monitor with only one VGA port and my motherboard has also one VGA port for the Display
Apple have not used VGA in their products for more than ten years so unsurprisingly they do not include support for it in their operating system(s).
 
Joined
Jun 4, 2017
Messages
13
Motherboard
ASUS H81M-CS
CPU
i3-4130
Graphics
HD 4400
Mac
iMac
Mobile Phone
Android, iOS
Apple have not used VGA in their products for more than ten years so unsurprisingly they do not include support for it in their operating system(s).
So is there any unofficial way to manually enable graphics for my VGA display.
 
Last edited:
Joined
Jun 4, 2017
Messages
13
Motherboard
ASUS H81M-CS
CPU
i3-4130
Graphics
HD 4400
Mac
iMac
Mobile Phone
Android, iOS
Finally I was successfully able to install a hackintosh on my PC after buying a new Nvidia graphics card. But it didn't ended well. As soon as I've restarted my PC it was stuck at the ASUS boot logo and both mouse and keyboard freezed. Thus I can't open my pc, neither can I go to the BIOS settings. Please help and give me any solution.
 
Joined
Jun 4, 2017
Messages
13
Motherboard
ASUS H81M-CS
CPU
i3-4130
Graphics
HD 4400
Mac
iMac
Mobile Phone
Android, iOS
What is the best compatible internal WiFi card for hackintosh?
 
Joined
Mar 7, 2016
Messages
52
Motherboard
GA-X99-UD4P
CPU
E5 1650 v3
Graphics
GV-N970G1 GAMING-4GD
Mac
MacBook Pro
It's been very hassle to upgrade my card from GTX 970 to Zotac GTX 1070. With fresh 10.13.6 (17G65) Install still getting boot loop from the drive.

While booting from the USB to the High Sierra drive, the Nvidia webdrivers seem to be working :crazy: Any explanation?
 

Attachments

Top