Contribute
Register

Random panics on boot

Status
Not open for further replies.
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
Hello!

To be honest... I don't understand how something like this can happen at all. Why do panics occur randomly? Shouldn't the system be in a definite state all the time? Or maybe it has something to do with the state it gets put in when shutting down...

Okay, now to the topic:

Before those panics, the cause of the earlier ones (as far as I could read them) was the CodecCommander kext. I've deleted every kext which had something to do with audio, since that won't really work on my system natively anyways (I either use USB C headphones or an external sound-card, I've wasted enough time on audio, maybe going back later...).

Now the panic seems to stem from the broadcom NIC? What? That worked flawlessly in the past and does to this day! I really don't understand how this happens... It's not that hindering (since it takes a max. of 3 boot tries until I am in a fully running (except audio, lol) hackintosh system), but it really p!$$es me off that I'm not able to resolve this.

I've attached two images of the panics (since it doesn't seem to get logged into any file, which I also don't understand) and the PR-files (debug).
Thank you guys a lot for helping me out again, this forum is amazing! It's what got me started and interested.

Yours,
BlvckBytes
 

Attachments

  • debug_12960.zip
    1.7 MB · Views: 70
  • IMG_20191031_154623.jpg
    IMG_20191031_154623.jpg
    1.7 MB · Views: 75
  • IMG_20191031_154828.jpg
    IMG_20191031_154828.jpg
    1.8 MB · Views: 62
Joined
Dec 20, 2018
Messages
744
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
try disabling vbox
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@Mrgeque

What do you mean by "vbox"? Sry, but I don't know what to change.
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@Feartech, @Mrgeque

Oooh, right... I'm sorry :D. Removed it (didn't really need it anyways). Also, today I finally had time to update my Hackintosh to 10.14.6 (formerly 10.14.3), so it's the last Mojave version ever released. Catalina is something I'm not considering at this point in time since I'd like to keep 32b support :)

With those two changes I'm curious if some new panics will appear. If so, I am going to post them here, thanks for now, guys! :)
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
Sadly, today I noticed that my hackintosh was stuck while booting, but no panic was visible. I can't really make any sense of the output :/ Also, I don't see any proof of kext names which could cause this in the verbose output, maybe audio-related stuff though.

PR Files attatched, with the image of -v output.
 

Attachments

  • debug_5893.zip
    5.9 MB · Views: 69
  • IMG_20191106_210500.jpg
    5.5 MB · Views: 50

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,519
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sadly, today I noticed that my hackintosh was stuck while booting, but no panic was visible. I can't really make any sense of the output :/ Also, I don't see any proof of kext names which could cause this in the verbose output, maybe audio-related stuff though.

PR Files attatched, with the image of -v output.
lilufriend.kext shouldn't be needed in clover

config.plist:
debug=0x100 can be removed

try disabling this:
Code:
<key>FixHDA</key>
                <true/>
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@Feartech

So, lilufriend.kext should be in /L/E? Or do you mean remove totally? I think something is dependent on that... Or maybe thats not the case anymore, as I didn't read the changelog of many kext updates :(.

Then, debug=0x100 is the flag which stops a reboot on panic, right? I need that in order to make these fotos.

And FixHDA is now disabled, if this will help will show itself over time, thank you! :)
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,519
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
@Feartech

So, lilufriend.kext should be in /L/E? Or do you mean remove totally? I think something is dependent on that... Or maybe thats not the case anymore, as I didn't read the changelog of many kext updates :(.

Then, debug=0x100 is the flag which stops a reboot on panic, right? I need that in order to make these fotos.

And FixHDA is now disabled, if this will help will show itself over time, thank you! :)
lilufriend is only needed when you install all your kexts to /L/E

you have all your kexts in clover so it is not needed, remove
 
Joined
Mar 8, 2017
Messages
763
Motherboard
Dell XPS 9700 4K (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 3840x2400
Mobile Phone
  1. Android
@Feartech

Thank you for your fast and helpful replies, I've now uninstalled lilufriend.kext and disabled FixHDA. We'll see how that configuration works out, I'm going to post again if some errors occur.
 
Status
Not open for further replies.
Top