Contribute
Register

install hackintosh high sierra on Acer Aspire 5750g

Status
Not open for further replies.
Joined
Dec 5, 2017
Messages
1
Hello everyone, I would need some help from you. Today I wanted to install on my old PC: Acer 5750g (i5 2410m CPU, 4gb RAM, Nvidia GT520m GPU) hackintosh High Sierra. After creating the key, I insert it in my old PC (Legacy boot) is created the Clover boot, but, when I start the installer of high sierra, appears the Apple logo without progress bar, and, after 2 minutes, the PC is restarted, and started doing the same thing again. I have seen around to try to put in the settings of Clover -v to see the error, but having put -v no longer display the logo but only a - at the top that flashes that after 2 minutes disappear and the PC restarts. I do not think it's a problem of incompatibility because I saw on YouTube that the same model of my PC has already been done. What do you recommend?
 
Last edited by a moderator:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello everyone, I would need some help from you. Today I wanted to install on my old PC: Acer 5750g (i5 2410m CPU, 4gb RAM, Nvidia GT520m GPU) hackintosh High Sierra. After creating the key, I insert it in my old PC (Legacy boot) is created the Clover boot, but, when I start the installer of high sierra, appears the Apple logo without progress bar, and, after 2 minutes, the PC is restarted, and started doing the same thing again. I have seen around to try to put in the settings of Clover -v to see the error, but having put -v no longer display the logo but only a - at the top that flashes that after 2 minutes disappear and the PC restarts. I do not think it's a problem of incompatibility because I saw on YouTube that the same model of my PC has already been done. What do you recommend?

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Also, your profile must be filled out as per FAQ. Please fix before your next reply.
 
Joined
Jul 2, 2015
Messages
14
Motherboard
Acer 5750G
CPU
i7 2670QM @ 2.2 GHz
Graphics
Intel HD3000 384 MB and GeForce 540M 1GB
Mobile Phone
  1. iOS
Hi RehabMan, I need your help. I installed HIGH SIERRA on my ACER 5750G (I7 2670QM, Intel HD Graphics 3000 384 MB, GeForce 540M with 1GB, 6GB of RAM, SSD with 240 GB). All seem to work correctly but there are the following issues:
- STOP/WAKE doesn't work
- SHUTDOWN doesn't work (the PC restarts!)
- Often the Windows Manager freezes and it is needed to turn off the pc.

I am using the following kexts:[/SIZE]
- FakeSMC.kext in /Volumes/EFI/EFI/CLOVER/kexts/Other

while the following are in /Library/Extensions:
> ACPIBatteryManager.kext
> FakePCIID_BCM57XX_as_BCM57765.kext
> FakePCIID.kext
> GenericUSBXHCI.kext
> IONetworkingFamily.kext
> ProBookAtheros.kext

Moreover in the /System/Library/Extensions there are:
- VoodooHDA.kext
- AppleHDADisabler.kext

I attach DSDT, SSDT and the config.plist files so that the configuration i am using is completelly described. Please can you suggest how i could solve the above listed issues?
 

Attachments

  • DSDT.aml
    36.6 KB · Views: 388
  • SSDT.aml
    1.7 KB · Views: 399
  • config.plist
    5.1 KB · Views: 325

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMan, I need your help. I installed HIGH SIERRA on my ACER 5750G (I7 2670QM, Intel HD Graphics 3000 384 MB, GeForce 540M with 1GB, 6GB of RAM, SSD with 240 GB). All seem to work correctly but there are the following issues:
- STOP/WAKE doesn't work
- SHUTDOWN doesn't work (the PC restarts!)
- Often the Windows Manager freezes and it is needed to turn off the pc.

I am using the following kexts:[/SIZE]
- FakeSMC.kext in /Volumes/EFI/EFI/CLOVER/kexts/Other

while the following are in /Library/Extensions:
> ACPIBatteryManager.kext
> FakePCIID_BCM57XX_as_BCM57765.kext
> FakePCIID.kext
> GenericUSBXHCI.kext
> IONetworkingFamily.kext
> ProBookAtheros.kext

Moreover in the /System/Library/Extensions there are:
- VoodooHDA.kext
- AppleHDADisabler.kext

I attach DSDT, SSDT and the config.plist files so that the configuration i am using is completelly described. Please can you suggest how i could solve the above listed issues?

You should not install patched kexts such as IONetworkingFamily.kext. Restore to vanilla.

"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jul 2, 2015
Messages
14
Motherboard
Acer 5750G
CPU
i7 2670QM @ 2.2 GHz
Graphics
Intel HD3000 384 MB and GeForce 540M 1GB
Mobile Phone
  1. iOS
You should not install patched kexts such as IONetworkingFamily.kext. Restore to vanilla.

"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.


Hi RehabMan, thank you for your feedback.
I generate Problems Report using the suggested script. The attached zip file contain all generated files.

What does "Restore to vanilla" means?

thank you again for your help.
 

Attachments

  • debug_17709.zip
    591.2 KB · Views: 129
Joined
Jul 2, 2015
Messages
14
Motherboard
Acer 5750G
CPU
i7 2670QM @ 2.2 GHz
Graphics
Intel HD3000 384 MB and GeForce 540M 1GB
Mobile Phone
  1. iOS
Run the macOS installer to restore your system kexts to Apple provided original.

Hi @RehabMan, i restored the Apple original kexts as you suggested.

Do you have other suggestions to solve the issues listed above? In particular the freeze of the Windows Manager since it makes the pc unusable.

thank you for your help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi @RehabMan, i restored the Apple original kexts as you suggested.

Do you have other suggestions to solve the issues listed above? In particular the freeze of the Windows Manager since it makes the pc unusable.

thank you for your help.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jul 2, 2015
Messages
14
Motherboard
Acer 5750G
CPU
i7 2670QM @ 2.2 GHz
Graphics
Intel HD3000 384 MB and GeForce 540M 1GB
Mobile Phone
  1. iOS
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.


Hi @RehabMan,
thank you for your patient!!!

Attached zip file contain the files generated by the script install_tools.sh (which internally calls gen_debug.sh) + EFI directory + the output of the commands kextstat and pmset.

I hope to have done all well.

I am waiting for your replay!

I add that with this same configuration (DSDT, SSDT, config.plist, KEXTs, ...) Sierra seems to run correctly. The issues (shutdown, wake, Windows Manager freeze) occurs whit High Sierra.

Grazie!!!!

Antonio
 

Attachments

  • Problem Reporting Files.zip
    2.8 MB · Views: 113
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi @RehabMan,
thank you for your patient!!!

Attached zip file contain the files generated by the script install_tools.sh (which internally calls gen_debug.sh) + EFI directory + the output of the commands kextstat and pmset.

I hope to have done all well.

I am waiting for your replay!

I add that with this same configuration (DSDT, SSDT, config.plist, KEXTs, ...) Sierra seems to run correctly. The issues (shutdown, wake, Windows Manager freeze) occurs whit High Sierra.

Grazie!!!!

Antonio

Suggest:
- try MacBookPro8,1 or MacBookPro8,2

Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

You forgot to press F4 as per FAQ, "Problem Reporting" (your ACPI/origin files are dated July 5, but today is July 11).
Please read FAQ "Problem Reporting" carefully.
 
Status
Not open for further replies.
Top