Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Apr 26, 2016
Messages
210
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
kgp, how did you connect your nzxt internal USB hub power supply? It has Molex connection, but my power supply doesn't have Molex power supply. Should I use something like on the photo? But then I think it is always 12V, where USB hub needs 5V.
 

Attachments

  • pcie6.jpg
    pcie6.jpg
    24.3 KB · Views: 42
Joined
Mar 26, 2012
Messages
20
Motherboard
MSI X299M GAMING PRO CARBON AC
CPU
i9-7900X
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi All,

Have just set up a system based on this guide, MSI X299M AC CARBON GAMING motherboard and i9-7900, so thought I'd point out a few things:
  • Needed [npci=0x2000] to boot as well as the other boot flags.
  • You can disable the MSR lock in the BIOS (In OC Settings under Advanced somewhere) but I still needed TSRAdjustReset.kext to run stably.
  • I initially used APFS but had some lag which improved after re-installing with an HFS+ system using this method. However lag only completely resolved after reverting to the 10.13.2 NVIDIA WebDrivers. I'm not sure if I could reconvert to APFS now but HFS+ has never let me down.
  • Graphics works well with full acceleration.
  • VoodooHDA worked well for sound, although I'm using a USB headphone amp. I couldn't get AppleALC,kext to work as Lilu.kext seemed to prevent boot.
  • Native HWP and Sleep/Wake are working 100%, although I have to use my power button to wake from sleep, the mouse and keyboard won't work to wake from sleep.
  • Native NVRAM is working as I don't need [NvidiaWeb=true] in config.plist to use the WebDrivers, I can just select them from the NVIDIA menubar app.
  • I delidded my 7900X and get 26℃ idle and 60-65℃ load with OCCT at stock with all-core turbo (4.0GHz x 10) and GeekBench single core of 5399 and multicore 38295, so pretty happy. VRM gets up to 90℃ish so would need a VRM block or at least a fan strapped to the heatsink for more (I'm running a Nepton 240M AIO on the CPU).
  • The SmallTree-Intel-211-AT-PCIe-GBE.kext worked well for the I211 secondary LAN adaptor, the primary I219 was recognised with IntelMausiEthernet.kext as standard.
  • Sensors kexts work well in conjunction with iStat Menus.
  • I can't get any of the PCI devices recognised in System Profiler despite a seemingly-accurate SSDT and the appropriate DSDT patches. I feel like these are cosmetic only so not too fussed.
Overall I'm very happy, this was by far the easiest Hackintosh I've ever built, the most stable/functional, and by far the fastest... Thanks @kgp and all others who've contributed!
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,136
Hi All,
I delidded my 7900X and get 26℃ idle and 60-65℃ load with OCCT at stock with all-core turbo (4.0GHz x 10) and GeekBench single core of 5399 and multicore 38295, so pretty happy. VRM gets up to 90℃ish so would need a VRM block or at least a fan strapped to the heatsink for more (I'm running a Nepton 240M AIO on the CPU).

That sounds pretty high, 65C is what I get with a 7980 with all cores running at 4GHz with a 115i pro watercooler.
 
Joined
Apr 26, 2016
Messages
210
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
How am I getting 100
That sounds pretty high, 65C is what I get with a 7980 with all cores running at 4GHz with a 115i pro watercooler.
Why am I getting 100C with Corsair 150i Pro on my i9-7960x? :banghead:
 
Joined
Dec 31, 2013
Messages
635
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
Hi All,
  • I delidded my 7900X and get 26℃ idle and 60-65℃ load with OCCT at stock with all-core turbo (4.0GHz x 10) and GeekBench single core of 5399 and multicore 38295, so pretty happy. VRM gets up to 90℃ish so would need a VRM block or at least a fan strapped to the heatsink for more (I'm running a Nepton 240M AIO on the CPU).
Hi tokyo!!
thanks for your report.
What process did you use to delid?
Did you re-apply the lid using liquid metal?
Did you drop the water block on the die itself?

Thanks for your help!

Luca
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,136
How am I getting 100

Why am I getting 100C with Corsair 150i Pro on my i9-7960x? :banghead:

I too had pretty high temps with the 150i pro, it got much better with the 115i and it's quieter (bigger fans)...

Did you mess up with the thermal paste by any chance?
that's idle in windows
room temp is 22C
Capture.PNG

running cinebench 3 times in a row in windows, the max temp was 71C on one core, all other cores were at 65C
 
Joined
Jul 18, 2014
Messages
73
Motherboard
Asus X299 Prime DeLuxe - 3006
CPU
i9-10980xe
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
  • Like
Reactions: kgp

kgp

Retired
Joined
May 30, 2014
Messages
6,785
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
kgp, how did you connect your nzxt internal USB hub power supply? It has Molex connection, but my power supply doesn't have Molex power supply. Should I use something like on the photo? But then I think it is always 12V, where USB hub needs 5V.

That's what I use and what came with my PSU. A peripheral to Molex cable.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,785
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Joined
Sep 3, 2012
Messages
90
Motherboard
ASUS WS C422 FW PRO/SE
CPU
W-2175
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Mobile Phone
  1. iOS
Hi kgp.
This might be out of topic but I take the risk.
Last week I've bought myself a new rig.
Asus WS C422 motherboard
64GB 2666 Mhz DDR4 ECC Ram (16384 Mb x 4)
Intel Xenon W-2175
My goal was to try to build my own iMac Pro with hardware as near as the original as possible. I have now put up my rig with an old Zalman water cooler, RX Vega 56 graphics and two M.2 1 TB Samsung 950 Evo Pro.
I've followed your very impressive guide just to get some basic information. My problem is that I can't even boot up and install HighSierra. Could you or anybody else out there guide me in the right direction?

The MSR 0xE2 register on my Asus mobo is unlocked with the UEFI-patch according to your guide. I've tried booting with all different combinations of OsxAptioFix-drivers including Test2-2016.efi and the new AptioMemoryFix without success.
My USB-install HighSierra medium is working (tested on my old rig) but I always get stuck during installation ( see atacchment)
Could maybe you kgp shed some light over this problem?
Best regards
obusIMG_0471 copy.jpg
 

Attachments

  • EFI.zip
    19.5 MB · Views: 31
Status
Not open for further replies.
Top