Contribute
Register

[GUIDE] OC 10.13.6 Z490 Gigabyte Aorus Xtreme + Core i5 10400 / i9 11900K + Nvidia GTX 1060

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,865
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
What was your upgrade process? I have the same MB+CPU & was able to replicate your guide successfully for High Sierra. But bootstrapping or upgrading with Catalina doesn't work & open core debugging is unavailable for me to troubleshoot further. (using exact same EFI folder w/appropriate serials/keys gen'd)
here you go:

so you can update your hardware profile properly
 
Joined
May 11, 2011
Messages
1,964
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
What was your upgrade process? I have the same MB+CPU & was able to replicate your guide successfully for High Sierra. But bootstrapping or upgrading with Catalina doesn't work & open core debugging is unavailable for me to troubleshoot further. (using exact same EFI folder w/appropriate serials/keys gen'd)
Which chip are you using (ie. model)? Comet Lake or Rocket Lake? If using Comet Lake you may have to change the AAPL,ig-platform-id to 03009BC5 for Core i9 or 03009BC8 for Core i5. 03 is the iGPU headless mode (you have to enable it in BIOS as Auto). You will also need to change the corresponding device-id in Device Properties to reverse byte order ie. C59B0000 or C89B0000.

In addition you may need to disable Setup > IO Ports > Resizable Bar and enable Rocket Lake Thunderbolt if using the latest firmware. For AMD cards you’ll need to add shikigva=128 agpdmod=pikera as boot-args in the NVRAM. For Nvidia you could try no boot-args other than alcid=7 value or shikigva=256.

I would try sticking with OC 0.6.5 with Catalina for the time being because 0.6.8 has some sticky issues booting with Catalina.

Make sure your AppleEvent is set to Builtin and not OEM.

Also I’d advise you should keep your UUID the same (because it is your main Disk’s UUID).

When you change the config.plist or use my EFI do not forget to boot with it first, reset your NVRAM by pressing the space bar and selecting Reset NVRAM before rebooting and selecting the drive again.
 
Joined
Apr 21, 2021
Messages
5
Motherboard
Z490 Gigabyte Aorus Xtreme
CPU
Intel Core i9 11900k 5.2GHz
Graphics
XFX RX 5700 XT, Radeon Vega 64
Which chip are you using (ie. model)? Comet Lake or Rocket Lake? If using Comet Lake you may have to change the AAPL,ig-platform-id to 03009BC5 for Core i9 or 03009BC8 for Core i5. 03 is the iGPU headless mode (you have to enable it in BIOS as Auto). You will also need to change the corresponding device-id in Device Properties to reverse byte order ie. C59B0000 or C89B0000.

In addition you may need to disable Setup > IO Ports > Resizable Bar and enable Rocket Lake Thunderbolt if using the latest firmware. For AMD cards you’ll need to add shikigva=128 agpdmod=pikera as boot-args in the NVRAM. For Nvidia you could try no boot-args other than alcid=7 value or shikigva=256.

I would try sticking with OC 0.6.5 with Catalina for the time being because 0.6.8 has some sticky issues booting with Catalina.

Make sure your AppleEvent is set to Builtin and not OEM.

Also I’d advise you should keep your UUID the same (because it is your main Disk’s UUID).

When you change the config.plist or use my EFI do not forget to boot with it first, reset your NVRAM by pressing the space bar and selecting Reset NVRAM before rebooting and selecting the drive again.

I'm using Intel Core i9 11900k 5.2GHz.

I went back to OC 0.6.5 & all of the advised BIOS settings, but still no luck..
I've attached my OC config, BIOS settings profile & error log produced when I attempt to run the 0.6.5 debug build with recommended logging settings (it gets stuck at prebuiltkernel).


** UPDATE **
Disabling both network interfaces in BIOS got me further. Waiting on upgrade process...
** UPDATE2 **
I was able to boot, but I have no network interfaces (expected) and no longer bluetooth (worked in high sierra)
 

Attachments

  • opencore-2021-05-05-101726.txt
    256 KB · Views: 42
  • BIOS_profile.bin.zip
    1.9 KB · Views: 30
  • EFI.retail.catalina.6.5.zip
    13.9 MB · Views: 40
Last edited:
Joined
May 11, 2011
Messages
1,964
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Okay, I've made changes to your EFI. Try it out and see.
You had some issues. Framebuffer-patch-enabled was missing, picker was Builtin instead of external.
There were too many drivers installed for HFS and others not needed. As you have AMD 5700XT, there was missing AGPMInjector for it. I've also changed the CPUID to EB060900 Coffee Lake. In earlier versions Catalina was still Coffee Lake. Only latest versions after 10.15.6/7 is Comet Lake (afair). And I added vit9696's Intel I255V ethernet patch. Oh and ROM needs to be your Ethernet's MAC address. But I randomly created one. See if it works.
 

Attachments

  • Catc1h22-EFI.retail.catalina.6.5-fixed.zip
    13.7 MB · Views: 43
Joined
Apr 21, 2021
Messages
5
Motherboard
Z490 Gigabyte Aorus Xtreme
CPU
Intel Core i9 11900k 5.2GHz
Graphics
XFX RX 5700 XT, Radeon Vega 64
Okay, I've made changes to your EFI. Try it out and see.
You had some issues. Framebuffer-patch-enabled was missing, picker was Builtin instead of external.
There were too many drivers installed for HFS and others not needed. As you have AMD 5700XT, there was missing AGPMInjector for it. I've also changed the CPUID to EB060900 Coffee Lake. In earlier versions Catalina was still Coffee Lake. Only latest versions after 10.15.6/7 is Comet Lake (afair). And I added vit9696's Intel I255V ethernet patch. Oh and ROM needs to be your Ethernet's MAC address. But I randomly created one. See if it works.

thank you-- this worked :clap:
Now I just have to address a few power/TTL related issues : D
 
Joined
May 11, 2011
Messages
1,964
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Joined
May 11, 2011
Messages
1,964
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Great to hear!

As to your issues:
1) Change your ig-platform-id to
0000C89B for enabling Intel external HDMI - 03 means it is currently running headless mode

2) Change framebuffer-stolenmem to 00003001 and framebuffer-unifiedmem to 000080
This will bring VRAM to 2048MB.

3) For working WiFi in Big Sur you may need the following kexts:

AirportBrcmfixup
BR4LEContinuityFixup.kext
BrcmBluetoothInjector
BrcmFirmwareData
BrcmPatchRAM3
 
Joined
May 11, 2011
Messages
1,964
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Oh and if you want the proper data displayed for your CPU in System Profiler, use the latest version of RestrictEvents.kext.

You will also need to add 3841 under Processor type in SMBIOS page.
 

JBX

Joined
Sep 17, 2016
Messages
118
Motherboard
Gigabyte Z490
CPU
i7-10700
Graphics
RX 580
Hello, I am trying to boot a High Sierra installer thumb drive with your "High Sierra EFI". I get some text come up over the bios gigabyte logo for split second... then stuck at apple logo without a loading bar. My BIOS settings are good with your list on your guide.

I don't understand how to spoof CPU, however I would like to strip board specific kext and entries in the OC config from your EFI that I don't require for my system. I am currently running Big Sur and Catalina latest OC... with a Sapphire RX580 GPU.

This is what I currently use in the latest OC.
ACPI: SSDT-AWAC, SSDT-EC-USBX-DESKTOP and SSDT-PLUG-DRTNIA
Kext: AppleALC, Lilu, IntelMausi, VertuialSMC, USBPorts, and WhateverGReen

Any help would be appreciated.
 
Top