Contribute
Register

[GUIDE] OC 10.13.6 Z490 Gigabyte Aorus Xtreme + Core i5 10400 / i9 11900K + Nvidia GTX 1060

Joined
Aug 1, 2012
Messages
508
Motherboard
Asus Z490 Prime A
CPU
i9-10900K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks! About the UHD 750, I haven't tested it myself yet - but according to the latest Hackintosh ******, those who had tested it said it doesn't work at all (in macOS). Also Acidanthera's latest Whatevergreen updates actually disables macOS booting if the UHD750 isn't disabled in BIOS. So no, it doesn't work as far as I know.

and what about the UHD630 (aka an Intel i9-10850K in my case) in conjunction with a brand new Z590 mb?

I'm testing an Asus Z590-P and everything seems to work properly with the dGPU and iGPU set as headless but I was no able to boot the system with the UHD630 only, it hangs during boot.

OC 0.6.7
macOS 11.2.3
sysdef 20,1/20,2

I can give more info if you need them.
 
Joined
May 11, 2011
Messages
2,264
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
On my Z490 Aorus Xtreme I’ve successfully ran a i5-10500 on Big Sur 11.2.1. using the above EFI. It was set using the Coffee Lake CPUID (reverse byte order) instead of Comet Lake. You could try adding these using OC Configurator in Kernel section:
Cpuid1Data
Code:
EA060900 00000000 00000000 00000000
Cpuid1Mask
Code:
FFFFFFFF 00000000 00000000 00000000
 
Joined
May 11, 2011
Messages
2,264
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
and what about the UHD630 (aka an Intel i9-10850K in my case) in conjunction with a brand new Z590 mb?

I'm testing an Asus Z590-P and everything seems to work properly with the dGPU and iGPU set as headless but I was no able to boot the system with the UHD630 only, it hangs during boot.

OC 0.6.7
macOS 11.2.3
sysdef 20,1/20,2

I can give more info if you need them.

@Azimuth1 try to change your SMBIOS to iMac 18,3 and use CPUID1Data of EA060900 - I find this better suits the 10th gen chip. However I think EB060900 may suit it more (as that is proper Comet Lake ID). Also use Opencore's Sanity Checker to check your config settings if there are any issues.

For the iGPU to work, it needs the device C59B properties added into the config.plist under AAPL,ig-platform-id as 0300C59B, similar to this.

device-c59b.png

You will also need to add a device-id of 9BC50003 to enable Quicksync.

It may also need the disablegfxfirmware as a boot-arg if I recall (or at least just iGPU specific boot-arg settings).
 
Joined
Aug 8, 2019
Messages
2
Motherboard
Acer Aspire VX15
CPU
Intel i5
Graphics
Nvidia 1050
Hello, I'm looking foward to make a hackintosh for my Asus H410i-Plus + 10400 + PNY 970 with High Sierra, what you guys think? Can I success from this guide?
 
Joined
May 11, 2011
Messages
2,264
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Hello, I'm looking foward to make a hackintosh for my Asus H410i-Plus + 10400 + PNY 970 with High Sierra, what you guys think? Can I success from this guide?
Yes I think it can work.
 
Joined
Apr 21, 2021
Messages
5
Motherboard
Z490 Gigabyte Aorus Xtreme
CPU
Intel Core i9 11900k 5.2GHz
Graphics
XFX RX 5700 XT, Radeon Vega 64
Is there a future possibility of getting the network adapters to work or is there something specific that prevents them from operating in OSX?
 
Joined
May 11, 2011
Messages
2,264
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Is there a future possibility of getting the network adapters to work or is there something specific that prevents them from operating in OSX?
If you use the right kexts for the specific adapters (which I did), the network adapters technically should work. For now the built-in WiFi 6 adapter works using the Open Intel Wireless drivers as well as the optional Apple USB Ethernet adapter. The only issue I'm having is that the two main ethernet ports (2.5GBe & 10GBe) are detected but aren't working due to some device enumeration issue so @CaseySJ is currently looking into the issue for me.
 
Joined
May 11, 2011
Messages
2,264
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Alright, just thought I'd update you guys on some progress I've made. I have been working on this build recently and with the latest Big Sur and Opencore updates I have managed to get it updated to the latest 11.3 with OC 0.6.8. and corrected some issues I'd before.

The setup can now boot with most macOS including High Sierra, Catalina and latest version of Big Sur. Here are some of the highlights so far:

BIOS - updated to latest F20 for Z490 Aorus Xtreme (20/04/21)
Comet Lake & Rocket Lake CPU compatible

High Sierra 10.13.6 & Catalina 10.15.7

- ACPIs corrected, HS build now fully working
- OC 0.6.5. bootloader
- iGPU can now be enabled in BIOS
- Working Aquantia 10Gbe port
- Working Intel AX201 WiFi6
- Coffee Lake CPUID CPU & GPU configuration (no VDA decoding yet)
- Intel IGPU detected in macOS, no Intel Quicksync
- Nvidia Pascal fully working on High Sierra, limited VESA support on Catalina
- Booting from Thunderbolt now possible

Big Sur 11.3

- ACPIs corrected
- OC 0.6.8 bootloader
- iGPU can now be enabled in BIOS
- Working Aquantia 10Gbe port
- Working Intel 2.5GBe port via vit9696's patch
- Working Intel AX201 WiFi6
- Intel IGPU detected in macOS, no Intel Quicksync
- Comet Lake CPUID CPU & GPU configuration (no VDA decoding yet)
- Limited Nvidia VESA support on Big Sur
- Booting from Thunderbolt now possible
- USB ports mapped with USB Port

EFI files are below. Simply add your board serials and UUIDs and ROM to use.
 

Attachments

  • EFI for High Sierra.zip
    12.9 MB · Views: 114
  • EFI for Catalina.zip
    12.9 MB · Views: 70
  • EFI for Big Sur.zip
    23.8 MB · Views: 92
Joined
Apr 21, 2021
Messages
5
Motherboard
Z490 Gigabyte Aorus Xtreme
CPU
Intel Core i9 11900k 5.2GHz
Graphics
XFX RX 5700 XT, Radeon Vega 64
FYI I've just updated the EFI for the board with the latest Lilu, AppleALC and Whatevergreen updates as well as corrected the audio settings (boot-arg for ALC1220VB was missing). Also added a new update footnote. The EFI setup can now run Mojave, Catalina and Big Sur.
What was your upgrade process? I have the same MB+CPU & was able to replicate your guide successfully for High Sierra. But bootstrapping or upgrading with Catalina doesn't work & open core debugging is unavailable for me to troubleshoot further. (using exact same EFI folder w/appropriate serials/keys gen'd)
 
Top