Contribute
Register

[Guide] Lenovo ThinkPad T440

Joined
Sep 8, 2019
Messages
11
CPU
Core i5 4300U
Graphics
Intel Graphic HD 4000
@sir-hciassak thank you so much! the issue seems present because i forgot install patch SSDT-ALC3232.aml :D
 
Joined
Jan 7, 2019
Messages
2
Motherboard
Asus H97M-Plus
CPU
i5-4670
Graphics
GTX 950
I will post a problem reporting post soon, but in the meantime, has anybody had issues with the laptop just getting stuck with the spinning beach ball of death? Also, having some graphics issues when connecting with a external monitor: managed to get a report on the Intel HD panicking and when in use, the screen flickers with static with around 15 second intervals.

Many thanks to Sniki and everybody, this "Macbook" is an awesome machine!
Alright, hope i'm attaching everything ok!
 

Attachments

Joined
Sep 8, 2019
Messages
11
CPU
Core i5 4300U
Graphics
Intel Graphic HD 4000
@sir-hciassak could u toggle microphone by Fn+F4 key? today I try to turn off mic by this but it was not working.
 
Joined
Oct 13, 2019
Messages
1
Mac
MacBook Pro
Mobile Phone
Android
Hi, Thanks for the guide,
I've installed it and works flawless.
But I have 1 problem, my battery shows 0% after I unplug it from the adapter. Then if I plug the adapter again, It says "Battery not charging". (My point is my battery seems not detected).
Any suggestion here? Thank you.
 
Joined
Apr 18, 2019
Messages
3
CPU
i5-4200M
Graphics
HD4600
Hi. I make all according this guide except "Whitelist Removal" but sound and ACPI does not work.
 

Attachments

Joined
Apr 18, 2019
Messages
3
CPU
i5-4200M
Graphics
HD4600
My 3 buttons touchpad does not work well too.
 
Last edited:
Joined
Oct 25, 2019
Messages
1
Hi, Thanks for the guide,
I've installed it and works flawless.
But I have 1 problem, my battery shows 0% after I unplug it from the adapter. Then if I plug the adapter again, It says "Battery not charging". (My point is my battery seems not detected).
Any suggestion here? Thank you.
Do you have the 3 button trackpad or the flat one? if you have the 3 does it work the same as a macbook with the gestures i can only get certain gestures to work others dont respond what kext are you using for it?
 
Joined
Jan 19, 2018
Messages
112
Motherboard
Asus Z390-A Prime
CPU
i5-8400
Graphics
UHD 630 / RX 560
Mobile Phone
Android
After successfully running my T440 with Mojave 10.14.5 for a while using @Sniki 's files for T440 at Github, I ran into the following situation and eventually becoming problem:
1. I had a "Replace Battery Soon" in my battery indicator.
2. With that, I accidentally run the machine until the battery fully drained.
3. Recharging and turning back on, the battery does not work properly, i.e. charging unusually (and unrealistically) quick unlike its usual charging rate.
4. The machine then not able to restart. If I put the system to restart, it took longer until the Thinkpad logo shows, but after that the system stays with Thinkpad logo and not continue with booting. I then have to do a hard shutdown via the power button.
5. I then made a fresh install of 10.14.5, but the problem persist. However, after fresh install, the battery indicator seems to be ok even if the "Replace Battery Soon" still shows.
6. Tried to restart, but the result still the same, i.e. cannot boot from restart. However, shutdown works OK, sleep also works fine.
7. When in Clover Boot Manager, i get the computer to restart from Clover, and the system restarts successfully. Therefore I think the machine itself still OK, but this problem comes from the macOS.
8. Attaching the debug files.

Any hint on what I need to do?

Thanks.
Hello @Sniki
I would like to come back to my above problem on my T440.
To describe a little bit more about my restart problem:
1. Shutdown works normal as it should be. Apple Logo - Shutdown and the computer shuts down the way it usually is.
2. When I want to restart, i.e. Apple Logo - Restart (or whatever restart procedure required after installing a program, here is what happens:
a. macOS goes black screen as usual.
b. then comes the usual "brick" voice from the speaker (as it was always the case when my Thinkpad was able to restart previously).
c. then the screen keeps black for quite some time (longer than I remember it was used to be when restart works normally).
d. then the Thinkpad logo comes out.
e. usually, in quick succession, comes the "To interrupt setup, please Enter", but this time it took quite some time (almost around 1 minute).
f. then the system does not move from this Thinkpad logo.
g. comes the power button to the rescue, shutting down the system.
h. when turning the system ON again, macOS boot goes normal.

This happen after I accidentally leave my Thinkpad and drain the battery. I have tried to do clean install in hope of clearing the problem, but it is still the same. Thus, I think this is not the macOS problem. Should I do EC reset? Then clear CMOS? Then another fresh install?

Thanks.
 

Attachments

Top