Contribute
Register

[Guide] Dell Inspiron 15 7559 (Skylake, i7-6700HQ, Intel HD 530) Using Clover

Joined
Oct 20, 2015
Messages
234
Motherboard
Xiaomi Air 13
CPU
Intel i5-6200u
Graphics
Intel HD 520
...And nothing more...
Try installing Clover 3354 to get the correct Intel HD 530 showing up. You can use the latest Clover as soon as Clover 3530 is out. The battery will most likely also improve if you get a compatible WiFi/Bluetooth card.
 
Joined
Jan 8, 2013
Messages
86
Motherboard
Dell Inspiron 15 7559
CPU
Intel Core i7 - 6700HQ
Graphics
HD 530 & GTX 960m
Classic Mac
iBook
Mobile Phone
Android
Try installing Clover 3354 to get the correct Intel HD 530 showing up. You can use the latest Clover as soon as Clover 3530 is out. The battery will most likely also improve if you get a compatible WiFi/Bluetooth card.
In my clover settings it also says Intel Unknown, so maybe thats all i need to update (I'm on the latest clover).

You might also be right about the wifi card
 
Joined
May 6, 2016
Messages
11
Motherboard
Dell 0H0CC0
CPU
i7-6700HQ
Graphics
dual graphics Intel HD 530 / GeForce GTX960M 4GB
Mac
MacBook Air
I've redone my bios several times. Downgrading to 1.1.3 then upgrading to 1.1.5, default bios then making sure to disable secure boot. Actually, i say that but it doesn't revert secureboot even when i do that. I'm out of ideas really.
 
Joined
Oct 18, 2013
Messages
5
Motherboard
os x 10.9
CPU
1230 v3
Graphics
HD5750
Mac
Classic Mac
Mobile Phone
Thank you very much for sharing. But I have to disconect the power adapter and USB devices to start every time. Do you have this problem?
 
Joined
Oct 20, 2015
Messages
234
Motherboard
Xiaomi Air 13
CPU
Intel i5-6200u
Graphics
Intel HD 520
Thank you very much for sharing. But I have to disconect the power adapter and USB devices to start every time. Do you have this problem?
Yes, you won't be able to boot with power cord connected. you can plug it in as soon as you see the apple boot logo.
 
Joined
Oct 20, 2015
Messages
234
Motherboard
Xiaomi Air 13
CPU
Intel i5-6200u
Graphics
Intel HD 520
I've redone my bios several times. Downgrading to 1.1.3 then upgrading to 1.1.5, default bios then making sure to disable secure boot. Actually, i say that but it doesn't revert secureboot even when i do that. I'm out of ideas really.
Try to do the same as user geboe did. He encountered also many issues before booting into the installer.
 
Joined
May 6, 2016
Messages
11
Motherboard
Dell 0H0CC0
CPU
i7-6700HQ
Graphics
dual graphics Intel HD 530 / GeForce GTX960M 4GB
Mac
MacBook Air
Try to do the same as user geboe did. He encountered also many issues before booting into the installer.
only thing they tried that i haven't is unhooking the hard drive (assuming factory hard drive) but no one else has had to do that. Given where the error is i guess it could be due to a disk, or seemingly just as likely the ram or something in my bios that is reading out wrong
 
Joined
Sep 22, 2012
Messages
613
Motherboard
Gigabyte GA-Z97X-UD5H
CPU
i7-3770K OC @ 4.8GHz
Graphics
GTX 760
I'm having a heck of a time getting audio to work. I did all the DSDT and SSDT edits and everything is working except audio. I removed the AppleHDA_ALC256.kext and reinstalled it and rebuilt kextcache after rebooting without caches. I'm not sure what I'm missing here. I'm quite sure I applied all the patches correctly. Could someone share their functioning DSDT and SSDT edited files?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,063
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm having a heck of a time getting audio to work. I did all the DSDT and SSDT edits and everything is working except audio. I removed the AppleHDA_ALC256.kext and reinstalled it and rebuilt kextcache after rebooting without caches. I'm not sure what I'm missing here. I'm quite sure I applied all the patches correctly. Could someone share their functioning DSDT and SSDT edited files?
Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda
Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /
Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Top