Contribute
Register

[GUIDE] Catalina on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - CLOVER & OC

Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I'm not the best person to ask about that. I have 2 NVMe SSDs and 1 SATA SSD in my HP EliteDesk 800 G4 Mini. My default boot drive has CLOVER/macOS. If I want to boot Windows (rarely), I press F9 and select my Windows disk. I do not use Clover to boot windows.
 
Joined
Jun 1, 2020
Messages
16
Motherboard
HP EliteDesk 800 G4 DM 65W
CPU
Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz, 3000 Mhz, 6 Core(s), 6 Logical Processor(s)
Graphics
Intel(R) UHD Graphics 630
I'm not the best person to ask about that. I have 2 NVMe SSDs and 1 SATA SSD in my HP EliteDesk 800 G4 Mini. My default boot drive has CLOVER/macOS. If I want to boot Windows (rarely), I press F9 and select my Windows disk. I do not use Clover to boot windows.

HI,

I can now confirm that having Clover on a different disk is not the problem. I installed Clover also on the same disk and still the same issue - for shutdown and restart, system hangs and i need to press the button and do a hard restart.

Just to see what is exactly happening, i tried booting into single user mode and then rebooted from there. What i see is a kernel panic.

Can you see if you see any clue in the earlier files i attached

Update: I got one more clue now. I tried with your .80 version of files and everything works fine. No issues with shutdown/restart.

Regards,
 
Last edited:
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Can you see if you see any clue in the earlier files i attached

I stopped looking at your debug files after seeing that you have not customized the config.plist with your own serial number / IDs. You can't simply copy and paste the config.plist I provided without customizing your own serial number and other IDs. Please copy the config.plist from the EliteDesk800 archive that I attached to Post #1 in this thread and make sure that the XXX-MASKED-XXX values are set to your own values. You can use Clover Configurator to do this.

EDIT: @tkmanutk Note that I had a bug in one of the config.plist versions that I posted. I had inadvertently "masked" the Board-ID when I was sanitizing the config.plist for public posting. Please use the latest config.plist that I have included in the EliteDesk.zip archive attached to Post #1, because it has the correct Board-ID for the MacMini8,1.

EDIT2: @tkmanutk The config.plist that you posted here has a bug that I introduced in an earlier version of the config.plist that I posted. I had inadvertently deleted the framebuffer value AAPL,ig-platform-id in the posted version. It wouldn't surprise me if this missing AAPL,ig-platform-id was causing the problem you saw and why you don't see the problem with a newer version of my config.plist.

I apologize for my screw-up. This thread is still a work in progress and I have not yet converted it into a guide. Using the material I post in this thread is going to require a degree of knowledge and experience to check my work.
 
Last edited:
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
As I was exploring the ACPI from a real MacMini8,1, I noticed a couple of differences that need to be remedied in our HackMini8,1:

  • The real MacMini8,1 ACPI has Device (MCHC). This is easily remedied by enabling "Add MCHC" in Clover's config.plist
  • The real MacMini8,1 ACPI has a different Device (PMCR) than the fake PMCR that is floating around the web. With the fake PMCR version that I found, Device (PMCR) is not loaded (as viewed with IORegistry Explorer). With the "real" Device (PMCR) (from the real MacMini8,1 ACPI), Device (PMCR) is loaded. The "real" Device (PMCR) is below and is injected with the attached SSDT.

    See the attached IORegistry screenshot to see why this new PMCR has an IONameMatch.

Code:
DefinitionBlock ("", "SSDT", 2, "hack", "_PMCR", 0x00000000)
{
    External (_SB_.PCI0, DeviceObj)

    Scope (_SB.PCI0)
    {
        Device (PMCR)
        {
            Name (_HID, EisaId ("APP9876"))  // _HID: Hardware ID
            Name (_STA, 0x0B)  // _STA: Status
            Name (_CRS, ResourceTemplate ()  // _CRS: Current Resource Settings
            {
                Memory32Fixed (ReadWrite,
                    0xFE000000,         // Address Base
                    0x00010000,         // Address Length
                    )
            })
        }
    }
}
 

Attachments

  • SSDT-PMCR.zip
    616 bytes · Views: 34
  • Screen Shot 2020-06-08 at 4.49.32 PM.png
    Screen Shot 2020-06-08 at 4.49.32 PM.png
    35.5 KB · Views: 41
Last edited:
Joined
Jun 1, 2020
Messages
16
Motherboard
HP EliteDesk 800 G4 DM 65W
CPU
Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz, 3000 Mhz, 6 Core(s), 6 Logical Processor(s)
Graphics
Intel(R) UHD Graphics 630
I stopped looking at your debug files after seeing that you have not customized the config.plist with your own serial number / IDs. You can't simply copy and paste the config.plist I provided without customizing your own serial number and other IDs. Please copy the config.plist from the EliteDesk800 archive that I attached to Post #1 in this thread and make sure that the XXX-MASKED-XXX values are set to your own values. You can use Clover Configurator to do this.

EDIT: @tkmanutk Note that I had a bug in one of the config.plist versions that I posted. I had inadvertently "masked" the Board-ID when I was sanitizing the config.plist for public posting. Please use the latest config.plist that I have included in the EliteDesk.zip archive attached to Post #1, because it has the correct Board-ID for the MacMini8,1.

EDIT2: @tkmanutk The config.plist that you posted here has a bug that I introduced in an earlier version of the config.plist that I posted. I had inadvertently deleted the framebuffer value AAPL,ig-platform-id in the posted version. It wouldn't surprise me if this missing AAPL,ig-platform-id was causing the problem you saw and why you don't see the problem with a newer version of my config.plist.

I apologize for my screw-up. This thread is still a work in progress and I have not yet converted it into a guide. Using the material I post in this thread is going to require a degree of knowledge and experience to check my work.
Thank you for explaining this.

I did a fresh installation using the latest zip, also configuring the SMBIOS attributes using Clover configurator. The hanging issue at restart/shutdown is still there. I am observing the same happening right from installation phase. Each time the setup restarts also it is hanging and i have push the power button and restart.

Another feedback is i am using USB to connect to an external Audio DAC. I am noticing USB audio frequently breaking in between.

Regards,
 
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have attached a detailed itemization of my HP EliteDesk 800 G4 Mini BIOS configuration to Post #1 in a PDF document titled "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf."
 
Last edited:
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
The real MacMini8,1 ACPI includes Device (PPMC); however, PPMC does not appear to be "loaded" in a real MacMini8,1 IORegistry. I'm not sure what Device (PPMC) does, but the SSDT to inject this device is attached.
 

Attachments

  • SSDT-PPMC.zip
    588 bytes · Views: 37
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have updated the EliteDesk800.zip archive attached to Post #1 of this thread. See revision history here for an explanation of the changes.

This continues to be a work in progress. I am doing my best to make sure that my solutions are accurate and complete; however, this solution is not a step-by-step guide for novices and still requires a degree of knowledge and experience to confirm my proposed solutions and configuration files.
 
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
*** Deleted ***
 
Last edited:
Joined
Sep 22, 2011
Messages
1,081
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
When first configuring my Clover config.plist, I enabled "ResetHDA" (Devices > Audio Properties). It does not appear that this is necessary. This change is included in the EliteDesk.zip archive attached to Post #1.
 
Last edited:
Top