Contribute
Register

[Guide] Booting the OS X installer on LAPTOPS with Clover

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Sorry but I'm new in hackintosh. In config.plist file I should find #DropTables and remove from it # ?
Edit your plist with a plist editor (Xcode, PlistEdit Pro), never a text editor. Then follow the instructions in post #1. It is quite clear, and there is no reason for me to repeat here.
 
Joined
Jan 4, 2016
Messages
29
Motherboard
Dell Vostro 3350 (Clover Legacy)
CPU
i5-2410M
Graphics
Intel HD 3000 (1366x768)
Mobile Phone
Android, iOS
some minutes after selecting the install icon(bo verbosth in verbos and non) i face splash or broken.in verbos i saw it wrote something like no bluetooth detected and splash came up.:banghead:
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
some minutes after selecting the install icon(bo verbosth in verbos and non) i face splash or broken.in verbos i saw it wrote something like no bluetooth detected and splash came up.:banghead:
Boot verbose, show photo. Post EFI/Clover folder as ZIP (omit 'themes' folder).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have used every possible combination of boot flags to start up el capital but I am still unable to boot up el capital installation. I have the latest clover installed
Boot verbose, show photo. Post EFI/Clover folder as ZIP (omit 'themes' folder).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
You did not follow the guide correctly:
- drivers64UEFI is missing OsxAptioFixDrv-64.efi.
- GenericUSBXHCI.kext may not be a good choice (you should focus on using USB2 flash media in USB2 port)
- your profile does not include screen resolution. Therefore, no way to know if your config.plist is correct.

But "still waiting for root device" indicates a USB problem. Try all USB2 ports, use USB2 media.

See also additional USB solutions: http://www.tonymacx86.com/el-capitan-laptop-support/173616-guide-10-11-usb-changes-solutions.html
 
Joined
Jan 4, 2016
Messages
29
Motherboard
Dell Vostro 3350 (Clover Legacy)
CPU
i5-2410M
Graphics
Intel HD 3000 (1366x768)
Mobile Phone
Android, iOS
You did not follow the guide correctly:
- drivers64UEFI is missing OsxAptioFixDrv-64.efi.
- GenericUSBXHCI.kext may not be a good choice (you should focus on using USB2 flash media in USB2 port)
- your profile does not include screen resolution. Therefore, no way to know if your config.plist is correct.

But "still waiting for root device" indicates a USB problem. Try all USB2 ports, use USB2 media.

See also additional USB solutions: http://www.tonymacx86.com/el-capitan-laptop-support/173616-guide-10-11-usb-changes-solutions.html
i have removed config.plist and added "config_HD3000_1366x768" and renamed it to config.plist. did i find something wrong?
my laptop has just one usb2 and 2 usb3 ports.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i have removed config.plist and added "config_HD3000_1366x768" and renamed it to config.plist. did i find something wrong?
No idea... As written in my previous response, your profile does not provide information on your screen resolution.

Read post #1 regarding the correct way to place hardware details in your profile.

my laptop has just one usb2 and 2 usb3 ports.
The USB3 ports are not likely to be supported. Use only the USB2 port.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I was able to boot into el capital, set up my keyboard, choose language, set up internet. I get past the internet set up screen and then a dark gray screen appears then the spinning car wheel and then my computer restarts. My laptop restarts everytime i boot into my target hard drive.
No need to setup internet when in the installer (unnecessary risk).

Boot verbose, show photo. Post EFI/Clover folder as ZIP (omit 'themes' folder).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,692
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I got past that internet setup screen, after I selected this mac does not connect to ethernet.
Make sure you have the correct Ethernet drivers installed. See links in FAQ.

Also, during post-installation part of the guide, when installing clover to the hard drive, do I select the same options for clover hard drive as I did for clover USB ?
Yes. All setup must be the same (config.plist, HFSPlus.efi, drivers64UEFI, kexts, etc).
 
Top