Contribute
Register

ALC898 Audio Installation on macOS Sierra.

Status
Not open for further replies.
Joined
Apr 10, 2014
Messages
35
Motherboard
Gigabyte Z87X-UD7TH
CPU
Intel i5 Haswell
Graphics
Nvidea GT640
Mac
Classic Mac
Mobile Phone
  1. Android
I have a Gigabyte UD7 w/ dual thunderbolts running Intel HD4600 integrated graphics. I recently upgraded the machine to macOS Sierra which is booting normally and for the most part working well. I am in a spot of trouble trying to install the kext for the ALC898 6 port integrated sound card. Steps I took were as follows:

1. Manually copy the HDAEnabler1.kext from Toledo to /System/Library/Extensions
2. Use the kextcache command to rebuild the caches. I don't remember the exact two commands I supplied. I googled it.

Upon rebooting into macOS and finding that the integrated sound card is still not recognized by macOS Sierra I decided to copy the kext to the kexts/other folder of my EFI partition and also modify my config.plist to force load the HDAEnabler1.kext.

Upon booting again into macOS Sierra I found that the ALC898 integrated sound card is still not recognized by macOS Sierra.

Has anyone successfully installed said ALC898 audio on macOS Sierra? Is there a known set of instructions available for this card? Does anyone know where I've gone wrong? I read the sticky for Realtek Audio in this macOS Sierra forum however they are talking about an ALC120 not an ALC898.

Thank you.
 
Last edited:
Joined
Apr 10, 2014
Messages
35
Motherboard
Gigabyte Z87X-UD7TH
CPU
Intel i5 Haswell
Graphics
Nvidea GT640
Mac
Classic Mac
Mobile Phone
  1. Android
The script does work for the ALC898. One just has to terminal: diskutil mount disk0s1 (EFI) and then run the script. Upon rebooting into macOS Sierra I found the internal ALC898 sound card to be in working order. I'm chasing an iTunes freezing issue with iTunes Radio on the latest update of iTunes with the system now.
 
Joined
Apr 10, 2014
Messages
35
Motherboard
Gigabyte Z87X-UD7TH
CPU
Intel i5 Haswell
Graphics
Nvidea GT640
Mac
Classic Mac
Mobile Phone
  1. Android
The iTunes freezing problem goes away when I install a GTX640 graphics card and boot to macOS. It sounds like the issue is graphics related. Some extra configuration was necessary to boot the GTX640 only nvidea_enable=1 and check the box for InjectNvidea with Clover Configurator and then save your plist onto the EFI partition of the boot drive.
 
Joined
May 6, 2014
Messages
10
Motherboard
Gigabyte GA-Z87X-UD7 TH
CPU
i7-4770K
Graphics
HD 4600
Hi sepoto,

I have the same problem as you had, could not install the integrated sound card (Intel ALC898) and HDMI audio (Intel HD 4600) on my Gigabyte Z87X-UD7 TH after upgrade to macOS Sierra. I still tried Multibeast installation, and also HDAEnabler1.kext from Toleda (https://github.com/toleda/audio_RealtekALC), but did not get it running (EFI always was mounted). I think there are a lot other guys dealing with this issue.
Could you maybe describe in detail how you got it running?
Would be nice to get some help!

Best!

drstilpunkt
 
Joined
Apr 10, 2014
Messages
35
Motherboard
Gigabyte Z87X-UD7TH
CPU
Intel i5 Haswell
Graphics
Nvidea GT640
Mac
Classic Mac
Mobile Phone
  1. Android
The time I got it working I put HDAEnabler1.kext from Toleda into System/Library/Extensions and rebuilt with kextcache command at the terminal put a force load for HDAEnabler1.kext into clover config.plist and then after all that I ran the script ALC_120 that is duly noted in the macOS Sierra desktop sticky in the support forum. I did get audio to come out of line in on macOS Sierra but I havn't duplicated the situation yet.
 
Joined
May 6, 2014
Messages
10
Motherboard
Gigabyte GA-Z87X-UD7 TH
CPU
i7-4770K
Graphics
HD 4600
After a lot of trial and error this is how it worked for me permanently.

Hope this may help you!

Best!
 
Joined
Mar 28, 2011
Messages
20
Motherboard
Asus Prime Z370-P
CPU
i5-9400F
Graphics
RX 570
Mobile Phone
  1. iOS
drstilpunkt... I followed your instructions as per above, steps 1-3 above... and got my audio back.

However every now and then, I'm getting the error " System extension cannot be used. The system extension "/Library/Extensions/HDAEnabler1.kext" was installed improperly and cannot be used."

Any idea how to fix this please?

Thanks.
 
Joined
Jun 9, 2013
Messages
10,682
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
After a lot of trial and error this is how it worked for me permanently.

Hope this may help you!

Best!

Why are you using HDAEnabler with (Clover Audio Injection?)
 
Status
Not open for further replies.
Top