Contribute
Register

Stork's MyHero Build: ASUS ROG Z170 MAXIMUS VIII HERO - i7-6700K - GTX 980

pastrychef

Moderator
Joined
May 29, 2013
Messages
7,801
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thank you very much pastrychef.
You have also help me with your config.file.
Since I have been getting hardware acceleration,I have not been able to open final cut pro,it's always quit unexpectedly.
But now I can open it and work with it.
More grace,more ideas in 2019.
And more money in your account.

My mobo is haswell.
Intel core i7 4770k
Gigabyte z97m - ud5h
Amd Rx580
32gb ram
Ssd 1tb.

I use it media encoding..
But if you still have support for me please do.
Happy New year.
i7-4770K and Z97M are off topic for this thread... Please start a new thread and I'll try to help as best I can.
 
Joined
Jan 3, 2019
Messages
10
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
Hello Stork, thanks for an amazing guide I have the same exact processor and motherboard and successfully installed high Sierra, but when I turn on the power the hard drive doesn't boot automatically into the EUFI drive that the OS is installed on I have to always manually go from the bios > boot menu > select other OS drive before I get into my hackintosh. Also I have a Nvidia gtx 980 that I installed the web driver before restarting the system after the installation and it isn't being recognized. I also get a couple fan error when the bios loads. Any help would be appreciated.
 

Attachments

Joined
Jan 3, 2019
Messages
10
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
P.S not sure if it caused an issue, but, when I created the UniBeast drive, I didn't select inject Nvidia graphics, because I was going to install Nvidia drivers before restarting after the main installation.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,548
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@WarMachine,
It looks like you didn't choose the MultiBeast option as I recommended in Post #1:
Bootloaders -> Clover UEFI Boot Mode + Emulated NVRAM​

Your UniBeast choice was correct. The Inject > Nvidia is for older cards as the explanation states.
 
Joined
Jan 3, 2019
Messages
10
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
@WarMachine,
It looks like you didn't choose the MultiBeast option as I recommended in Post #1:
Bootloaders -> Clover UEFI Boot Mode + Emulated NVRAM​

Your UniBeast choice was correct. The Inject > Nvidia is for older cards as the explanation states.
@Stork Thanks for your response, I actually took a picture of my MultiBeast settings, and I did select Clover UEFI Boot Mode + Emulated NVRAM. I also noticed an "A0 q code" on the board after I updated the BIOS; I'm going to clear the CMOS and set all the BIOS settings again. I fixed the CPU fan error by placing it in the correct port on the board. As for the Nvidia GTX 980, I read I should only plug it in after the web driver is installed. I had it plugged in the whole time during the High Sierra install.
 

Attachments

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,548
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@WarMachine, I've never removed my Nvidia GTX cards when I did an install. So, don't go through the effort to take out and reinstall the GTX 980.
 
Joined
Jan 3, 2019
Messages
10
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
@WarMachine, I've never removed my Nvidia GTX cards when I did an install. So, don't go through the effort to take out and reinstall the GTX 980.
@Stork I just wanted to update you on the build, I moved the dark rock pro fan plug from OPT fan to CPU fan, and the the drive boots straight to Clover now and the BIOS CPU fan error is gone. All I need now is to get this Nvidia GTYX 980 to work, and I'm all set, any suggestions that don't involve a fresh install?
 
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,548
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@Stork I just wanted to update you on the build, I moved the dark rock pro fan plug from OPT fan to CPU fan, and the the drive boots straight to Clover now and the BIOS CPU fan error is gone. All I need now is to get this Nvidia GTYX 980 to work, and I'm all set, any suggestions that don't involve a fresh install?
Nope. Refresh me...can you now boot into macOS and get to the Desktop?
 
Joined
Jan 3, 2019
Messages
10
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
@Stork Yes, I can now boot into macOS and get to the desktop without any issues. When I go into the BIOS under graphics, it doesn't show the GPU in the first PCI-e slot, the BIOS doesn't detect it at all. I also tried setting primary display to PEG and still nothing.
 
Joined
Jul 25, 2016
Messages
157
Motherboard
ASUS Z170 ROG MAXIMUS VIII HERO-2202
CPU
i7-6700K
Graphics
GTX 970
Mac
MacBook Pro, Mac Pro
Classic Mac
Classic, iBook, iMac
Mobile Phone
iOS
Dear My Hero lovers,

Just a quick heads up for the latest High Sierra security update 2018 (003).
In case you wonder, why the update didn‘t work OOB (at least on my build): It doesn‘t matter, if you are updating from the MAS or directly from the downloaded DMG. After applying, you need to boot into the installler in the Clover menu. (In my case 2x after a reboot). After that, you can d/l the newest NVIDIA driver and things run smooth again.

I‘m writing this, because until High Sierra, every security update runs automatically on my build from beginning to finalisation without going to the Clover procedure. Strange...

Best
M.
 
Top