Contribute
Register

[SOLVED] Kernel Panic after Upgrade

Joined
Aug 15, 2011
Messages
30
Motherboard
ASUS Z170-PRO
CPU
Skylake i7 6700k
Graphics
ASUS GTX 1080 Ti Strix
Mobile Phone
iOS
My Situation:
After updating to High Sierra 10.13.4 from Sierra, I keep running into a kernel panic on boot. I can still boot to macOS with safe boot, but no luck without the -x flag.

My limitations:
• I can't access my boot drive's EFI partition when in safe boot.
• What I can do is access my unibeast flash drive's EFI partition through my spare hackintosh.

What I've done/tried with no success:
• Updated to the latest nVidia web driver (the one for 10.13.4).
• Updated Lilu.kext.
• Booting with webdrivers and then with VESA drivers, made no difference.
• Booted with iGFX, get a black screen after BIOS, can't get into clover.

Kernel Panic Details:
The kernel panic scrolls by at light speed. I was able to record it in slow motion with my iPhone, and enhance it with Premiere, although it's still a bit blurry.



A million thanks to anyone willing to help! Let me know if you need any other details.



-----------------------------------
SPECS
-----------------------------------
Processor: i7 6700k
Motherboard: ASUS Z170-Pro
GPU: ASUS GTX 1080Ti
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,553
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Joined
Aug 15, 2011
Messages
30
Motherboard
ASUS Z170-PRO
CPU
Skylake i7 6700k
Graphics
ASUS GTX 1080 Ti Strix
Mobile Phone
iOS
On my flash drive's EFI Partition:
• So I checked Lilu.kext's package contents and opened info.plist with text edit. From what I could tell it was the latest version of Lilu which is 1.2.3
• Just in case I re-downloaded it from
https://github.com/vit9696/Lilu/releases here and replaced it. I got the same kernel panic.

On my SSDs EFI Partition:
• I got an idea, and ghetto rigged my SSD to my working hackintosh. Erika, I was able to access its EFI partition. When I checked the Lilu.kext info there, instead of being 1.2.3 it was 1.0.0.

• I replaced that Lilu.kext 1.0.0 with 1.2.3 and... same kernel panic when attempting to boot off the SSD's clover.
(Although what I did discover is that with totally different hardware I was still able to boot into macOS in safemode on my working hackintosh which has integrated graphics, and no GPU.)

Discoveries:
• I'm fairly convinced Lilu.kext is not the culprit.
(I have a theory it shows up as 1.1.6 in verbose mode, but is still 1.2.3? Don't know for sure, just a guess.)

• I don't think the kernel panic is cause of a hardware incompatibility
(since it got the same kernel panic on two different machines, but was still able to boot in safe mode on both machines as well.)
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,553
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
You have an old version in :
/EFI/CLOVER/kexts/Other/ (or one of the /EFI/CLOVER/kexts/10. folders).
or /Library/Extensions/
or /System/Library/Extensions/
or cached.
 
Last edited:
Joined
Aug 15, 2011
Messages
30
Motherboard
ASUS Z170-PRO
CPU
Skylake i7 6700k
Graphics
ASUS GTX 1080 Ti Strix
Mobile Phone
iOS
You have an old version in :
/EFI/CLOVER/kexts/Other/ (or one of the /EFI/CLOVER/kexts/10. folders).
or /Library/Extensions/
or /System/Library/Extensions/
or cached.
Oh holy heck, you were right! So glad you thought of that. It turned out it was using the Lilu.kext from /Library/Extensions. I was able to boot on my working hackintosh without safeboot! Right now each time I start up my machine, i'm confronted with a "Your computer restarted because of a problem. Press a key or wait to continue." but at least I can get in without safe boot. I'll keep you updated with how it's going. Can't thank you enough!
 
Joined
Aug 15, 2011
Messages
30
Motherboard
ASUS Z170-PRO
CPU
Skylake i7 6700k
Graphics
ASUS GTX 1080 Ti Strix
Mobile Phone
iOS
You have an old version in :
/EFI/CLOVER/kexts/Other/ (or one of the /EFI/CLOVER/kexts/10. folders).
or /Library/Extensions/
or /System/Library/Extensions/
or cached.
Yup! Just hooked my SSD back up to my main hackintosh... and it works perfectly! Even that "Computer restarted because of a problem" message went away. I'm so happy! Thanks a million!

Conclusion:
Lilu.kext was totally the culprit.
 
Top