Contribute
Register

[Solved] easy fix for black screen after Clover update (10.11)

Joined
Apr 21, 2014
Messages
12
Motherboard
Gigabite Z87MX-D3H
CPU
i5 4670K
Graphics
GTX 660
Edit: See post below for fix

Hello all,

Introduction: I updated clover because I was still running 10.11 and thought about an update. As my computer was identified as an older Mac Pro, OSX didn't let me update straight away. So I updated Clover, and guess what... Black screen after Clover screen on booting.

Been reading a lot of topics and found this thread with a really helpful walk through to replace OsxAptioFix2Drv-64.efi. Not my daily walk in the park, but with the explanation it should be doable.

But when I select Shell in the Clover screen something strange happens


I get in the Shell, but the Shift key on my keyboard is not functioning. Whenever I hold the shift key, pressing another key doesnt do anything. I can write in capital using the caps lock, but for opening the disks I really need the 'colon' :)).



I've already tried changing the XHCI mode in the bios but neither Auto, Disable or Enable works and plugging the keyboard in a 2.0 or 3.0 port doesn't help either.

Unfortunatly, it's this older Apple keyboard (picture for reference) is the only keyboard i've lying around, so I won't be able to test another one. When I plug it in my Macbook, the shiftkey does work. So it doesn't seem te be hardware related.



I'm a bit out of options right now, because I can't find another solution to get my computer back to life other than following the step by step explanation by MissCatD, but can't even get started with it without being able to use a colon in Shell.

Who can be my saviour? Thanks!
 
Last edited:
Joined
Apr 21, 2014
Messages
12
Motherboard
Gigabite Z87MX-D3H
CPU
i5 4670K
Graphics
GTX 660
Solved!

Only in a different way.

I already ordered an extra ssd to make a clean installation when this problem couldn't be solved tomorrow and when looking up how to do that, I stumbled upon a very good explanation how to do that using clover. It described how to make a bootable USB with a clover instal and and explanation which options to choose during instalation of clover on the usb. It specificaly mentioned the OsxAptioFixDrv-64 and some useful kexts. I thought that I could try to boot my hackintosh with that usb and guess what, it worked! I was able to start up my computer and reïnstall Clover on my computer, this time with the OsxAptioFixDrv-64 option checked and the above mentioned kexts copy'ed to the EFI drive. Now it works like it did before, only my boot screen looks different thanks to a newer version of clover.

Maybe this is al very logical to the X86-diehards, but for a not so technical person like me, it can be very hard to find solutions, due to the fact that a lot of information is taken for granted, which for me is usually not the case. Anyhow, I'm probably stupid, i'm buying a real Mac next time and hope most of all someone else finds this thread helpful!
 
Joined
Nov 12, 2014
Messages
2
Motherboard
Asus Z-97 Deluxe
CPU
i5 ~ 4690K
Graphics
HD 4600
Mac
iMac
Classic Mac
Power Mac
Mobile Phone
iOS
Do you have a link to that fix? the link in your post is Dead. I myself would like to resolve the same issue. Just Efi Optifix. Crap Don't want to do it the long way with MissCD info. Was hoping for a link in your thread but still No easy fix. Mojave out tomorrow. So Why do terminal work when I can just wait for patches 24 hours from now and Do a Clean install of Mojave
 
Joined
Jan 24, 2017
Messages
1
Motherboard
ASRock HS110M-HDS
CPU
i7-6700K
Graphics
GTX 1080
I am having the same issue with the Shift key not working in the UEFI Shell. I can type lower-case, press caps-lock and type upper-case, but nothing is typed when I try holding either shift key down. I have tried two different USB keyboard (non-mac specific) in front and back ports on the PC. Any thoughts on how to remedy this?
 
Joined
Oct 26, 2015
Messages
5
Motherboard
I still didn't read
CPU
the RULES
Graphics
so ignore me
Solved!

Only in a different way.

I already ordered an extra ssd to make a clean installation when this problem couldn't be solved tomorrow and when looking up how to do that, I stumbled upon a very good explanation how to do that using clover. It described how to make a bootable USB with a clover instal and and explanation which options to choose during instalation of clover on the usb. It specificaly mentioned the OsxAptioFixDrv-64 and some useful kexts. I thought that I could try to boot my hackintosh with that usb and guess what, it worked! I was able to start up my computer and reïnstall Clover on my computer, this time with the OsxAptioFixDrv-64 option checked and the above mentioned kexts copy'ed to the EFI drive. Now it works like it did before, only my boot screen looks different thanks to a newer version of clover.

Maybe this is al very logical to the X86-diehards, but for a not so technical person like me, it can be very hard to find solutions, due to the fact that a lot of information is taken for granted, which for me is usually not the case. Anyhow, I'm probably stupid, i'm buying a real Mac next time and hope most of all someone else finds this thread helpful!

link not working
 
Joined
Sep 21, 2017
Messages
6
CPU
Intel Core i5-7260U
Graphics
Intel Iris Plus Graphics 640 Graphics
Having the same issue. Tried it with wireless and wired keyboards, Mac and PC keyboards. Without the shift key, no colon. Without the colon, can’t select a drive. Would love any insights into this.
 

csw

Joined
Apr 29, 2013
Messages
28
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX580
Solved!

Only in a different way.

I already ordered an extra ssd to make a clean installation when this problem couldn't be solved tomorrow and when looking up how to do that, I stumbled upon a very good explanation how to do that using clover. It described how to make a bootable USB with a clover instal and and explanation which options to choose during instalation of clover on the usb. It specificaly mentioned the OsxAptioFixDrv-64 and some useful kexts. I thought that I could try to boot my hackintosh with that usb and guess what, it worked! I was able to start up my computer and reïnstall Clover on my computer, this time with the OsxAptioFixDrv-64 option checked and the above mentioned kexts copy'ed to the EFI drive. Now it works like it did before, only my boot screen looks different thanks to a newer version of clover.

Maybe this is al very logical to the X86-diehards, but for a not so technical person like me, it can be very hard to find solutions, due to the fact that a lot of information is taken for granted, which for me is usually not the case. Anyhow, I'm probably stupid, i'm buying a real Mac next time and hope most of all someone else finds this thread helpful!
would love to see more detail on your solution.
 
Joined
Nov 12, 2014
Messages
2
Motherboard
Asus Z-97 Deluxe
CPU
i5 ~ 4690K
Graphics
HD 4600
Mac
iMac
Classic Mac
Power Mac
Mobile Phone
iOS
I have an Asus Z-97 DeluxeNFC,WLC with i5~4690K/BCM94.XX combo wifi Bluetooth native to MacBook. I have tried to install Mojave. I crashed High Sierra. I HAVE BEEN ON THIS SINCE SEPTEMBER9TH . 4 WEEKS IN AND 63 RELOADS. ALL AWARD BIOS SETTINGS ARE IRRELEVANT. ALL. the only thing that prevents High Sierra from Booting is Limit CPU ID Maximum . everything else Does Not affect GOOD INSTALL of High Sierra or prevent booting or any issues. the only way I can boot this thing is with Clover2.4k 4259 Build everything before Doesn't see AFS. and everything after Causes Video issues , Black Screen, No mouse, No Keyboard,etc. All the problems I have are Normal on Forums on this site for anyone who Has above Clover 4.259. Multi beast I never use it causes same issue since Mavericks. I have HDMI plugged into HDMI port. Nothing external , only thing I have is a conversion card with BCM94.XX combo wifi Bluetooth native to MacBook. everything works fine .Dealt with drives showing external .etc... Lost network interfaces installing kexts. rebuilt Net Stack.. over 200 hours of research Nothing works after Clover 2.4K 4259 Build from 10-17!!! I have been booting from USB install drive since 2014. No problems until I got to High Sierra and Clover build above listed. I use the archive ,Get Unibeast 8.0.0 and create install disk. Boots Tonymacx86 theme. as New one embedded is Ultra Bright. Everything is Fine...Just Don't touch anything above 4259 clover. I used Kext beast . tried upgrade, restore, Time machine, New install ,even had to use El Capitan installed on 8 gig Flash drive to run for a week. On the install page TonyMacX86 lists Unibeast 8.3.2 But actual file that opens shows 8.3.1. even info tag shows 8.3.2? Which contains Clover 2.4K 4428 Build which again causes video issues. Regardless Clover 2.4K Build 4259 is The answer for me without writing My own code. Not a Rant, just Info for Others. The End. Alternate info I installed the public beta of Mojave(direct upgrade) and it ran. But Clover build Caused issues then crashed.
 
Joined
Nov 8, 2013
Messages
60
Motherboard
Gigabyte Z370M D3H
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
128K, Color Classic, Portable, Power Mac, PowerBook, SE/30
Mobile Phone
iOS
I get in the Shell, but the Shift key on my keyboard is not functioning. Whenever I hold the shift key, pressing another key doesnt do anything. I can write in capital using the caps lock, but for opening the disks I really need the 'colon' :)).
I am having the same issue with the Shift key not working in the UEFI Shell.
Having the same issue. Tried it with wireless and wired keyboards, Mac and PC keyboards. Without the shift key, no colon. Without the colon, can’t select a drive. Would love any insights into this.
I come from this thread where I was having the exact same issue of the shift key not working in the Clover shell. Looks like it's a bug in recent Clover builds. I found this post during my search that put me in the right direction. Just install an older Clover build on a usb stick and boot from there. In my case build r4411 did the trick. I don't know how this could impact your particular issue, though…
 
Top