Contribute
Register

[solved] BCM94352Z - UX430UA Sierra 10.12.6 wifi not working

Status
Not open for further replies.
Joined
Nov 19, 2015
Messages
107
Motherboard
MSI GS65 Stealth Thin 8RF
CPU
i7-8750H
Graphics
UHD630, GTX1070
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
S/L/E folder is not the same as L/E folder. Maybe that is the issue?

Here’s what my main disk partitions look like.

Applications
EFI Backup folder
Library < Extensions >
System < Library/Extensions >
Users

I think this is an area people get confused about and or relay incorrectly. If Rehabman suggested you place them in L/E and you placed them in S/L/E this could explain a failed result. These two Extensions folders work differently and a fix in one may not work in the other folder.

RehabMan is responsible for many, many, hackintosh solutions (not only on this site but many others) that allow “us” end users the ability to run macOS on our systems. When it comes to laptops and other small form factor systems you will be hard pressed to find a more knowledgeable person than he. If you follow his directions and most importantly provide your crash reports “problem reporting” as requested you may be able to find a proper solution for your system but also help others with a similar setup.

Please take a deep breath and relax, this is a friendly site with a positive and a very helpful cast of Members, Moderators, and Admins. Let’s keep hackintosh fun, it can and (in my opinion) should be challenging, but fun and rewarding as well. Try not to take things too personally.
Dude did try both XD those kexts only work in clover/other !!
 
Joined
Nov 19, 2015
Messages
107
Motherboard
MSI GS65 Stealth Thin 8RF
CPU
i7-8750H
Graphics
UHD630, GTX1070
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
and I can ,make difference between LE/SLE since SLE is only visible after you enable hidden folders !
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,438
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
and I can ,make difference between LE/SLE since SLE is only visible after you enable hidden folders !
in terminal:

open /System/Library/Extensions

will open the folder for you
 
Joined
Nov 19, 2015
Messages
107
Motherboard
MSI GS65 Stealth Thin 8RF
CPU
i7-8750H
Graphics
UHD630, GTX1070
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
in terminal:

open /System/Library/Extensions

will open the folder for you
oh boy and I thought I am crazy ?? Are you blind ? I know where she it docent work this way !!!!!!!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,438
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
oh boy and I thought I am crazy ?? Are you blind ? I know where she it docent work this way !!!!!!!
no, I am not blind, my vision is just great thanks

although I am not sure what it is you are trying to say, would you like to repeat in English?
 
Joined
Nov 19, 2015
Messages
107
Motherboard
MSI GS65 Stealth Thin 8RF
CPU
i7-8750H
Graphics
UHD630, GTX1070
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
I am trying to say that moving kexts for this wifi card in ether SLE or LE docent work they only work if they are in Clover Other folder stop sending people in to the wrong place did you understand it now or you need translation !!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,438
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I am trying to say that moving kexts for this wifi card in ether SLE or LE docent work they only work if they are in Clover Other folder stop sending people in to the wrong place did you understand it now or you need translation !!
I have the same card, the kexts work fine in /Library/Extensions

But as you keep failing to upload your problem reporting files, then no one is't going to be able to help you

so calm down and upload your files
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,572
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I am trying to say that moving kexts for this wifi card in ether SLE or LE docent work they only work if they are in Clover Other folder stop sending people in to the wrong place did you understand it now or you need translation !!

This may be true for you and your system configuration. What works for you may or may not work for others. If it's working that's good you should be happy.
 
Joined
Jan 9, 2014
Messages
117
Motherboard
Gigabyte H270M-DS3H
CPU
Core i7-7700K 4.2 Ghz
Graphics
Nvidia GT660 2GG
Mac
  1. iMac
I had troubles with wifi, laptop is also Asus, but bit bigger N752VX.
Updated lately Sierra to the last 10.12.6 version and by the same as well Clover boot loader.
For surprise wifi did not work anymore. Took hours to find out the problem and there is the
conclusion, don’t never install multiple things at same, always do step by step…
Actually Sierra update did not break anything, seems Clover has a bug, but it wasn’t my first
suspicion.
My BCM94352Z works so far with these 4 common Sierra patches + fakeiids (early worked well with Clover r4035 boot loader). Now I did install latest Clover r4359 and wifi not worked anymore (wifi icon on the titlebar informed that wifi hardware not installed). Started test step by step early boot loader versions, like r4334, r4330 - no progress, nothing worked.
After installation of Clover r4297 my wifi started work again. Obviously there is bug inside of the
newer boot loaders … or it’s just the bad luck of combination Clover + hardware (bios + wifi card), but
from the other hand nothing was left to test, laptop runs already latest bios….
Does anyone met also similar behaviour ? That boot loader update broke wifi ?
So, just for information, if anyone struggling with non-working wifi, it will be also good to test different Clover versions.
Attached screenshot from my wifi card ident. Now BCM94352Z works with Clover r4297.

Edit. Kexts were always installed S/L/E (also now).
 

Attachments

  • Screen Shot 2017-12-29 at 05.49.01.png
    Screen Shot 2017-12-29 at 05.49.01.png
    70.9 KB · Views: 121
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I had troubles with wifi, laptop is also Asus, but bit bigger N752VX.
Updated lately Sierra to the last 10.12.6 version and by the same as well Clover boot loader.
For surprise wifi did not work anymore. Took hours to find out the problem and there is the
conclusion, don’t never install multiple things at same, always do step by step…
Actually Sierra update did not break anything, seems Clover has a bug, but it wasn’t my first
suspicion.
My BCM94352Z works so far with these 4 common Sierra patches + fakeiids (early worked well with Clover r4035 boot loader). Now I did install latest Clover r4359 and wifi not worked anymore (wifi icon on the titlebar informed that wifi hardware not installed). Started test step by step early boot loader versions, like r4334, r4330 - no progress, nothing worked.
After installation of Clover r4297 my wifi started work again. Obviously there is bug inside of the
newer boot loaders … or it’s just the bad luck of combination Clover + hardware (bios + wifi card), but
from the other hand nothing was left to test, laptop runs already latest bios….
Does anyone met also similar behaviour ? That boot loader update broke wifi ?
So, just for information, if anyone struggling with non-working wifi, it will be also good to test different Clover versions.
Attached screenshot from my wifi card ident. Now BCM94352Z works with Clover r4297.

Edit. Kexts were always installed S/L/E (also now).

No bug in Clover. Change in Clover is intentional.
Name=AirPortBrcm4360 will not work, must be com.apple.driver.AirPort.Brcm4360
 
Status
Not open for further replies.
Top