Contribute
Register

[solved] BCM94352Z - UX430UA Sierra 10.12.6 wifi not working

Status
Not open for further replies.
Joined
Apr 21, 2012
Messages
273
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Hi,

I've installed newset 10.12.6 and my wifi stopped working.
Is not visible in SystemReport->Wi-fi.
Bluetooth works fine.

I've tried refresh kext cache, files permisssion etc.. but stil no luck.
It worked on betas but now it doesn;t work.
All patches applied in Clover.

any ideas?
 

Attachments

  • CLOVER.zip
    6.5 MB · Views: 142

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,201
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi,

I've installed newset 10.12.6 and my wifi stopped working.
Is not visible in SystemReport->Wi-fi.
Bluetooth works fine.

I've tried refresh kext cache, files permisssion etc.. but stil no luck.
It worked on betas but now it doesn;t work.
All patches applied in Clover.

any ideas?
all those kexts in kexts/other should really be installed to System/Library/Extensions or Library/Extensions
 
Joined
Apr 21, 2012
Messages
273
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
all those kexts in kexts/other should really be installed to System/Library/Extensions or Library/Extensions

i don;t know, i always(Maximus, G551JX Asus, and until today this build laptop) put everythig only in EFI instead od S/L/E
 
Joined
Sep 9, 2011
Messages
935
Motherboard
HP 250 G5 (81EF) Clover UEFI
CPU
i3 5005u
Graphics
HD 5500 (1366x768)
Mobile Phone
  1. Android
Yes. Install the kexts to /S/L/E so they will be included in the kernel cache. I did the same mistake, but I learnt. :)
 
Joined
Apr 21, 2012
Messages
273
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
it didn;t fix it too ;( still no wifi
in kextstat i see driver

Code:
69    0 0xffffff7f81bdf000 0x7bd000   0x7bd000   com.apple.driver.AirPort.Brcm4360 (1150.12.1a1) BB3626FA-A579-348F-AF69-3249DAC7949D <68 67 66 65 12 7 6 5 4 3 1>

it worked fine for over month on 10.12.5 and 10.12.6 betas, but now... don;t get it ;(
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,201
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Apr 21, 2012
Messages
273
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
ok, i've added all files.
I've moved kexts back to Clover EFI because as i said nothing changed when i put them to S/L/E

Thx
 

Attachments

  • Gulios-UX430UA.zip
    7.1 MB · Views: 74

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,201
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
ok, i've added all files.
I've moved kexts back to Clover EFI because as i said nothing changed when i put them to S/L/E

Thx
read post 2, about kexts, they need to be installed to system for them to function correctly
 
Joined
Apr 21, 2012
Messages
273
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
read post 2, about kexts, they need to be installed to system for them to function correctly

so you don't put any kext in EFI/CLOVER/kext/ ?
hard to understand this because my Maximus hack works fine only with EFI, same second Asus G551JX.

As i wrote, when i put kexts to /L/E or S/L/E nothing changes so i think it's not a problem with drivers localizations
 
Joined
Apr 21, 2016
Messages
1,011
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
so you don't put any kext in EFI/CLOVER/kext/ ?
hard to understand this because my Maximus hack works fine only with EFI, same second Asus G551JX.

As i wrote, when i put kexts to /L/E or S/L/E nothing changes so i think it's not a problem with drivers localizations
Put only mandatory kexts in EFI/Clover/kexts/other (like FakeSMC, VoodooPS2, Ethernet kext)
All of the kexts (including those mandatory kexts) should be installed to S/L/E, or L/E (your choice)
Make sure you have config.plist/SystemParameters/InjectKexts=Detect.
 
Status
Not open for further replies.
Top