Contribute
Register

Sidecar

Joined
Jul 19, 2013
Messages
17
Motherboard
10.8
CPU
q9300
Graphics
HD6850
Mac
Classic Mac
Mobile Phone
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.
I am building a new machine with the same motherboard as you. Can you share your EFI? plz
 
Last edited by a moderator:
Joined
Jul 8, 2010
Messages
12
Motherboard
ASUS TUF X299 Mark II
CPU
i7-7820K
Graphics
Vega 64
Mac
MacBook Pro
Classic Mac
Color Classic
Mobile Phone
Android, iOS
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.
I`m using X299 with Vega64.
Sidecar is working with wired only.

EDIT
Soon after that, I was test Sidecar with wireless, It worked.
But, iPad screen was choppy.

My SMBIOS is iMac19,2.
 
Last edited:
Joined
Apr 18, 2011
Messages
492
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
MacBook Pro
Mobile Phone
iOS
I`m using X299 with Vega64.
Sidecar is working with wired only.

EDIT
Soon after that, I was test Sidecar with wireless, It worked.
But, iPad screen was choppy.

My SMBIOS is iMac19,2.
Does it look very compressed and glitchy?
 
Joined
Oct 28, 2015
Messages
7
Motherboard
Gigabyte Z370-HD3P
CPU
i7-8700K
Graphics
Vega 64
Classic Mac
iBook, iMac
Mobile Phone
iOS
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.
I got mine working too on a similar setup, do you happen to have DRM working too though? iTunes, amazon prime, Netflix etc?
 
Joined
Oct 10, 2012
Messages
34
Motherboard
GA Z77X-UP5 TH
CPU
i7-3770K
Graphics
RX 590
Mac
MacBook Air
Mobile Phone
iOS
Hello, my Hackintosh don't show my iPad Pro 10.5 - I updated it and updated the Mac. My iGPU is enabled and the Intel QuickSync is working. I can't even make it work with cable... Bluetooth and Wifi are working.. Handoff Continuity and Airdrop works...
View attachment 429577

EDIT: Sidecar working perfectly, with cable and without it :)
Can you please give a step by step of what you did to make it work. Thanks
 
Joined
Jun 12, 2019
Messages
18
Motherboard
GA-170X UltraGaming
CPU
i5-6500
Graphics
RX 560
Mobile Phone
iOS
Can you please give a step by step of what you did to make it work. Thanks
In my experience I had to edit my custom USBInjectAll.aml again, after the Catalina update and then it works flawless.
 
Joined
Jun 12, 2019
Messages
18
Motherboard
GA-170X UltraGaming
CPU
i5-6500
Graphics
RX 560
Mobile Phone
iOS
Sorry for the dumb question.. how did you edit you USBinjectall. could you please share the steps. Thanks


I followed the first guide but the second is the newest, so you should go for it, correct USB implementation is one of the main problems to fix
 
Joined
Sep 13, 2017
Messages
31
Motherboard
Acer Travelmate P-249-M/5070-Clover
CPU
i3-6006U
Graphics
HD 520, 1366x768
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS, Other
Hello, Everyone

Problem
- SideCar is Not Working

System
Model - Acer TravelMate P249M (Laptop)
SMBIOS- MacBookPro 13,1
CPU- intel i3 6006U 6th Gen Dual-Core 1.99 GHz
RAM- 8GB DDR4
GPU- Intel HD 520 1536MB
SSD- 128GB HDD- 1TB
OS- MacOS Catalina 10.15.0

Device
iPad 9.7inch 5th Gen ipadOS 13.3

~ iGPU Option is not available in BIOS Not Sure On/Off
~ When i connect ipad through cable its not appear in SideCar Menu

Thanks.
 

Attachments

Top