Contribute
Register

Sidecar

Joined
Jan 23, 2019
Messages
187
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
I did a new installation of Catalina, compared to the one I had from tests starting from the first beta.
The procedure I used was this:

1) I cloned my disk with Mojave updated to the latest release of 10.14.6 on another SSD.
2) Through the App Store I asked to get Catalina and after downloading 8.09Gb I asked for the installation.

Everything went smoothly, thanks also to the refinement of the EFI and the configuration made in the beta to try to make everything work.

To my surprise I discovered that with SMBIOS in 19.1 and therefore iGPU activated I have Sidecar working as before and as I expected, but on Safari there are no sites with DRM (Prime video, etc ...), otherwise the system crashes (in the last betas no longer crashed), but the big surprise was to see that with Crome the quality of sites with DRM became the maximum, whereas before it was only in low quality.

So from now, assuming that my PC does not change its mind (but in that case I will update), there are no limitations to using the SMBIOS configuration closer to that provided for my hardware, nor need to go through patches or terminal commands. For those with similar hardware configurations it can be a viable route.

Greetings to all
 
Last edited:
Joined
Jun 26, 2014
Messages
108
Motherboard
ASUS Prime X299 Deluxe II
CPU
i9-9920X
Graphics
Radeon RX 6900 XT
You can use that:


That is the more stable situation that I found...

My tests:

iMac Pro1,1 do not work (black screen due T2).
iMac 17.X and upper... Work with IGPU enabled, but I cannot use Netflix or Prime video.
Mac Pro 6,1 work with patch without IGPU.

So I changed my configuration to Mac Pro. The only thing is the bad quality streaming "compression" :(

No WhateverGreen (I will try with it).

i try to set my smbios to macpro6,1 and patch sidecar.

yes, i can click sidecar to connect my ipad mini 5 but it warning : The device timed out.

so i opened VideoProc to check. H264 hardware decoder ok, HEVC unavailable.

any solution for that issue? thanks.
 
Joined
Dec 27, 2015
Messages
9
Motherboard
Gigabyte GA-H97M-D3H
CPU
i7-4790
Graphics
Vega 56
Mobile Phone
  1. iOS
What do you use instead of whatevergreen?

Nothing in Clover, but I see Whatevergreen in my /Library/Extensions folder...

Actually I've updated Whatevergreen in Clover and /L/E

Hello,
That's the same for me: iMac Pro only shows a black screen, even the pencil is correctly reconized.
The patch works with MacPro 6,1
And I have an old configuration: CPU 4820K (Ivy Bridge) and X79 mobo. Graphic card more recent: RX 570
I think this is the reason why the (relatively) bad streaming connection, the Ivy Bridge CPU cannot decode HEVC properly.

Cannot encode*

I don't know if our dGPU (Vega 56 in my computer) can encode HEVC and we can force to use dGPU... Or if we can change the streaming preset (like OBS or something like that)...

i try to set my smbios to macpro6,1 and patch sidecar.

yes, i can click sidecar to connect my ipad mini 5 but it warning : The device timed out.

so i opened VideoProc to check. H264 hardware decoder ok, HEVC unavailable.

any solution for that issue? thanks.

HEVC unavailable in my case too.

I don't know about The device timed out, sorry :(
 
Joined
Jun 26, 2014
Messages
108
Motherboard
ASUS Prime X299 Deluxe II
CPU
i9-9920X
Graphics
Radeon RX 6900 XT
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.
 
Joined
Apr 18, 2011
Messages
1,363
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-7900X
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.

Just tried this and it does work except the quality isn't the best. Think there has to be a way we can spoof Sidecar into thinking we're using iMac19,1 instead of iMacPro1,1. Think I'll stick to duet for now :lol:
 
Last edited:
Joined
Dec 27, 2015
Messages
9
Motherboard
Gigabyte GA-H97M-D3H
CPU
i7-4790
Graphics
Vega 56
Mobile Phone
  1. iOS
i managed to make sidecar working.

x299 mb without IGPU

switch smbios to iMac19,1 and bootargs set to shiki-id=Mac-7BA5B2D9E42DDD94 shikigva=40

both h264 & hevc are activated.

sidecar is working.

What about Sidecar stream quality? I will try the shikigva=40
 
Joined
Jan 23, 2019
Messages
187
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
I have to make a sad update to my previous post ...
When I tested the sites with DRM (Prime video etc ...) in the SMBIOS 19.1 configuration I used a series instead of a film (it's a period that I only follow series and I didn't really think about movies), it happened to me to try a movie and unfortunately I had to see that nothing has changed: only low quality.
I'm sorry I gave the wrong news, but I just didn't think there was a distinction between series and films (I don't watch a lot of movies and series, anyway).
I hope that sooner or later a valid solution will come out ...

Greetings to all
 
Joined
Oct 23, 2013
Messages
63
Motherboard
Mac Pro Late 2013
CPU
6-core Xeon
Graphics
AMD D500 (Dual)
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
You can use that:


That is the more stable situation that I found...

My tests:

iMac Pro1,1 do not work (black screen due T2).
iMac 17.X and upper... Work with IGPU enabled, but I cannot use Netflix or Prime video.
Mac Pro 6,1 work with patch without IGPU.

So I changed my configuration to Mac Pro. The only thing is the bad quality streaming "compression" :(

No WhateverGreen (I will try with it).
Will i be able to use this feature on my “real” trash can mac pro?
 
Joined
Dec 27, 2015
Messages
9
Motherboard
Gigabyte GA-H97M-D3H
CPU
i7-4790
Graphics
Vega 56
Mobile Phone
  1. iOS
Will i be able to use this feature on my “real” trash can mac pro?
I think so

Now we need to reach maximum quality x)

Edit: More tests...

The only way to enable HEVC in Vega 56 is using iMac Pro SMBIOS... so we get a black screen in Sidecar (I've read that due T2 Chip...)
 
Last edited:
Joined
Feb 21, 2015
Messages
7
Motherboard
MSI Z370-A Pro
CPU
i7-8700K
Graphics
GTX 1070
Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I cant get Sidecar to work.
I use SMBIOS iMac 18.1 and UHD630 graphics.

I use the same apple ID on both my computer and my iPad pro. Both devices are updated to the latest os.

I see Sidecar in the meny, but I can not activate it....

Edit 1: My computer is connected directly to the router (no wifi), the iPad uses wifi.
I have even tried connecting the iPad through cable (USB), but nothing works.

Do I need to do something else?

Edit 2: It works now. I had to sign out from both my iPad and computer, then sign in again :)
 
Last edited:
Top