Contribute
Register
Joined
Apr 3, 2013
Messages
1
CPU
Intel Core i5-3230M
Graphics
ATI Radeon HD 7670M
Mac
  1. Mac mini
Mobile Phone
  1. Android
Hello!

This is my first post here, even though I've been secretly reading hundreds of them for a while now!
I am planning on writing an installation and general setup guide for the old Toshiba Satellite L850-1RC I own, however I can't manage to fix this issue.

I installed Yosemite with the UniBeast guide and since the screen shows weird glitches when trying to display an animation (authentication boot screen, jumping icons on the dock, etc.) and the resolution is set and locked to 1024x768 however I want it to be 1366x768 (bonus point if I can run it in more than 20fps).
The beast has an i5-3230M with HD Graphics 4000 and an ATI Radeon HD 7670M both I can't deactivate in BIOS. Looking up the "System Report" the Radeon seems to be partially detected (VRAM is supposed to be 1024MB).
System-graphics.png


The bootloader is the latest available version of Chimera (4.1.0), I installed a few basic things with MultiBeast (including Intel Graphics Patch for Mixed Configurations) and my [...].boot.plist reads GraphicsEnabler=No and IGPEnabler=Yes (I tried deactivating the discrete card with GraphicsEnabler=Yes but I got a black screen).
I also tried setting Graphics Mode with 1366x768x32 but it didn't do anything.
In despair, I installed RehabMan's low res HD4000 DSDT patch by scrupulously following his patching guide, in vain.

One would say I am trying too hard to use HD4k but I simply cannot find anything related to this issue with this graphics card that I did not mentioned not working here.
I don't really care which of Intel's or AMD's graphics could work, however I don't think heading toward the Radeon direction is the shortest path.

I can provide the list of things I have installed/done (as I have written them down for the guide) as well as the pieces of furniture I have broken/burned in the last 24 hours of intensive "Maybe that's finally the one!"

I know there still are many things I haven't tried as I am still learning. Are there other ways to disable the discrete card or setting it up correctly? I know Apple provides ATI's drivers but aren't there unofficial ones available?

Many thanks in advance!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,155
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello!

This is my first post here, even though I've been secretly reading hundreds of them for a while now!
I am planning on writing an installation and general setup guide for the old Toshiba Satellite L850-1RC I own, however I can't manage to fix this issue.

I installed Yosemite with the UniBeast guide and since the screen shows weird glitches when trying to display an animation (authentication boot screen, jumping icons on the dock, etc.) and the resolution is set and locked to 1024x768 however I want it to be 1366x768 (bonus point if I can run it in more than 20fps).
The beast has an i5-3230M with HD Graphics 4000 and an ATI Radeon HD 7670M both I can't deactivate in BIOS. Looking up the "System Report" the Radeon seems to be partially detected (VRAM is supposed to be 1024MB).
System-graphics.png


The bootloader is the latest available version of Chimera (4.1.0), I installed a few basic things with MultiBeast (including Intel Graphics Patch for Mixed Configurations) and my [...].boot.plist reads GraphicsEnabler=No and IGPEnabler=Yes (I tried deactivating the discrete card with GraphicsEnabler=Yes but I got a black screen).
I also tried setting Graphics Mode with 1366x768x32 but it didn't do anything.
In despair, I installed RehabMan's low res HD4000 DSDT patch by scrupulously following his patching guide, in vain.

One would say I am trying too hard to use HD4k but I simply cannot find anything related to this issue with this graphics card that I did not mentioned not working here.
I don't really care which of Intel's or AMD's graphics could work, however I don't think heading toward the Radeon direction is the shortest path.

I can provide the list of things I have installed/done (as I have written them down for the guide) as well as the pieces of furniture I have broken/burned in the last 24 hours of intensive "Maybe that's finally the one!"

I know there still are many things I haven't tried as I am still learning. Are there other ways to disable the discrete card or setting it up correctly? I know Apple provides ATI's drivers but aren't there unofficial ones available?

Many thanks in advance!

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Top