Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Apr 12, 2012
Messages
7
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
MacBook Air, Mac Pro
Both GPU's "working" does not mean dGPU is encoding...it will decode but not encode WITHOUT the dummy kext (unless you are using 10.14.5 BETA).
You can prove it to yourself by examining the IOREG WITH and WITHOUT the dummy kext.
See this.

I just recently swapped my Nvidia card with the RX580 in an attempt to upgrade to Mojave 10.14.6. After a fresh install on my i7-3770k setup, I tried so many different things in this thread it's probably better for me to start from scratch. Anyone with a similar setup can share what's their working setting for 10.14.6?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,400
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I just recently swapped my Nvidia card with the RX580 in an attempt to upgrade to Mojave 10.14.6. After a fresh install on my i7-3770k setup, I tried so many different things in this thread it's probably better for me to start from scratch. Anyone with a similar setup can share what's their working setting for 10.14.6?
Unless you previously installed stuff all over the place, odds are that you can avoid a clean install.

I no longer have my Ivy Bridge system but it shouldn't be that hard to get an RX 580 working. Which brand of RX 580 do you have? What version of macOS are you on?

Please post your EFI folder.
 
Joined
Sep 21, 2013
Messages
696
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Classic, iBook, iMac, Power Mac, PowerBook, Quadra, SE/30
Mobile Phone
iOS
@pastrychef
Using the iMacPro 1,1 and disabling iGPU in BIOS and config allows me to use FCPX and the use of "Send to Compressor" from FCPX without crashing. Spacebar-Preview works great. Thanks!
WEG is 1.3.3 and ALC is v1.42. Geekbench 5 scores and Power Gadget shots enclosed... Thanks again; LMK if you want my EFI folder for my system.
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,400
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef
Using the iMacPro 1,1 and disabling iGPU in BIOS and config allows me to use FCPX and the use of "Send to Compressor" from FCPX without crashing. Spacebar-Preview works great. Thanks!
WEG is 1.3.3 and ALC is v1.42. Geekbench 5 scores and Power Gadget shots enclosed... Thanks again; LMK if you want my EFI folder for my system.
All looks good.
 
Joined
Feb 25, 2014
Messages
38
Motherboard
MSI Z87M Gaming
CPU
i5-4650??
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
I just recently swapped my Nvidia card with the RX580 in an attempt to upgrade to Mojave 10.14.6. After a fresh install on my i7-3770k setup, I tried so many different things in this thread it's probably better for me to start from scratch. Anyone with a similar setup can share what's their working setting for 10.14.6?
Radeon cards do not work with ivy bridge. Even a properly configured system will display red or green screen during itunes, Amazon, Netflix playback. Need a Haskell or newer processor.
 
Last edited:
Joined
Feb 25, 2014
Messages
38
Motherboard
MSI Z87M Gaming
CPU
i5-4650??
Graphics
RX 570
Mac
iMac
Mobile Phone
iOS
If Netflix is working in Chrome, does it mean that DRM is working? In Safari, the entire system hangs when I access Netflix.
I think this is an issue with Netflix on safari and an rx480 or 500 series on iMacPro symbios. iMacPro symbios uses Vega cards on real Mac so that is what others have suggested is the issue. I have same problem as you describe but prime videos stream fine in HD on safari. itunes works etc. I’m pretty convinced drm is good and it’s due to some other issue specific to Netflix and the model of the video card.
 
Joined
Sep 21, 2013
Messages
696
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Classic, iBook, iMac, Power Mac, PowerBook, Quadra, SE/30
Mobile Phone
iOS
I think this is an issue with Netflix on safari and an rx480 or 500 series on iMacPro symbios. iMacPro symbios uses Vega cards on real Mac so that is what others have suggested is the issue. I have same problem as you describe but prime videos stream fine in HD on safari. itunes works etc. I’m pretty convinced drm is good and it’s due to some other issue specific to Netflix and the model of the video card.
...Which is goofy because I'm using a 2012 Mac Mini 6,2 via HDMI for my HTPC with Mojave<Safari<Netflix.
 
Joined
Apr 12, 2012
Messages
7
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
MacBook Air, Mac Pro
Unless you previously installed stuff all over the place, odds are that you can avoid a clean install.

I no longer have my Ivy Bridge system but it shouldn't be that hard to get an RX 580 working. Which brand of RX 580 do you have? What version of macOS are you on?

Please post your EFI folder.

Thanks, Pastry Chef.

I'm using an XFX RX580, I've already freshly installed Mojave 10.14.6. I have messed around with EFI and this is what I have now. Probably currently a mess.
 

Attachments

Top