Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
Thank you for this. I'm not quite sure what you mean. Which Kext do I need from your EFI folder and where do I put it?
put this one in /L/E
 

Attachments

Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
Thank you! To be clear, Do I put these in the Macintosh HD system folder or in the Clover EFI folder?
1 archive.. on EFI.. // second in machintoshhd/Library/extension
 
Joined
Aug 28, 2018
Messages
18
Motherboard
Gigabyte Z370 HD3P
CPU
i5 8600K
Graphics
Sapphire RX 590 Nitro+
AMD GVA H264/HEVC encoder/decoder work fine on 10.14.5 up.

VideoProc detect AMD GVA H264/HEVC available not equal to AMD H264/HEVC encoder will work correctly, need SMBIOS iMacPro1,1 to fully enable H264/HEVC encoding features.

Change SMBIOS to iMacPro1,1, make sure DGPU is attached to GFX0.
IGPU QSV HEVC encoder no longer supported on latest Mojave.
Hey @shuhung , firstly thanks for this useful thread :)

I'm trying to get full acceleration on my Sapphire RX 590 Nitro+ and tried to find how to do by myself reading this and other threads but it's confusing me..
Do i have to switch to iMacPro1,1 and disable iGPU and rename PEGP to GFX0 as you suggested here to achieve full acceleration?

You can see my situation from attached screens and EFI, thank you :)
 

Attachments

Joined
Feb 10, 2012
Messages
69
Motherboard
GB Z370-HD3P
CPU
i5 9600K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
512K
Mobile Phone
iOS
Hey @shuhung , firstly thanks for this useful thread :)

I'm trying to get full acceleration on my Sapphire RX 590 Nitro+ and tried to find how to do by myself reading this and other threads but it's confusing me..
Do i have to switch to iMacPro1,1 and disable iGPU and rename PEGP to GFX0 as you suggested here to achieve full acceleration?

You can see my situation from attached screens and EFI, thank you :)
Try all these things and let us know what works!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,800
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Hey @shuhung , firstly thanks for this useful thread :)

I'm trying to get full acceleration on my Sapphire RX 590 Nitro+ and tried to find how to do by myself reading this and other threads but it's confusing me..
Do i have to switch to iMacPro1,1 and disable iGPU and rename PEGP to GFX0 as you suggested here to achieve full acceleration?

You can see my situation from attached screens and EFI, thank you :)
Please disable IGPU in BIOS and try this EFI.

Also, remember to refresh VideoProc by pressing the two arrow semi-circles.
Schermata 2019-10-14 alle 21.42.54.png


Edit:
Forgot to change system definition to iMacPro1,1. Fixed now.
 

Attachments

Last edited:
Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
Please disable IGPU in BIOS and try this EFI.

Also, remember to refresh VideoProc by pressing the two arrow semi-circles.
View attachment 430760
Why to disable IGPU.
SO real imac 19.1 use 9900K . I have same. CPU and should work with IGPU enable.
Everyone use imacpro1.1 and disable iGPU, because are easy way.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
11,800
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Why to disable IGPU.
SO real imac 19.1 use 9900K . I have same. CPU and should work with IGPU enable.
Everyone use imacpro1.1 and disable iGPU, because are easy way.
Opps. I forgot to change your system definition to iMacPro1,1. Please do that.

iMacPro system definition with IGPU disabled will get DRM working consistently.

Edit:
Fixed it.
 
Last edited:
Top