Contribute
Register

Radeon RX 4XX/5XX standalone system, AMDRadeonX4250.kext (GVA support H264) does not support HEVC HW

Joined
Apr 12, 2012
Messages
8
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
  1. MacBook Air
  2. Mac Pro
Radeon cards do not work with ivy bridge. Even a properly configured system will display red or green screen during itunes, Amazon, Netflix playback. Need a Haskell or newer processor.

Yes, I've read somewhere that it would need a Skylake CPU for proper acceleration, but then I've seen Mojave guides for Ivy Bridge and users in this thread having this CPU/GPU combination on their profile. I wouldn't mind not having DRM as long as it can encode fine, I would think that it will still be better than putting the RX580 on my 2010 Mac Pro...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,236
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks, Pastry Chef.

I'm using an XFX RX580, I've already freshly installed Mojave 10.14.6. I have messed around with EFI and this is what I have now. Probably currently a mess.

Quite a few XFX brand video cards do not work well with hackintoshes. I don't remember if the RX 580 is one of them. Search around to see if it's one of the bad ones...

Please try the attached EFI to see if it will help. I changed your system definition to iMac13,2. When I had my Ivy Bridge system, it didn't run right unless I used iMac13,x....
 

Attachments

  • EFI.zip
    17.5 MB · Views: 32
Joined
Sep 19, 2010
Messages
602
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7-4790K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
I think this is an issue with Netflix on safari and an rx480 or 500 series on iMacPro symbios. iMacPro symbios uses Vega cards on real Mac so that is what others have suggested is the issue. I have same problem as you describe but prime videos stream fine in HD on safari. itunes works etc. I’m pretty convinced drm is good and it’s due to some other issue specific to Netflix and the model of the video card.

Yesterday I tried accessing Amazon Prime videos website and it too crashed my system. I'm trying to get a hold of a Vega card to test out if it in fact is an issue with the RX 480/580 cards.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,236
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Yesterday I tried accessing Amazon Prime videos website and it too crashed my system. I'm trying to get a hold of a Vega card to test out if it in fact is an issue with the RX 480/580 cards.

I don't have Netflix so I can't test that, but I know Amazon Prime videos work fine in Safari on both my Z370 and Z390 builds.

I will try to find some time and pull the Vega out of my Z370 built and stick in an RX 560 to see if Amazon videos will work. Maybe later today, maybe tomorrow...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,236
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Yesterday I tried accessing Amazon Prime videos website and it too crashed my system. I'm trying to get a hold of a Vega card to test out if it in fact is an issue with the RX 480/580 cards.

I can confirm that with my RX 560, trying to play Amazon Prime videos in Safari froze the entire system.

Amazon Prime videos play fine when I have my Vega 56 installed.
IMG_0156.jpg
Carnival Row playing with Vega 56 installed. Screenshot is not possible due to HDCP causing the Safari window to appear black.

This on a Z370 system with i5-9400F which does not have an IGPU.


*Side note:
Amazon Prime videos also work fine with Radeon VII.
 
Last edited:
Joined
Sep 19, 2010
Messages
602
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7-4790K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
I can confirm that with my RX 560, trying to play Amazon Prime videos in Safari froze the entire system.

Amazon Prime videos play fine when I have my Vega 56 installed.
View attachment 431162
Carnival Row playing with Vega 56 installed. Screenshot is not possible due to HDCP causing the Safari window to appear black.

This on a Z370 system with i5-9400F which does not have an IGPU.


*Side note:
Amazon Prime videos also work fine with Radeon VII.

Thanks for trying it out. I even tried the new Catalina beta hoping this issue might have been fixed but no luck. I guess I'll have to upgrade the card.
 
Joined
Apr 12, 2012
Messages
8
Motherboard
ASUS Maximus VIII Hero
CPU
i5-6600
Graphics
Vega 64
Mac
  1. MacBook Air
  2. Mac Pro
I can confirm that with my RX 560, trying to play Amazon Prime videos in Safari froze the entire system.

Amazon Prime videos play fine when I have my Vega 56 installed.
View attachment 431162
Carnival Row playing with Vega 56 installed. Screenshot is not possible due to HDCP causing the Safari window to appear black.

This on a Z370 system with i5-9400F which does not have an IGPU.


*Side note:
Amazon Prime videos also work fine with Radeon VII.

So even with your newer CPU, RX560 (or 580) still won't fully function? It's a bit disappointing when 2010 Mac Pro can take RX580 and Hackintosh cannot.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,236
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
So even with your newer CPU, RX560 (or 580) still won't fully function? It's a bit disappointing when 2010 Mac Pro can take RX580 and Hackintosh cannot.

I get full acceleration from the RX 560. Just DRM isn't working.
 
Joined
Feb 25, 2014
Messages
38
Motherboard
MSI Z87M Gaming
CPU
i5-4650??
Graphics
RX 570
Mac
  1. iMac
Mobile Phone
  1. iOS
So even with your newer CPU, RX560 (or 580) still won't fully function? It's a bit disappointing when 2010 Mac Pro can take RX580 and Hackintosh cannot.
i have an i3-8100, b360 mobo, with RX 570 on catalina and amazon prime works fine in Safari. Netflix freezes my system. Apple TV also fine. Hackintool reports VDA Decoder fully supported.
 
Top